Whisperfish - The unofficial SailfishOS Signal client

Whisperfish has its own pinned certificate. Update should be out in some hours that fixes this. Sorry for the inconvenience!

To ease the waiting time, you can watch me babble about Signal, Whisperfish and secure messengers, in a talk that I gave in Lausanne last weekend:

9 Likes

FYI: the reason behind this, is that Signal rightfully does not trust the public CA infrastructure. There’s absolutely no reason for them to trust it either, because they control both the client and the server. Validating the chain against the system trust pool would be a serious privacy issue. Apparently, Signal added this new root CA in January for a transition period, but we missed the commit.

2 Likes

Great last update one hour ago

I have installed it it works :+1::sunglasses:

3 Likes

Same here. I tagged it, it should appear on OpenRepos in an hour or so. If it doesn’t, I’ll manually upload it by noon.

3 Likes

Confirmed! Thanks a lot!

Hi. It works again. :+1:Via storeman I got no update offer. Also not after hours. I directly installed it via OpenRepos. Then it worked as expected. Thanks for your fast support.

1 Like

Interesting! Is that on Sailfish 3.4 by any chance?

I could not install it via Storeman as well (SFOS 4.4). Uninstall and reinstall solved it and it’s now working again.

1 Like

Just to provide a counter point, I got the update via storeman just fine, a couple of hours after rubdos’ post. Xperia 10 III.

1 Like

Is it possible to move Whisperfish data and content to an other phone?
After seven year i have to switch to an other phone an it would be fine when i do not lose the whole conversation.
If the data and content is phone bound a export/import would be nice :smiley:.
Many thanks for a hint or a link to a description if there is one …

Yep, perfectly possible.

  1. Make sure Whisperfish is not running.
  2. Copy these directories to the target device:
  • .local/share/be.rubdos/harbour-whisperfish/
  • .local/share/harbour-whisperfish
  • .config/be.rubdos/harbour-whisperfish
  • and this file: .config/be.rubdos/harbour-whisperfish.conf
  1. Make sure to never start Whisperfish again on the first device, if migration was successful.

Some of those files and directories exist from former migrations and are technically unneeded, but let’s copy them just to make sure :slight_smile:

Also, you may find some trouble seeing attachments if your username changes from nemo to defaultuser. This is expected, sadly, and can only be solved by designing a “proper” export/import procedure.

4 Likes

Hi, after the recent Update of Whisperfish, I re-registered Whisperfish (because the security number of one of my contacts changed so I could not message her anymore). The registration as a secondary device went perfectly normal, but now I am unable to receive messages in a specific group. I can text all of the members in the group perfectly fine, but IN the group I can’t see their messages.

Is this already a known bug? Or have I done something wrong?

To see thumbnails for attachments I can recommend merging contents of ~/.cache/org.nemomobile/thumbnails from old phone to new phone.

1 Like

This is known to me, but not widely to the community, yet.

This is probably a new groupv2 that implements sender keys. Gabriel started working on that literally yesterday, it will take a while before that’s implemented. The good news is, existing groups shouldn’t yet force-upgrade, for now. They take into account the capability level of every present member, and Whisperfish correctly advertises itself as not capable of sender keys yet.

Isn’t slavas MyBackup enough to get data and content?

It should be enough indeed. Same rule applies: don’t start Whisperfish again on the old device after you started it on the new one. Make sure to close Whisperfish before making the back-up.

1 Like

I don’t fully understand that - you say existing groups shouldn’t force-upgrade, but the group which is affected for me has existed for at least 2 years…?

It was upgraded when you re-registered with the official client. They should not force-upgrade as long as there’s an old client, but it will upgrade once there’s only up-to-date clients, however briefly that may be.

Oh. I also need to apologize, I made a mistake when reporting this. I noticed that I can see messages from some of the members, but from most of them I can’t see the messages

1 Like

Yes, I assume those others are still on “regular” sessions, not yet on sender keys. I have yet to figure out how the whole system works, have not had time yet…

1 Like