Whisperfish - The unofficial SailfishOS Signal client

This is so cool dudes!

4 Likes

Glad you enjoy it already. The pictures do already get downloaded and stored in the database, and almost half a year ago I started working on actually displaying them in the app. It’s a bit more difficult than I’d like it too, if it’s to be decent code. I might give it a go again if I can finish the message queue implementation that I now started.

Thank you all for your support!

3 Likes

Actually the share plugin (currently works only on SFOS 4.4) has already been released. It’s a separate RPM file, and you can download it from Openrepos. Making it work on SFOS 4.3 all the way down to 3.4 should be done during the hackathon, too!

And about the camera, there’s an in-app support for camera coming up for the next release, so stay tuned for that!

Ruben is also splitting Whisperfish and the share plugin into separate repositories, so it will be a lot easier to download the correct versions - determined by the Sailfish OS version installed.

4 Likes

Regarding the sqlite symbol conflict, have you tried building againt system sqlite instead of bundled, when building libsqlite-sys?
I’m sorry if this has already been covered, but I’m on mobile and couldn’t find any mentions of this (and unable to use the workaround).

When linking against a SQLite (or SQLCipher) library already on the system (so not using any of the bundled features), you can set the SQLITE3_LIB_DIR (or SQLCIPHER_LIB_DIR) environment variable to point to a directory containing the library. You can also set the SQLITE3_INCLUDE_DIR (or SQLCIPHER_INCLUDE_DIR) variable to point to the directory containing sqlite3.h.

https://crates.io/crates/libsqlite3-sys

1 Like

Yes, we’ve tried against the system SQLcipher before. In fact, the reason that we started shipping our own, was is because of the conflict.

Meanwhile, you haven’t heard from us since the hackathon picture. We accomplished a lot of things, except for one: actually releasing it. Currently, time is a bit short, and I haven’t gotten around the few things I’d like to polish first. Soon™!

8 Likes

Whisperfish beta.10 :tada:

This is a huge release, thanks to the hackathon we did a month ago with @direc85 (see picture at Whisperfish - The unofficial SailfishOS Signal client - #595 by rubdos).

There’s a ton of useful changes for the users, and there’s also a lot of technical debt fixed that will make the next releases even more awesome. Diffstat since beta.9: 127 files changed, 11795 insertions(+), 5464 deletions(-) (and that’s huge)

Changes

Highlights:

  • Registration should work again! Thanks @direc85 and Gabriel Margiani !
  • Cover page is awesome!
  • Typing notifications are cute!
  • Display multiple attachments!
  • Resending failed messages!

This is quite a milestone. The next big milestone will be porting Rust 1.61 to SailfishOS, because that will allow us to further push the dependencies and implement all the new GroupV2 and sealed sending features more easily.

Beta 10 should become available the next few hours on OpenRepos automatically.


@flypig or any other moderator in here, is it an idea to allow me to edit the first post to update the change log? Wiki-style or just to remove the time limit?

16 Likes

Congratulations on the release. What a properly impressive set of improvements, I’m really looking forward to using it :grinning:

Would you be able to ping me a private message with some info to include in the newsletter (e.g. a short explanation of why Whisperfish is important; a description of the update and how your hackathon went; what your future plans are)? I can extract the info from your post here otherwise, but it’d be nice to have a little more context direct from you for users who aren’t so familiar with Whisperfish or Signal.

Unfortunately I don’t have the power to reset the timer. I can convert it to a wiki, but then anyone would be able to edit it. Would that still work?

2 Likes

Expect a DM :slight_smile:

A Wiki is maybe a bit too crazy; are there others who did that in the past? I imagine the community could also positively contribute to it, however.

Great!

I’m not sure if anyone used a wiki for this purpose (we have many wikis used for a variety of things), but I don’t see why not. People are generally very considerate of the wikis I think, so you could add a sign asking only Whisperfish devs to edit it, and I’m sure others would respect that.

I believe the most used wikified opening post is Apps that haven’t been ported to aarch64, and that seems to have worked very well! It was meant to be a collaborative post in the first place, which makes the “use case” a bit different, though. I think it’s worth a try anyway.

4 Likes

Sounds good, let’s try that!

2 Likes

It’s now a wiki. Good luck :smiley:

3 Likes

I’m falling behind but I check and cross reference as much as I can… great work guys!

Unfortunately registration still fails for me. Whisperfish crashes with an exception:

thread 'main' panicked at 'ls command failed to start: Os { code: 2, kind: NotFound, message: "No such file or directory" }', src/model/prompt.rs:155:14

looking at the code the message is misleading as it’s not ls that’s missing, but /usr/bin/sailfish-qml, and that later executable doesn’t exist on my Xperia 10 II with Sailfish 4.4.0.64. What workaround do I need to make this work?

I can file a bug report as well, if you want, but that will probably have to wait a day or two.

@direc85 did we forget to package that file? :blush:

Or did I remove it when I was refactoring something in the RPM? :thinking:

Works for me on xa2 SFOS 4.4.0.64 (32 bit)

sailfish-qml is provided by Sailfish. I’ll have a look at it, probably in sailjail or packaging… The ls is a typo in the error message, whoops :slight_smile:

2 Likes

Trying to figure out if I did something wrong, I see that both the “normal” and the 3.4 clients shows as installed in Storeman.

I know that I explicitly installed the main client the other day and today all I did was update it. i wonder what makes Storeman cunfused.

I will try to remove it and re-install it to see if it helps.

That does not help. They will both show as installed, that’s normal. There’s definitely something wrong at our side!

2 Likes

Ok, I wont do that then :slight_smile:

Wouldn’t it be possible to suffix the 3.4 client rpm/name with -3.4, or similar, to avoid confusion?