Whisperfish - The unofficial SailfishOS Signal client

I re-registered today. After registering, sending messages worked for a short periode of time (I was able to send 3 private messages and 1 group message), but then it stopped working again (same problem as before). I will now leave Whisperfish for 24h and try it again tomorrow

Hmm, this is strange. I tried it yesterday after your post, and it still wasn’t working for me then. But just now I tried it again while trying to capture logs, and this time it did work (contact confirmed receipt).

This might be an A-B testing thing, or partial rollout. If anyone stubles across again, would be nice to see logs.

Today I tried again, and I experienced the same thing. Sending attachments wasn’t working, so I restarted Whisperfish from SSH and tried to capture the log. But this time it again worked fine again :confused:

I also have a question. When a contact uses an emoji, it renders like a box with a cross in it (☒ maybe?). I tried searching for this, but I can’t really find if it is supposed to work or not. I did find a whole section about emoji in this bug report, but it’s not clear to me if this is to support custom emoji only?

I.e. I would expect (basic) emoji to work out-of-the box.

  • Is this a bug, and if so is it already reported or should I report it (I couldn’t find one)?
  • If not, could someone please explain how to get emoji to work (maybe there is a wiki page I missed)?

There may be something going on with attachments on the server side. If you do capture the logs, please make a ticket. Attachments were broken for me too for a while.

Emoji support in Sailfish is limited, and black-and-white only. The box with cross means that the emoji in question isn’t included in the set Jolla provides (or that it’s a skin tone modifier). There are ways to install colored emojis in Whisperfish, please check the Whisperfish wiki for more info.

Sending and receiving attachments not working looks to be a IPv6+DNS issue, not a Whisperfish/Signal issue. That also explains the intermittent nature of the bug occurring or not. Please see this bug report for details - there’s a workaround for the issue, too, if you’re familiar with using the terminal.

I tried sending another picture recently, and I again experienced the same thing. Not working initially, then working when starting from ssh. I am experiencing a similar situation with Fernschreiber. Fernschreiber however gives an error “can’t get stat about the file” when it doesn’t work.

I now suspect that this is maybe something with my specific setup, something to do with permissions somehow?
I’ve symlinked my pictures folder (and other folders) from my home dir to my sdcard, so that I have a continuous backup. So far this has worked great. However when I go to share a picture in whisperfish and I choose “File system” I can only see my homedir, not the sdcard (I can see it if I start whisperfish from ssh). In the homedir, all folders (like pictures) are 0 byte files (but not when started from ssh).

Could the problem be that whisperfish doesn’t have access to the sdcard, so sharing a file from there would never work? Even though e.g. the image picker does see it?

Sounds familiar indeed. Could you test what happens if you devel-su ping cdn.signal.org from the command line? And if it does not work, does the same command with ping -4 cdn...?

1 Like

I verified that sending an image was not working after starting whisperfish from the app drawer. Then I went to the terminal and tried to ping. This worked fine, and it pinged an ipv6 address. Then I tried to ping -4. This time it didn’t work, with the following error:

PING cdn.signal.org ( 56 data bytes
ping: sendto: Network is unreachable

The same error occurs when I try to ping -4 google.com. I don’t know what this means.

But I think it’s more likely a permission problem than a network issue.

@d.geelen, sounds a lot like what direc85 talk about here Whisperfish - The unofficial SailfishOS Signal client - #587 by direc85

I’ve figured it out, so far as the attachments go. I added the RemovableMedia permission to the .desktop file and now I can see the sdcard when I go to browse ‘File System’ and sharing a picture from the picker also works and is shared properly.

For the network stuff I don’t quite know yet, but it looks like maybe ipv4 doesn’t work properly when roaming (not on wifi). But unlike the bug report by @direc85 I have never tried VoLTE yet.


FYI, I’ve added RemovableMedia to the privileges for the next release.


Thanks for sharing this, no wonder I couldn’t send pictures taken with Camera :slight_smile:

Day two of the Whisperfish hackathon!

Since yesterday, @direc85 and I are working very hard on some very necessary features and fixes in Whisperfish.

You can follow our progress on the Brussels 2022 code sprint milestone and follow live on Matrix.


Good luck and all the best. Looking forward to Wisperfish 1.0.


Hi, very cool idea to have a hackathon! I see something on the issue list referencing a ‘share plugin’. What is it, I can’t find much info on it? Is it a way to integrate Whisperfish into the ‘share’ dialog in e.g. camera? Because that would be awesome :smiley:

1 Like

Hi. Thank you for WP 0.6. I used it since several months. It works often very well and as expected. I only miss sometimes some pictures. Especially when they come in via a picture serie.

I’m looking forward to more versions and hope to see the first official version 1.0 soon.

Keep up the good work, rubdos and direc85 :+1:


This is so cool dudes!


Glad you enjoy it already. The pictures do already get downloaded and stored in the database, and almost half a year ago I started working on actually displaying them in the app. It’s a bit more difficult than I’d like it too, if it’s to be decent code. I might give it a go again if I can finish the message queue implementation that I now started.

Thank you all for your support!


Actually the share plugin (currently works only on SFOS 4.4) has already been released. It’s a separate RPM file, and you can download it from Openrepos. Making it work on SFOS 4.3 all the way down to 3.4 should be done during the hackathon, too!

And about the camera, there’s an in-app support for camera coming up for the next release, so stay tuned for that!

Ruben is also splitting Whisperfish and the share plugin into separate repositories, so it will be a lot easier to download the correct versions - determined by the Sailfish OS version installed.