Whisperfish - The unofficial SailfishOS Signal client

Hello @rubdos and Whisperfish team and thanks for you work.

I encountered an interesting “feature” of Whisperfish. I installed the latest alpha from openrepos and linked my number. It worked just fine, I had a couple of direct conversations and one group conversation, which was created by an android user (this was obviously the legacy type group). After a while I wanted to try the android app, which meant that whisperfish was de-authorized, and when I returned to Whisperfish, I had to delete the databases and start from scratch.

I initiated direct conversations with two of the people of were in the previous group conversation, but the group conversation was not visible anymore. I suspect that the group was updated to v2 when I used the android app.

Anyway, the direct messages worked just fine, but interestingly, when the members of the group conversation posted messages in the group, I received these messages in the direct conversation with the poster of the message, as if they were sent directly to me. My messages worked as they should, meaning they were not sent to the group.


Known issue indeed. When WF encounters any message that’s not recognised as something “special”, it’s get shoved in the direct conversation of the sender. GroupsV2 are really something I’d like to tackle next week. Hopefully it’s not too much of a pain :crazy_face:


Heads up, I’ve opened a public icon design contest.

The current application icon has a few issues.

  • We only have it in .png, in fairly low resolution.
  • It’s kinda “busy”, Sailfish OS applications tend to be quite calm.
  • It does not feel like it is Signal-related, although we have to make sure not to come over as Signal-endorsed.
  • Maybe it’s due an update :slight_smile:

I’ve had a previous suggestion via the forum, and had a kind of “contest” in mind. The idea is to source both icon-concepts as well as complete designs from the community. If you submit your icon, you agree that I can distribute it under AGPLv3.


Heads up: elevated reports of ERROR - Failed to setup Signal client during registration (HTTP 402 in the logs). We’re working on this, it’s Signal that requires new registrations to submit a captcha.


Just updated to Sailfish 4 this morning and although I can see the list of my conversations clicking on any of them results in a ‘could not load page’ error. So if any of you are using this app as a direct android replacement you may want to wait to install Koli until this is sorted.

Edit: I also can’t send a new message to anyone…when I click to add a receipient it says ‘no people’.

Indeed, there are some bugs with SailfishOS-4.0. I will try to get these and the registration fixed over the weekend. I posted it on the Release Notes quite early, but I should probably have posted that here too.

Hi again,

wow, it really took me a whole month to get back here … :confused:

Storeman should be installing alpha.6 by now, you might want to check
why that doesn’t update. beta.1 will require SailfishOS 3.3 for minimum,
but there’s no such constraint on alpha.6 and lower.

I just looked into this and tried to install it via command line

Problem: nothing provides libm.so.6(GLIBC_2.29) needed by harbour-whisperfish-

alpha.3 lacks many features and has quite some bugs, please don’t use that any more

I am still using the 0.5 which works fine except receiving images :(. The alpha.3 does not connect to the network, but i have not tried to find out why.

alpha.3 cannot connect to anything. By now we’re on alpha.7 already, so do make sure you’re on the latest!

yes I saw that alpha.7 is out but suspect the problem with the


will be the same. So unless I can upgrade my system to something providing the newer version I will have to stick with the 0.5

Just checked and the problem is indeed still the same.

That’s really weird, what’s your SailfishOS version? I think most of us are on 3.4. If you have the time, we could sync up on IRC or Matrix to get this resolved quickly. There’s barely a reason to stay on 0.5 nowadays.

What Sailfish OS version are you running?

If you are running a version earlier than 3.4.0, and you don’t want to upgrade, you might want to install sfos-upgrade and run sfos-upgrade --verify to make sure your current version is in a consistent state.

1 Like

I am currently running

I do not mind an upgrade if it works :slight_smile: Since it is my daily phone an I (currently) do not have a land line I am a bit cautious. Will install sfos-upgrade and have a look.


Once my gentoo system is again in a clean state, I will install a matrix client and sync up there.

Aha, I don’t think we’ve ever tested WF on anything older than 3.3…

1 Like

FWIF, I’ve been running 3.4 and now 4.0 EA and I can’t recall anything important getting broken since 3.1… I think the newer glibc was introduced in 3.3…

I suggest upgrading anyway (up to 3.4 that is), the older versions have (more) unpatched vulnerabilities. Backup your data, of course :slight_smile:

Yeh, we’re also using some functionality that’s only available starting in 3.3, so even if I wanted to compile against 3.1, it wouldn’t really be possible without backporting some stuff.

1 Like

I have now pushed alpha.8 to OpenRepos, with very minimal changes (current master contains an important performance bug):

Fixes in alpha.8:

  • Many hours have been spent in implementing the reCAPTCHA functionality. It works, with a LOT of thanks to @gamag for figuring out what went wrong and for actually fixing it. Jolla is shipping an old version of sqlcipher, which interfered with qt5-mozembed, and we now ship our own sqlcipher for this. Registration should hereby be fixed, so please file an issue if it is not.
  • SailfishOS 4.0 stopped shipping the (non-public) BubbleBackground, and replaced it with a ColorBackground. We now ship our own ColorRect, thanks to @ichthyosaurus . Viewing messages on should be fixed.

Notable bug: reCAPTCHA rendering on SailfishOS currently does not work. We think this is a regression in mozembed, and filed a bug with Jolla. We hope this is resolved before SailfishOS 4.0 hits the masses.

Another pair of issues just came to light:

  • Newly registered Android/iOS accounts might not be reachable from Whisperfish. This will be addressed when we finally migrate to UUID sessions.
  • Contact names may not show up and will not update. This is the same regression that @Ygriega noticed. #231

Many hours have been sunk into getting the reCAPTCHA rendered. Your patience is now finally awarded :slight_smile: The Whisperfish beta is getting in good shape, and there are many treats coming your way in a few weeks™! :partying_face:

PS: for about two hours, there has been a “new alpha.7 aarch64” on OpenRepos. This was a mistagged alpha.8, and has now been removed. No damage should’ve been done.


Just updated to alpha.8 a few hours ago, and basic messaging at least is working fine with SFOS 4.0 EA. Thank you so much!

1 Like

Actually, I completed the Finnish translation yesterday evening, but it’s not included in alpha.8. I guess it gets pulled when it gets pulled :slight_smile:


It’ll be in in beta.1, and it’s in current master (or soon to be)! I’ve backported the two changes that I listed to an older state, because of some bugs in current master that would make Whisperfish unusable to some. Thanks for the :finland: translation :slight_smile:


Since 3.1 is quite old I am not that surprised that nobody tested it. And supporting old systems limits the potential for improvement (at least in my experience).
And I now know that I will have to update my system somehow …

Thanks for the answer.