WayDroid on SFOS?

I just noticed this article about WayDroid https://linuxsmartphones.com/waydroid-lets-you-run-android-apps-on-linux-phones-with-smoother-performance-than-anbox/
Is that something that it’s applicable to SFOS? Certainly it seems to have more chances than AnBox.

7 Likes

its acutually the new Anbox organized and developed by some members of the ubports community.

Fundraisingj

4 Likes

If i understood it right. Anbox for Ubports uses project Halium which SFOS doesn’t support. If i am saying something wrong please correct me :slight_smile:

WayDroid has been running on a few different Sailfish OS ports so far with varying levels of functionality.

From communications through different channels, I know that it runs on at least the following devices currently:

  1. PinePhone
  2. Sony Tama platform (Sony Xperia XZ2, XZ2c, XZ3)
  3. Mi Note 10
  4. Mi Note 8
  5. Mi 6
  6. Galaxy Note 4
  7. Fxtec Pro 1
  8. Volla Phone

(if you know anymore, share here)

With help from Erfan Abdi over Telegram, it was possible to get WayDroid running on Sony Tama (XZ2c), and I noted down the instructions - Tama WayDroid Instructions.

On Sony Tama, the status is:

  • Camera (no flash, but then that is a Tama thing on Sailfish too)
  • Sound (application sounds work, but not notification sounds)
  • Video (using Firefox, Amzon PrimeVideo)
  • No location access
  • No vibration feedback (update: vibration feedback could be enabled by enabling the service, see instructions)

There isn’t much integration between Sailfish (host OS) and WayDroid at present. Meaning Sailfish contacts, clipboard or files cannot be accessed easily in WayDroid and vice-versa. By running KDE Connect on both Sailfish and WayDroid, it is possible to have a limited level of integration though.

Tagging some others who where successful in getting WayDroid running on ports @piggz @b100dian @edp17 @rinigus @Levone1

9 Likes

firefox browser plays video with a sound

2 Likes

Waydroid running great on XZ2c, according to your instructions. I can’t get this to work yet - https://github.com/casualsnek/waydroid_script I opened an issue describing my attempt. Anyone with more knowledge wants to try, let me know…

Note - to get the OpenGapps script to successfully install, you need either a different version of Tar, (SFOS one is a symlink to Busybox which doesn’t understand “–lzip”), or to modify the script. I built a new Tar from source if anyone wants it…

update - tried again with OpenGapps, starting from scratch, and working. Not sure what the issue was before…


2 Likes

I confirm that Mi Note 10 has the same Sony Tama status, with one more adaptation bug (no video recording) and one less (has flash)
Also, microg works - it is a signature spoof-able image!

(Ah, I forgot I have the b100dian alias on the forum too - but don’t use it.)

3 Likes

How did you flash MicroG? Did you use Waydroid_script tool for Magisk?

Mi Note 8 works too.

3 Likes

How about Xperia X? Would it be feasible? And you definately need MicroG? Thanks! :slight_smile:

1 Like

MicroG can be installed from it F-droid repo on the device, no flashing needed.

1 Like

Is anyone able to launch Waydroid apps from SF launcher? For me it just does perpetual spinner, and card closes, even if Waydroid is up and running …

@Kabouik - I saw your issue on Waydroid_script github - Did you see mine? Do you have functioning Magisk? Not working properly for me…
update - seems like script detected my phone as 32-bit…

@levone1 Not really, I have the same problem as you and replied in your issue, but that is obviously not specific to SFOS because I only tried on Pro1 running Droidian so far.

1 Like

Seems like / is not mounted rw when script runs, because I can run init-magisk script in root shell after mounting rw, and everything gets created/symlinked, but then trying to run Magisk binary gives 32-bit error…

I have gotten an update merged into the instructions - I packaged gbinder-python for armv7hl, allowing waydroid to be run on 32 bit devices. I currently have it running on my Fxtec Pro1.

2 Likes

Would it work on Xperia X instead of old 4.4 AD?

1 Like

maybe helpful …
https://wiki.archlinux.org/title/Waydroid

I would wish that too. But if i understood it right, the kernel is the important part to run a newer Android version. Our kernel version just allows Android 4.4. To run a higher version of Android we would have to flash the new kernel before. If i got it right, running SFOS directly on the Kernel without a midlayer would facilitate running an emulator with a higher Android version and this will probably be the strategy of Jolla for the future. Tell me if i say bullshit. I am quite tech interested but also don’t know all the issues and dependencys for SFOS :slight_smile:i

If you have had luck running containers on the device before, probably Waydroid will run too, I guess. I am sure the Waydroid docs page (or was it Arch wiki) describes kernel requirements. Might be worth checking those.

1 Like