Update Mess....need help

This is my 1st update with SFOS. I plugged my phone in, downloaded the update, got the notice I needed to remove CHUM GUI and ignored it, then the update failed.

Since then I have not been able to update the repsoitories for storeman or chum. I cannot download the update, I can’t do anything.

I believe the core problem is not enough room in the sytem folder. I have read the instructions for resizing the sytem folder and it has ‘nightmare’ written all over it for me.

I read removing OSM SCOUT should clear enough space, however I can’t get storeman to work to remove it. I tried removing via the command line but nothing happens.

So, the update didn’t finish and you are now still on 4.4? Could you run ‘ssu re’ in thr terminal and check if the output is version 4.4.x or 4.5.x.

OH WOW!!! The plot thickens!!

“Warning ssu.ini does not seem to be writable. Setting values might not work. Device release is currently :”

Now what??? LOL

At least I am updated!..maybe…

In Terminal enter ‘ssu re’ and then do a pkcon refresh. Maybe this helps.

What does “ssu re” do please?

pkcon refresh just hangs at “waiting in que”

It tells your phone that it is on SfOS version or you want to update to this version and sets the necessary repositories. If the update crashes before installing rpms you are still geworden using the old release but the repos point to the new release.

Which OS version is shown in Settings → About SailfishOS?

You could also try to upgrade using the cli.
This can be done by using sfos-upgrade from openrepos or by using ssu re to set the desired os version.

In this case ‘ssu re’ .

Followed by ‘version --dup’ .

If you are able to install sfos-upgrade, you could use ‘sfos-upgrade --verify’ to check the installed packages. ‘ssu re’ is needed before exexuting thus command.

Thank you for explantion!

With both versions ssu re returned:
" warning:dbus call failed, falling back to libssu: message recipient disconnected from message bus wihtout replying
terminate called after throwing an instance of 'zypp::parser::ParseException: what() /etc/zypp/repos.d/ssu_openrepos-Karry_release.repo: Section [operepos-Karry]: Line 7 contains garbage (no “=” or “:/?|,” in key)

Look like progress???

about shows 4.4
ssu re shows 4.5

Never downgrade; only try to install!

Move the file ssu_openrepos-Karry_release.repo to e.g. home directory and try again. That blocks the operations now.

If you can, please post the contents of the file here; I’ve had that happen once and I didn’t save the file…

Edit: There is something funny with handling repos, or openrepos, and I’d like to know what. A broken openrepos repo file should not stall package manager, because it’s both 3rd party, and non-critical repo.


I have read the downgrade warning before, thanks for the reminder.

Where do I find that file? I opened file manager, clicked root, went to etc and there is no zypp folder there.

Just checked, it is in /etc

Or just do

‘devel-su mv /etc/zypp/repos.d/ssu_openrepos-Karry_release.repo /home/nemo’

in Terminal if your user is nemo, if not exchange nemo with defaultuser.

Still couldn’t find it. Obviously looking in the wrong place because terminlal worked.

Typed ‘ssu re’ .

Followed by ‘version --dup’ .

got the error message and ran it a su, entered passwork and it says “REFRESHING CACHE AND DOWNLOADING PACKAGES

and has said that for the last 20 minutes with no movement or percentage showing.

I rebooted and went to settings-update and it is now downloading the update.

This time it gives me a list of about 80 pkgs it says I should remove.

Hey, at least it is doing something different!!

FIANLLY!! Updated and working.

Thanks everyone for your help.


Great! So it was the repo file! Could you share the broken file so I could see how messed up it was?

1 Like

I would be happy to if I could find it. I have never found the file.

I go to root-home-defaultuser and it just isn’t there. I have never been able to find it. The above command did the trick and got me to the point I could upgrade, but I still have no idea where this stupid file is.

I do have “show hidden files” turned on. Still can’t find it.

If your home directory is /home/defaultuser have you changed nemo in my command to defaultuser? If not then you should find the file in /home with the name nemo.

Changed nemo to defaultuser.

Thank you for solution! In my case it was ssu_store_release.rep…