Unable to use mobile data on Sony Xperia 10 III

Xperia 10 III,, Vodafone Germany:

Another short test in Switzerland: Mobile Data works with access point set to IPv4. Did not try IPv6.

Switzerland, Roaming

  • Vodafone:, Xperia 10 III, No Problems after setting Access to IPv4, did not try IPv6, LTE
    [edit: tested dual mobile access point: works.
    Swiss roaming is a bloody rip off!]

I use an xperia 10 ii and i only can use mobile data with android support, very strange. Everytime i enable wifi in android settings it disables itself again

Why do you have to enable WiFi in Android settings?
There is one central control in Sailfish.

I don’t know, i only see that it’s disabled there

And did you test if Android apps have internet access, when enabling wifi in SailfishOS?

Yes i tested it and no they don’t have

same for me. new user of sailfish with a brand new sony xperia 10 iii.
no mobile internet connection at all.
in france with french operator “Free”.
work with wifi for both sailfish and android.
placed the sim in the second position and now have mobile internet but still not for android applications for which I have to activate wifi.
very annoying because of some work android applications I have to use (mainly slack, even with wifi, I have problems with google authentication :frowning:
thinking about reverting to plain android but, hey, kinda got attached to this swipe world…
still trying…

[edit] ok mobile internet worked for a few minutes. some time later, not working anymore again for SFOS apps and, of course, also for android ones :frowning:

1 Like

Try Clat

1 Like

ok then. spend a whole week end reading docs and trying things => complete fail.
my xperia 10 III with the latest official sailfish os can’t have mobile data working except for wifi.
really disapointed.
played with both sim1 and sim2, tried ofono logs.
not tried to suppress the sim pin code as some suggested as I find this solution very strange.
so, still no solution.

[ xperia 10 III ( / official sailfish os / french carrier “Free” 4G/5G enabled ]

1 Like

Also XIII on free.fr.
Works only with the voodoo of ‘no PIN required’.
I suspect that waiting for PIN introduces a race condition/delay/who knows what/ that prevents the mobile data from working.
I will try CLAT one day, to see if it makes a difference in two situations:

  • in case the PIN delay affects how the operator allocates IP address.No high hopes here
  • when roaming on OrangeFR 3G/3.5G (I hope/expect CLAT to address it).
1 Like

Have you tried the clat plugin for connman like sugedted by @Gordon?

hello miau,

no, didn’t try the clat plugin for conman (and not sure I understand what you mean).
but just read the comment of rtr2001.
tried to deactivate the pin and now works.

ok, my bad. found this solution too strange and it’s actually is the only one which works for me.

SF team, maybe you should add this solution to the mobile data problem Q&A.

We will roll out a 4.5.0 update in the near future, containing the CLAT fix.


Great news, thank you!

For the “PIN required” trick : Tried the CLAT-enabled new relese( => no change compared with past 4.4./4.5.. Mobile data only works with “PIN required” set to “off” .
I have yet to test the 3/3.5G part.

1 Like

No change here too, no way to access mobile data on Vodafone IT on the Xperia 10 III.


Carrier: Plus PL, no changes, mobile data doesnt work.

1 Like

Let’s continue collecting feedback in tomic’s style (a little bit modified). This time, it is only about Xperia 10 III and Xperia 10 II, using the release (as it has the CLAT). Check the IP version from “Settings > Mobile network > Data access point > Protocol”. Use a 4G network.

    "Country", "Home or Roaming"
    “Provider”, “IP version”, “Phone model”: Solution/Verdict → Speed
Please use “?” as a prefix for unsure, and “?” as a postfix for unknown.
1 Like
Italy, Home

- Vodafone, IPv6/Dual, Xperia 10 III: Data not available, limited connectivity displayed, some packets exchanged at the beginning (known via ifconfig) then nothing more, only IPv6 address available.
- Vodafone, IPv4, Xperia 10 III: No connection established (no data arrows shown).
- Iliad, Dual, Xperia 10 III: No problems → LTE.