UI-Themer missing from OpenRepos

Hi all,

I’ve been using UI-Themer for a long time. Today, I had to update my device to the latest SFOS, which led to a bootloop. I had to install from scratch, and now I can’t get UI Themer from OpenRepos/Storeman because it has been removed, apparently.

Does anyone have an rpm available that they installed previously? There are numerous features in that application that I depend on (icon sizing/spacing, font changes, dalvik screen density, etc.) and I’d really like to have that functionality again.

Thanks, in advance!


Indeed, Fravaccaro has removed ALL of his applications from Openrepos and Github, shame, he made good apps and patches.

1 Like

I have it installed via Storeman, but is it possible that package is still somewhere? I would like to have this functionality in future too.

Missing it a lot too.
That was really usefull … If someone still have the rpm … Say it :slight_smile:

Maybe this link can help to recover your settings manually :
Sailfish OS: how to display more content - fravaccaro.wordpress.com

1 Like

Here you can get the rpm’s


Are rpms saved to phone for install? If so, please direct me to the folder (Rokua) and I’m sure I’ll try.

It’s always possible someone has saved the original (last) rpm of that app. If not, install ‘rpmrebuild’ from Openrepos (czarkoff) and ‘remake’ the app while you have it installed, then you will have a copy of that app. But as elements of SFOS change, eventually the app may stop working/installing.

Grab rpmrebuild directly with this link;

Once installed, open Terminal and simply type ‘rpmrebuild’ and add the name of the app you’re rebuilding.


rpmrebuild sailfish-weather

Output from terminal;

[nemo@Sailfish ~]$ rpmrebuild sailfish-weather
warning: Could not canonicalize hostname: Sailfish
result: /home/nemo/rpmbuild/RPMS/armv7hl/sailfish-weather-1.0.3-1.8.3.jolla.armv7hl.rpm
[nemo@Sailfish ~]$

but the links in your link direct back to Frav’s Openrepo, which is empty.

Sorry yes i have note it also now.

rpmrebuild as Edz stated.

It would be fantastic if you could build those rpm’s from your installed version! :slight_smile:

1 Like

I hope the UI-themer legacy will be adapted by someone. Cannot really imagine to use the standard app icons after being used to those elegant N9 style icons.

1 Like

If you have UI Themer installed, you can rebuild the rpm using rpmrebuild. If you or anyone else could provide it, I’d be grateful!


Why dud he remive all his stuff?

I see that I have his repo enabled but no idea which app was installed!
I tried to find out with
zypper --no-refresh se -si|grep “frava”
but nothing appears.
As I am not sure that this empty listing is related to the repo removed: does some has a listing what he offered so I could check if I have something installed?

1 Like

Fail, sorry (also tried as root). Willing to try again with any adjustments suggested.

Click to expand

[nemo@XperiaX ~]$ rpmrebuild sailfishos-uithemer
/usr/lib/rpmrebuild/rpmrebuild.sh: WARNING: some files have been modified:
…T. /usr/share/applications/sailfishos-uithemer.desktop
missing /usr/share/sailfishos-uithemer/scripts/sailfishos-uithemer.txt
Do you want to continue ? (y/N) y
Do you want to change release number ? (y/N) N
error: File not found: /home/nemo/.tmp/rpmrebuild.4340/my_root/usr/share/sailfishos-uithemer/scripts/sailfishos-uithemer.txt
File not found: /home/nemo/.tmp/rpmrebuild.4340/my_root/usr/share/sailfishos-uithemer/scripts/sailfishos-uithemer.txt
/usr/lib/rpmrebuild/rpmrebuild.sh: ERROR: package ‘sailfishos-uithemer’ build failed

Does he have a reason for removing everything? Someone could get in contact with him. Since it’s oss, shouldn’t we be allowed to continue using his code and rebuild it?

I’m not sure, probably a lack of time or interest. I contacted fravaccaro by submitting a contact form on the website listed in the repo’s homepage. Maybe he’ll see it. I hope.

I’ll try that later and let you know then. Thanks to @Edz for help.

I have contact him on Telegram and ask him for the rpm, but this was his reply why he remove it from Openrepos: “Hey, it’s halted at the moment, I just can’t find enough time to dedicate to it”

1 Like

Thx for asking, that is a pity. I could still install themer without gui, a few seconds later it was gone. I tried making a rpm package. But I do not know the package name for themer. If some1 knows, let me know and I load it to a cloud for public access.
For me changing pixel ratio and icon size is most important. Any alternatives to that?
Sadly most of my fav icons were removed, too. But without overlays (wrong path) it makes no sense. Any workaround for that? TIA

Fortunately, you can change the pixel ratio and font scaling over ssh or by using a terminal: https://fravaccaro.wordpress.com/2017/03/08/sailfish-os-how-to-display-more-content/

I’m not certain how to change the icon size, but I’m going to poke around the system and see if I can figure it out today.