Trying the guest user feature destroyed all my data

REPRODUCIBILITY (% or how often): ??
BUILD ID = OS VERSION (Settings > About product): 3.4
HARDWARE (Jolla1, Tablet, XA2,…): Sony Xperia XA2
REGRESSION: (compared to previous public release: Yes, No, ?): No, new feature


I thought I’ll check out the new guest user feature. I switched to guest user and fiddled around a bit. Then changed back to device owner. The backgroud went black but the phone was usable otherwise. So I rebooted the phone and was greeted with the first use wizard. Had to do the whole tutorial wizard and setting up wlan.

After I got past all that I saw that the whole home directory was reset back to factory. All data from Sailfish side and Android side gone.

All the apps I had installed were still there, developer mode was still on. I updated to 3.4 through OTA so I was still using nemo as a user. nemo was still there in home. So it wasn’t a complete factory reset.

Luckily I had a image backup from a few days ago so I didn’t lose very much data (hopefully, I’m still in the middle of restoring).

I don’t use any patches. I have some apps installed from OpenRepos but these should all be user land stuff. Nothing that would mess up system files.


Nemo as a user. Maybe important, maybe not.
Encryption not in use. Maybe important.
Update: I am using Battery Buddy which does use some background services.


  1. Enable guest user
  2. Switch to guest user
  3. Switch back to owner
  4. Reboot


Reboot to my normal phone


Rebooted to empty phone


I dont’ have any logs anymore. I’m restoring my phone.


Thanks for reporting.

Has anyone else seen this issue?

Hi jovirku,

I had similar problems, but I had luck. The data are still there. The situation was as follows.

My phone is an Sony Xperia XA2 dual sim

I updated my phone without any problems. Then I created a guest account. I changed to the guest account and it worked. I went back to the owner account, I switched back again and then I tried to go back to my owner account but it doesnt work. The display was dark and nothing happend. I restarted the phone and was again in my guest account. I tried again to go back to the owner account. No chance. Then I started again, opend some apps on my guest account and tried again to go back to my owner account. Now it worked. BUT at the moment I wouldnt try this again, because its not safe. Its not clear if you can switch back from one account to another. I hope this will help you to analyze the problem.


Well, maybe that’s what happened to me and I was back on my guest account just didn’t realize it.

But when I rebooted I had to do the first-use wizard. And all data in /home/nemo was gone. I don’t know how guest user works. If it masks the filesystem some how or uses some virtual environment or chroot type system that could explain why I didn’t see my stuff.

1 Like