Support for addons on the browser

With the newer engine can we have addons back??? The internet is a horrid place without ad blocks.


Indeed, browsing the internet without ublock origin is horrendous and scary at the same time, which is why i use firefox for android as my primary browser on my sailfish phone.


I did that for quite some time, but it has a price of apps being OOM killed far too often when having to run android apps. Now the browser mostly works, but it makes me cringe thinking about how open it is.

As Defender now has been updated for encrypted devices, you can block ads system-wide in any app with the same filters as uBlock.
It is not the same as addon for browser, but now I can browse internet in defaunt browser without ads.

1 Like

This is true for (see above added) native apps.


And if you like the same for the dark (Android) side then follow

1 Like

The biggest issue is that defender is not in the shop.

1 Like

Jolla makes the rules :wink:

And the rules are problematic. And tbh i totally get it that devs will be pissed if something changes down the line and have to modify their apps.

But we are missing so many useful apps. Native mapping (Pure maps) is awesome and we cant have it. And so many other stuff that would make the phone far more useful out of the box. We have discussed it so many times in meetings and no solution could be found.


With Sailfish 4.0 it’s already time. Make the smart and at the same time easy move to support existing extensions.

It would be nice, but I don’t think it’s feasible to officially support them. In the short term while we’re still lagging behind a currently supported version of Gecko there will be compatibility issues. Even when we’re up-to-date, the Sailfish Browser UI is very different from Firefox’s so many addons will never work, and those memory problems mentioned by tanghus will continue to be an issue.

Saying that, some of the addon bits were re-enabled in 3.4.0 so we could use GMP plugins for the codecs. Has anyone tried messing around with them lately?

1 Like

I’d be happy if we could at least enable UblockOrigin.

1 Like

There is Defender that works really well for blocking ads, it just needs one change to work in 4.0’s browser until it gets updated. So adblocker addon won’t be that helpful.

Its about having something that works out of the box. without needing to go to openrepos etc.

1 Like

I’ve only had two major problems with Sailfish. The other one, lost VPN credentials, has been solved. Please solve this one too - upgrade Gecko and do everything else needed but I know there is a way add-ons for Firefox can work with a fork.

I’ve installed Defender II at (the original defender’s been abandoned for so long that I highly doubt its usefulness) and it does help. Combined with the built-in saving of pages as PDF, I tend to agree the most important addition to browsers is covered. Still, it’s ridiculous not to support the vast wealth of extensions. After all, they aren’t equivalent to ad blocking alone. So - please work on this and find a solution.


Are there any news about an ad blocker for Sailfish 4.4 ?

1 Like

I don’t care about cookies would be fine!
The cookie warnings are really annoying!

I miss an option in Browser settings to just allow Cookies from the visited website itself and blocking all third-part cookies…

Another missing thing is support for WebApps an Service Workers.

1 Like

This works really nicely for me. I only can’t make automatic updates work, otherwise it is quite nice, if you are not scared of using terminal. I definitely recommend using ssh from your PC.

1 Like

Hi, tried to install it via ssh,the first commands worked, but I have an error message:

[defaultuser@Xperia10III ~]$ sudo nano /var/lib/lxc/aliendalvik/extra_config
>>> /etc/sudoers: syntax error near line 98 <<<
sudo: parse error in /etc/sudoers near line 98
sudo: no valid sudoers sources found, quitting
sudo: unable to initialize policy plugin

$ devel-su nano /etc/sudoers
## Read drop-in files from /etc/sudoers.d
## (the '#' here does not indicate a comment)
#includedir /etc/sudoers.d
#12.6.22 ergaenzt fuer adblocker
defaultuser ALL=(ALL) ALL

Could you please help me to finish the installation?

1 Like