Some "new" icons

“CC 3.0” is not a license; it just means Creative Commons version 3.0. The type of license is usually marked by letters after the CC, e.g.: CC BY-SA 3.0.

My guess: I’m sure Jolla uses a permissive license for their icon design, because they’re interested in 3rd parties styling their icons accordingly, and those would fall under the same license.

Look for the actual license inside the SVG files themselves (they’re plain text).
(oops, /usr/share/icons/hicolor features only PNG versions of the original, where did you get the SVGs from, esp. for apps?)

Do I understand you found those icons, and have not made the adaptations yourself?
In that case you should look for Licenses there.

Also see here

1 Like

They are all free to download.
## Icon template and library

And this is about license.


This is a set of default icons for Jolla App launcher.
Please use them along with Sailfish-Apps-icon-story document, Sailfish-Apps-icon-template and Sailfish-Apps-icon-library.

This icon template set is licensed under Creative Commons version 3.0 (CC BY 3.0). You are not required to provide attribution to us, as you making cool apps is enough for us.


Yes and no.

Yes, you are right that CC 3.0 is not a licence; in fact I am writing a file for each one, CC BY 4.0 where possible (especially being 3.0 “deprecated” and 4.0 being compatible with GPLv3 which is the licence of many of the non-Jolla projects).

Or in the git(hub/lab) pages: sometimes the icons folder contains only .png pictures, but the .svg happens to be somewhere else.

No: as @eson pointed out, Jolla’s original icons are available for the “taking”, but since the “old” wire-style ones instead are not available anymore, the adaptations are mine. I took every single icon and modified it:

@ohnonot, thank you for your comment: as I said I know very little about the licences aspects, I am still doing my homework and every help …helps.

1 Like

Yes, my mistake (maybe). :flushed:

I tried to activate it with Fuzzy Time already on, and your patch didn’t work. I turned FT off and it did. Then I restarted the home screen after turning everything off, turned custom-text on first and FT afterwards and everything worked, and still works. Bah…

But hey! Great patch and very useful! Thanks!

1 Like