Smartphone printer

These are good news!
And how can we deduce if the printer can be used directly with the phone or if it needs a wifi network in between?

If you are asking whether the printer can act as an access point; it either just plain says that - but primarily that is what WiFi-Direct signifies.

Yes, that is it. And if Sailprint can manage them with Wifi-direct or are there other specs to verify?

Actually my Epson printer works pretty well with sailprint

If the printer acts as Access Point I suppose SailPrint could work and print. Does printer provide DHCP server or you have to set manual IP? If sailfish detects any printer it will appear in the list-first screen. I have to add for sailprint that I was able to print only when I was connected to the same Access Point the Canon printer was connected too. If I was trying from different access point it didn’t work. Never checked to find why…

1 Like

Ok, so I received my Selphy CP1500 and can report that it’s success with ipp available on the local network. Haven’t tried direct print yet. Yeah! The quality of prints is quiet good!

Sadly, there are network issues with the volla22/GS5/rephone. But it works fine with the GS290/volla and the experia 10iii. shows up as ipps://xxx/ipp/print

Thanks @attah!


@ric9k , @davidrasch

SeaPrint, like that other printing system, only fishier.

As for managing; that is an unspecific term.
It can print to them same as over a network provided by some other access point, yes.
Still subject aforementioned compatibility concerns.

Not all Epsons - but some.

Oops, yes SeaPrint, sorry :face_with_open_eyes_and_hand_over_mouth:

Like my hopeless ET-2710 which I can’t use (but don’t really need) from Sailfish.
In contrary of a Selphy, which is really cool on the road.

1 Like

Oh, I’m totally sorry. Other difference to that other one is that yours just works. Amazing!

1 Like

Ok, @attah, here some screen of the selphy cp1500, from the volla/GS290 phone.

This is with the selphy on the local network, not directly. I’ll try to get to that after debugging networking on my DD.

1 Like

Hi @poetaster, have your experimentations brought some new elements about printing on the road, I mean with no wifi network between the phone and the printer?

Haven’t tried that yet. The printer tosses a dhcpd up, that I know, but I haven’t tried to connect yet. On the list.

Hmmm. Ok, a bit odd. I can connect the phone to the printer network but seaprint does not find the printer. Not even by supplying the ip / url. Look like I need to debug.

EDIT: Worked immediately with the Xperia 10III … it’s network weirdness on the GS5/Volla22 … or rephone.

So, connecting directly to the printer just works.

1 Like

Oh, great news! Will be harder to resist now! :blush:

Just a follow up. Bascially disabling the firewall (ipv4) on the Vollalikes made seaprint connectivity work, too :slight_smile:


Wouldn’t allowing UDP on port 5353 be enough?

Certainly :slight_smile: There are other issues on the volla ports. I hadn’t gone through all the ports but the firewall was an issue for numerous services (NO sdk QML debugging, a number of others).