Slow Camera Response on xperia 10 III

I use Advanced Camera from piggz, which works fine for me.

1 Like

It is this one, right? How do you install it?

Yes, that it is.

You have to install the Chum “App Store” first. Then you install it via Chum

1 Like

ok, so this is the link for the app store app, you need to try out (or know) on what chipset the phone is running (there are only 3 options):

Install “Advanced Camera”.
Then, the focus mode to select is “Continuous” or “Infinity”.
“Auto”, “Macro” have the same issue.

1 Like

have the Sony Xperia 10 II also have the problem that the camera is unusable.
triggering is so slow that photos are distorted, photos with a flash result in a white picture.
when will this be fixed the problem has existed for a very long time.
With the Sony Xperia X, the camera works without any problems.

You are right that “auto” and “macro” focuses slower but on my phone its way better than the jolla-camera.

generally, the problem with both “Advanced Camera” and “Open Camera” is:

  • they often won’t start because allegedly the camera is used by another application (even if the sf os camera app is closed)
  • they eat a lot of energy even when not used. So you have to quit them each time after you take a photo.

So I wouldn’t consider this issue as solved …


Sorry, to resurrect this old conversation…

I have this issue with a xperia 10 iii.
If you pan the camera at all, or if there is a general level of change in the viewfinder, the camera will never capture the image.
You can press the shutter button and pan the camera slowly forever and it will never capture until the contents of the image are perfectly still and constant for about a second or more, which basically renders the camera useless in many situations.

The problem seems to have got slightly worse in recent versions, or over time, since I installed SFOS last year.

I tried Advanced Camera but it has the exact same behaviour/problem.

Does anyone know any way of inhibiting it (changing any config file, clearing any cache, restarting any service)?

I used to use my old Lumia mostly as a camera, so, although the 10 III is very good for capturing still subjects such as macro and landscape, the camera is wildly limited and it makes me think of trying something else as a daily driver, which is a shame because this is the only major problem I’m having using the phone.


There’s a trick, you press the shutter button, then swipe like going to the gallery and you’ll hear the “click” because it shoot the photo.
I do that and finally could take picture that aren’t perfectly stopped and in focus.
But… it’s so annoying, isn’t it?
EDIT: or you can swipe to go to multitasking screen, but it’s less convenient


That’s very interesting. So there is a way to interrupt the camera’s deliberation over whether to take the photo …
The thing is, that’s still a situation that’s no good for taking a good number of images of family and especially children, where you’re taking lots of exposures.

Not being able to use the camera for family shots (even when the person is sitting down at a table) is a major showstopper.

I think I might have to charge up my Windows Mobile again and have a think about what to do.

As said elsewhere, Android Camera API 1 seems to have a fallback for when better autofocus options aren’t available. This fallback is slow, doing a zoom-unzoom to capture clear focal length.
On some phones, this function is much worse, for reasons unknown.

Will update the other thread.

1 Like

Hi David,
That’s interesting. When you say Android Camera API, this is the built-in camera app in Android, is that right?
I’ve not used Android in a long time.

I have Advanced Camera installed in SFOS and it has various focussing modes but the exact same problem occurs in auto, continuous and macro modes, which are the only modes where the phone focusses by itself.

Certainly on the xperia 10 iii, the problem can be enormous.
When shooting at an aquarium where the light was constantly shifting, it basically refused to take an image at any point. It would sit for anything up to a minute after the shutter was pressed, or until it was pointed at something static before the image would finally capture.

No. Sony don’t make drivers for Sailfish so Jolla have to use a compatibility layer called libhybris which I presume calls the Sony camera Android drivers. Jolla also replicate Androids’ API so you have a Jolla app calling Jolla’s Camera API 1, which calls libhybris.

Anyone - let me know if I got eg the libhybris bit wrong. :wink:

I wrote a couple of informative comments here and here.

An aquarium is pretty niche – I would give that 50/50 to work here except on manual or the other lenses.


The issue that teleshoes is describing is definitely that same one that I’ve been having on the Xperia 10 III.
It’s got to be a very tricky thing to say the least to get the camera functionality working in a different OS when Sony clearly work closely with the Android developers to get their features implemented there.

Even so, the camera is seriously hamstrung in SFOS when it comes to taking shots where there’s any appreciable movement in the image.

You may have the same hardware/installation problems as Teleshoes.
I barely notice the issue.

There are 4 ways to bypass the problem now.

1 Like

NGL, it’d be swell to know what those might be.

  1. Use Android eg Open Camera.
  2. Use Manual/Infinity on Advanced Camera.
  3. Use one of the other lenses.
  4. Valorsoguerriero97’s trick.
  5. [Bonus] Try Camera API 2. Breaks torch and video though.
1 Like

This is a great summary, thanks!
I slapped Open Camera on it and it’s a very nice app:

Even with very quick testing, you can tell that it works much better than the built-in camera app and Advanced Camera.

You’ve probably also noticed the menus are very broken. Fiddle with them and you can get them to work. Notable setting is switching it from Camera 1.0 API to 2.0.

I wrote a thread on HDR photography here:

1 Like

Thanks for that,
It took me a little while to find my way into the menus and those are tricky to get working. There seem to be some options that you can’t quite get at, but it works fine overall.

One thing I noticed was that, when I enabled API 2, whatever you tried, the image would be very pale - what it captured was very noticeably different (overexposed). That was the case when you left on auto, or HDR or anything.

When I put it back on API 1, it seems to work faster, and it takes a decent image.

1 Like