Sailfish in the USA

@ peterleinchen

Even my Sony X Compact using 4G with so i see no Problems here.

Jolla didn’t mention 5G at all, the talk was always explicitly about VoLTE. However, as X10III has 5G capabilities, one would assume… Well, y’all know what they say about assuming :wink: It would have been nice/cool, but as 3G is dying (fast), VoLTE sure must have the priority over 5G. (Okay, some areas are packed with 4G traffic, so in some cases 5G could actually be highly beneficial. Ask me why I know…)

I’m sure 5G will sorted out at some point!


Reporting on my experience, three days in with SFOS running on Xperia 10iii in USA:

  • 4G indicated throughout the call
  • No drops to 3G or 2G during or after calls
  • No dropping off networks between calls (this happened repeatedly to me on 10 and 10ii)
  • When 4G is active I can access websites during calls
  • Stronger and more consistent signal than 10ii, 10, and XA2

I tested with Android 11 before flashing SFOS with same results.

Note that a bug has been reported about Beta VoLTE dropping after toggling wifi; discussion of workarounds is here. It occurs regardless of country or carrier, so likely not due to a mismatch with US networks.

Edit: Works on both TMobile prepaid and postpaid accounts.


Ahm … the irony is it never mentioned 5G, so how do you come up to the conclusion that it supports 5G?
This is like if I am not mentioning a Mercedes but talk about VW you conclude I have Mercedes :smiley:

My experience with Jolla 4.4 on Xperia 10 III on ATT: there is no data link. no LTE / 4G period. The upper right shows 3G but the IP network is not reachable even on 3G.
3G calls are solid in and out. (apparently ATT still has a local tower serving 3G). but no data over SIM. The same Xperia 10III works solid with Android (both 11 and 12) and the same SIM/
Also noticed, that Connectivity – Cellular Network doesn’t have the following fields: to input MMSC value,
MCC and
MNC value
and APN type
and APN protocol
those fields are a must in order to have LTE working under Android. If I set to Choose networks manually, than I have an option to at least select the MNC (in my area can be 410 or 260) but There is still no place to type APN ( it should be: default, mms, supl, hipra,fota ) and APN protocol (Should be Dual) , and APN Roaming protocol (should be just IPV4).

next - will try to buy t-mobile SIM and of course will wait for Jolla 4.5 version to come and fix all the above. +))


Thanks for sharing this, @nemirova . I was hoping AT&T would give the 10 iii 5G functionality but I guess not. :-/

Update: AT&T just told me the phone was incompatible with their network. No signal on Android and can’t register on the network with Sailfish. YMMV.

Get a Tello sim. It’s cheap and they are on t-mobile network.

1 Like

Greetings. I am curious about your continued experience with the 10iii on TMO USA. Do you live in a metro area, suburban area, rural area? Do you drive much while on phone conversations? If so, do calls drop a lot? I live in Chicago suburbs, but drive for work all around the city and into the city. On 10 with 3G/2G calls, I have only a couple of spots where I predictably know my call will drop, and where I will get service again.

When the 10ii arrived, I tried a call from Joliet to St. Charles - a commute call I had regularly and never get a dropped call. On the 10ii, the call dropped 9 times. This was not unsurprising given that the 10 I still use (while I can) is the USA variant, whereas the 10ii and above, Sony chose not to create a US-variant, and thus leaves me/us with hardware that utilizes a fraction of the available frequencies/bands here.

With the 10iii there are few bands of compatibility here. I have two unopened 10ii phones, and two that my family members used and have SFOS on them. I am gathering data from your usage (and hopefully others who will post here) in the U.S. and deciding whether 10ii VoLTE will be available in time. If that won’t and 10iii is the only option, will I get so many dropped calls that it’s practically unusable, even though “technically” it’s usable?

Thank you for your reporting.

I also found the 10ii dropped calls, dropped off the network, lost coverage, switched bands… it was so unusable I shelved it after a few weeks. I tried out the 10 after that, and while it wasn’t quite as bad as 10ii I still found I missed a ton of calls and service was spotty. I was down to just using 2G in the end.

On 10iii all those issues are gone. I am receiving more calls, service doesn’t drop mid call or afterward, I experience fewer dead zones, it stays connected to 4G. I don’t live in an urban area and I know the dead zones around here well and the 10iii stays connected where others didn’t. While driving through a dead spot this morning my call stayed connected the whole time, and I even received a call the other day in a spot where my last two phones would never even have rung.

My only drawbacks so far are that I still cannot get MMS, and there is currently a bug with beta volte that produces discontinuous data connectivity. Other than that, for me this build is a major improvement over 10 and especially 10ii. YMMV so I’m keen to hear what you and others experience.


Thank you for your detailed response. As a result, I just placed my order for a 10iii. It is supposed to arrive Friday, so that means this weekend’s yard work and domestic duties will have to get done quickly so I can get to flashing my phone and transferring content.

I will gladly report back with my experiences in an effort to help others decide what is best for them.


Out of sheer curiousity, does MMS work for you? I’m on T-Mobile but their suggested APN settings don’t seem to work, same for the sim provided settings

Edit: I just read the previous post, and I am confused as to why MMS doesn’t work as well.

Short answer: I don’t know. MMS was nearly entirely broken for me on XA2 and has been unusable since I moved to the 10 series. I’ve tried tons of different settings and configurations and it never works. I thought from past posts that others had MMS trouble in the US too, and when we bring this up the Europeans seem unwilling to fix it as they can’t imagine anyone uses MMS anymore. Anyway I recently downloaded the MMS log tool and am hoping to figure this out. If anyone else has had success with MMS in the US (I’m on T-Mobile) I am all ears!

1 Like

MMS worked for me in the UK on the XA2 using EE (same as T-Mobile) but not with the settings provided by Jolla which were out of date. Changing them to more current ones googled from the web made MMS work fine. But … Moving to X10 III on the same SFOS release ( and using the same carrier/SIM card from the XA2, and the same settings … MMS does not work at all :disappointed:.

1 Like

seeing that mms will be deactivated by providers end of this year, the effort to fix anything regarding them might be unworthy.

Can you please share a link to more info about this shutdown?


AT&T has been known to whitelist, which is probably the issue, your Xperia 10 III is not whitelisted for their network.

T-mobile only requires volte, anything will work if it has that.

1 Like
1 Like

Thanks. I knew this was going on internationally but I haven’t heard MMS will be discontinued in the US. MMS is still used widely in the United States, especially in “texting” from iPhones to non-iPhones if the message exceeds SMS character limits. If Jolla still wants to expand to the US market as they indicated at the outset of this year, they may yet have to engage with MMS.


Another satisfied customer in the U.S. on T-Mobile!!!

I received my phone. It came with the latest Android 11, fully patched on it, so that simplified things. I ran it with my SIM for 30 minutes or so, including having my wife send me a photo via MMS. Worked beautifully. I then flashed SFOSX upon it and restored from backup. To be thorough - I’ve had issues in the past with notes causing my backups to not restore properly. As a result, with my relatively few notes, I simply took a screen snapshot of them, deleted them all, performed the backup, then moved the microSD card to the 10 iii and restored from backup.

I did have issues with SIM in slot 1 and getting cellular connectivity. I removed the microSD and moved the SIM to slot 2, then set the correct APN for T-Mobile USA (, etc.) and voila - everything connected well.

I tried to send an MMS, to no avail. It does not work, as has already been reported.

The OS is buttery smooth. It’s a good white wine that is described as buttery smooth - smooth. The browser is so smooth. I saw someone asking for a video of the browser. I may do that tonight even though I am not a podcaster type with the pro setup for such videos, just so those of you unconvinced of the browser’s smoothness can see how smooth it is. It is that good that it is worth it for me to do a video.

Then the pièce de résistance - I enabled the VoLTE, paired one of my Bluetooth headsets (Etymotic Blu2), and went for a drive through three of the spots that 100% dropped my calls on the Xperia 10. I had one dropped call at the very far side of a known area, and I was stuck in traffic merging from three lanes to two. I am convinced that if I had proceeded through that zone at 45 mph, the call would have handed off to the next tower seamlessly. But even with that call dropping, there wasn’t the 10-second delay that the X10 had where “no service available” message comes up, the phone connects to 4G, then finally allows me to reestablish a 3G phone call. With the 10iii, I had Cellmon running and I watched the signal drop precipitously from 72% to 32% to 1% and then the call dropped. The message appears at the bottom of the screen to Call Again, which I pressed and the call immediately connected. Behind that I could see Cellmon jump to 52% then 72% again on the new tower. I was far less interrupted with this drop than any of the other call drops.

Through the other two zones, my signal strength on 4G stayed 97% - 100% and the calls did not break up at all.

Given the 10iii is not working on all available T-Mobile USA frequency bands, I am thoroughly shocked at the call quality and signal strength and coverage in the Chicagoland suburbs thus far. I have not yet driven outside of 5 miles radius. I will do so tomorrow and report back.

I was able to, at red lights of course, surf the internet while being on the phone call and it was just as speedy and smooth as not being on a call.

I pulled up an email that came in while I was driving. Clicking on alerts and having the app open so quickly and the message displaying so quickly is just a treat.

I was so ecstatic with the person with whom I was performing the test call that they started laughing. “It’s just a phone.” is what that person said. Of course, they didn’t understand the monumental victory this is, especially in the USA for which neither the phone nor the OS has been targeted/optimized.

This weekend we are driving out of state to attend a wedding. My T-Mobile service on interstate travel has been erratic. We will travel routes upon which I have experienced poor cell service or no cell service in the past. I will test the phone during that and report back.

I have even experienced delightful Android app compatibility that has plagued me in the past. The Ubiquiti Network Application app for monitoring and controlling UniFi networks has not worked for a year and a half on my 10, even with updates to SFOS and the app, itself. It works flawlessly on this.

I used Aurora store to install the JP Morgan Chase banking app. I don’t have Google services and haven’t even bothered with the workarounds. I just tried it on a whim. The Chase website would not let me log in with the native browser. I had to download Firefox before Chase’s site would let me in. I could enter my credentials, get the one-time code texted to me, then successfully authenticate. But at the next screen it would said that I needed the app or to check the laptop/desktop requirements for the website. However, I downloaded that app and it worked straight away, despite a warning about not having Google services or something along those lines. I just acknowledged the error and my banking information appeared. LOVE IT!

I should note, I opened the APKPure App and it reported that it did not have network connectivity. I had to use the utility to restart network services, then the Android app had network. I’ve gotten used to this from the X10, and do look forward to this being permanently resolved.

The Axis Companion Classic app that I use for work also works nicely. Over cellular I can watch the four cameras that fit on the screen at once in real-time. I can scroll through the various cameras on a 16-camera site and the application’s performance is smooth. I can click on any one camera, select a recording and play it back in high quality and the graphics playback is perfectly smooth on this phone.

I paired my Logitech Bluetooth keyboard with the phone. Its performance has not changed - in SFOS-native applications the keyboard works flawlessly. In Android apps, I can type and the phone keeps up with my speed, however I cannot use any key combinations, therefore no capital letters or symbols from Shift+(a number key) can be displayed. I have seen this since my Xperia X, 2x 10X, 10+, 10ii consistently, so I don’t think it’s the phone. :slight_smile:

I turned on Location, installed MLS Manager and ran Here and it properly located me very quickly.

In summary, I completely agree with @cyberlyra and wholeheartedly recommend this phone for purchase and use in the USA. I will answer questions you may have as best as I can.