Sailfish in the USA

We’re all in this together. You paved the way for me to even get the 10iii and continue with SFOS. So I literally couldn’t have done it without you! Glad to be of service to the community.

7 Likes

And really, the source knowledge goes back to @deprecated from years ago. I know he’s still here somewhere. He should get a 10iii now!

3 Likes

I just use it on desktop for the web portal. I set it up on my One Plus and then switch the SIM.

@cyberlyra @Ras72 pardon the tag, Sending photo MMS works but I’ve noticed I can’t download MMS. What are your experiences? Maybe I need to try network situations (ie. No Wifi, Just-activated Data, etc)

Also thank you to the both of your for your contributions to this community <3

1 Like

@LSolrac (ahhh, Carlos spelled backwards…I get it) No worries about the tag. :slight_smile:

Yes, I am able to send and receive MMS photos consistently. I can only do it when I am on cellular data, however. If I have WiFi enabled, the MMSes won’t come in. I’ll get a notification and “downloading”, but it does not complete. This was also the same behavior on all of the phones, IIRC. I receive multiple photos daily for work, and I send photos at least every few days. Many times, I am on a phone call with one of my coworkers who will try describing something, then finally take a photo and text it to me while I’m on the phone. As such, they tell me they sent the photo and then see when it arrives and that time difference is usually one to two seconds. In fact, this is now faster for me since before VoLTE, my voice call dropped the phone to 3G. Now with VoLTE, my phone call and texts can work at the 4G speeds.

If you can’t receive MMS messages while on cellular data only, then I would recommend that MMS Log application and maybe we can work through together what it is reporting and why you cannot receive the MMS messages.

2 Likes

For those on T-Mobile, I’ve found a solution for my MMS woes that gives me both photo sharing and group texts. As of 4.4.0.x, the T-Mobile DIGITS app started working. This is an Android and iOS app from T-Mobile for managing MMS, calls, and voicemail. You can install it from Aurora store. For whatever it’s worth, my phone is a Xperia 10 ii.

2 Likes

Yeah mine is already set up. I built a webwrapper for the desktop portal that worked great on my phone until google started requiring OAuth2.

Unsure if I will be able to fix it or if I even want to.

Hm, I am having the same problem, @LSolrac. That first night I was able to send three picture messages successfully. But two of the three claimed they didn’t work (failed to send) even though they did, and the remaining one strangely switched statuses to “failed to send” after it had already been sent. I haven’t been able to send one since, and I haven’t been able to download them either. The logs keep reporting errors and closed connections. It feels pretty random, or at least I haven’t found a pattern yet.

Things I have tried: toggling connectivity on and off via utilities and airplane mode, resetting phone, trying to send an MMS in the hopes the system receives at same time… Should we start a thread to share settings and logs?

I’ll try to see if I can get Digits working (thanks for the pointer, @ajwatt and @Sword11)

1 Like

I believe and I could be wrong, but I think digits can make calls via data (like sip). If so that would be helpful for people with devices that dont have native volte.

Can you check if that works?

I just attempted a call via DIGITS and it tries to hand off to another app. I’m prompted to choose an app to complete the call, either the Android call handler (which doesn’t work) or the Sailfish phone app. So this does not provide a workaround for VoLTE calls.

1 Like

Ah shame. Well thanks for trying.

@cyberlyra and @LSolrac - Given the same hardware, same carrier and same operating system, then there has to be a settings-related thing to be addressed to solve this because my phone continues to send and receive photo MMSes flawlessly.

My entire family used to be on Sailfish. When we got the X10 phones, mine did not receive MMSes while everyone else’s did. I thought the same thing as I posted above. I typed the settings into everyone’s phone, so I knew they were identical. The only thing left I could think to do was call T-Mobile. I explained the situation and the support tech “reset [my] account”. I knew they’d do something, so I actually called in from my wife’s phone so I could stay connected with the technician as they tried things with my line.

After the “account reset” in the T-Mobile system, I then had to reboot my phone. After that, I could receive the MMSes.

Now that VoLTE is demonstrated to work, I have one son still hanging onto Sailfish. I’ll order him a 10iii today and later this week or next weekend get it loaded with SFOS. That will be the next opportunity I have to test the MMS capabilities and report back at this forum. Perhaps the problem can be resolved on T-Mobile’s end and you will be able to send/receive MMSes? Perhaps I need to have them do that and that’s why mine works with the old epc.tmobile.com rather than the fast.t-mobile.com setting?

Again, it’ll be a week before I have another device upon which I can obtain more data. I hope this helps.

1 Like

Intriguing. What did you do to get Digits working? I went to Aurora store, downloaded it. I sign in with my T-Mobile credentials. It blinks the three dots a few times, then screen changes to “Loading…” with the trhee dots blinking left-to-right, and that is all it does. I never get past that screen.

I don’t have any of the MicroG or anything for Google services loaded upon my phone. Is that absolutely required to make Digits operate? Do you have that on your phones?

1 Like

Thanks, @Ras72, please keep us posted on your son’s device. Maybe if you can post your settings screenshots (Data and MMS settings) that could help us? I think I’ve reproduced your settings but I’m not sure.
I just got a fresh T-Mobile account so I’m not sure what an additional “reset” would do to help, but I’m willing to try!
I also had the same problem with Digits – downloaded from Aptoide, signed in, Loading … interminably. I also don’t have a Google ID or any Google services on the device, if that makes a difference.

Thank you for this! Another device reporting their results could help a lot. I think made a mistake however… I thought receiving MMS images was not working due to a peculiar coffee company’s (Bones’) offers sometimes contain GIFs or APNG (Animated PNG) or Video, which remain in “Waiting”. However, I experimented and texted myself and then sent an image, and to my surprise, both the text message and image arrived back. Now, I know this isn’t a proper test but I figured it was worth reporting.

I also asked a friend to try mms with me and I can receive images, however GIFs remain as a still image rather than animated.

Have you tried with MicroG? Though I’m not sure how to properly install it. I have yet to try the Digits app myself.

I am just learning about MicroG now.
I gave up Google products in 2012 so it depends how far down in the stack their ‘non-Googleness’ goes as to whether or not it’ll work for me.

2 Likes

I’ve noticed a lot of complaints about MMS working with T-Mobile. Under the MMS APN input the IP for the proxy. Don’t use a host. The resolution doesn’t seem to always work here. I have MMS send and receive working on T-Mobile reliably here in Central Texas on a Xperia 10 III.

1 Like

Yes, sorry, I do have microG with a UnifiedNLP installed. I had installed these prior to the 4.4.x updates and DIGITS didn’t work at that time. So my assumption was that the 4.4.x updates were the difference. In hindsight, I bet it was the combination of the 4.4.x updates and microG+UnifiedNLP.

In working with the DIGITS app on a Windows machine and in a browser, I noticed that it is particularly finicky about location services. So my guess with the Android version on Sailfish is that it needed access to a location provider. That is when I installed microG and MozillaNlpBackend.

To install microG and a UnifiedNLP, you need to first install F-Droid from www.f-droid.org. Then launch the app and search for microG. You need “microG services core” and a location provider such as MozillaNlpBackend. I installed “microG Services Framework Proxy” too, but I don’t remember what for. I would suggest you only try adding that if DIGITS still doesn’t work. The same goes for FakeStore, actually.

With microG installed you’ll need to run the self check in the microG settings. The signature spoofing check boxes will need to be ticked. The installed packages ones will be ticked according to the packages you have installed. The permissions granted boxes you can tick those yourself. I have them all ticked, which I don’t like, but I’ve made peace with it. Beware that once you tick a box it cannot be un-ticked. I think for DIGITS to work you need at least the ones pertaining to location to be ticked. Maybe more.

Can you elaborate on this some more, or maybe post the settings you have on the “MMS access point” screen? I don’t have a proxy set at all, and I can’t find an IP address for fast.t-mobile.com.

You won’t use IP addresses, setting up APNs is a bit like a VPN. If you’re using T-Mobile or any MVNOs for them, you’ll usually be using fast.t-mobile.com or epc.t-mobile.com for the APN host. For Mint and several others, they use an APN host simply titled wholesale.
The MMSC address will usually be http://mms.msg.eng.t-mobile.com/mms/wapenc or http://wholesale.mmsmvno.com/mms/wapenc and some people will usually find IPv6 best for that.