[Release notes] Verla 4.2.0

I have a Ford Audio system, made by Sony, which requires a PIN code. Pairing goes fine, so does music playback. I used to be able to make calls before 4.2, but no more :frowning: There’s no audio from the car speakers. That should be fixed in the upcoming update. (This also applies to JBL TUNE750BTNC, which doesn’t have a PIN pairing.)

Or is your issue different?

My update from 4.1 to 4.2 failed with Sony Xperia 10 II 128GB Dual SIM with 1 SIM installed, no microSD card. I have a quite fresh install of Sailfish OS, only native and Android apps from stores. During the update process the phone rebooted and the progress bar got stuck at about 40% for 5h+. I powered the phone off and restarted it. Now it shows version even though the update was not completely successful. I currently encounter problems with some Android apps (Signal is not opening chats, only the overview, WhatsApp is not able to access the camera) and also triple camera does not work. Have not tested much.

EDIT: After doing this in the terminal, everything seems to work fine.

$ devel-su
# ssu release
# version --dup

1 Like

I can’t seem to find the thread, but i guess here is a good place too:
For the first time in quite a long time (years) i’m having problems with Android apps’ network connectivity when switching between wifi and cellular. :confused:


Every evening, after using my phone whole day, I want to set my alarm clock but right after starting clock app screen goes black. After a few seconds it comes back with lock screen. After unlocking all apps are closed. Then I can start clock app without problem.
( on XA2)

It sounds like lipstick crashes and restarts… Does it still happen if you remove all alarms and add them again?

1 Like

Is there any chance we can get this issue fixed?

I use favourite ambiances in the top menu with the Situations app to conveniently change settings, so it really hurts when my favourites no longer sort to the top.

Edit: Apparently this can be patched in AmbienceSelector.qml. However, I’d like to have the OS functionality restored.


How long before 4.3.0 is released? I am having to stop and re start Android App support two or three times per day to re-establish an internet connection via WLAN for Android apps. Right now the usefulness of the phone is very limited. I rely on having some Android apps open to receive notifications, e.g. Outlook.

I’m not receiving notifications and don’t know when the apps drop off line.

I suspect I’m not alone in relying on having Android apps that work.


hopefully that’s something which can be fixed in the GA of 4.2? and not having to wait for 4.3 - anyone at Jolla can confirm?


You are definitely not alone. I’m facing this issue regularly throughout my days, which renders apps, specifically like Whatsapp and Telegram not fulfilling their purpose; missing texts/calls.

Another annoying and super embarrassing shortcoming introduced in 4.2, is the random and unexpected loss of call audio, of like 50% of my calls (I believe thats an old issue but almost never happened on 4.1 or previous versions- XA2)
Truth: I’m so ashamed to explain the problem to family and friends, instead I’m regularly saying stuff like "it’s definitely something stupid I did/tweaked with my phone/OS (that I’ve been proudly promoting among family and friends since 2013 :zipper_mouth_face:)
We love you Jolla but seriously, stop putting us in such silly positions :hugs:


The reason I asked about the release of 4.3 is this problem is acknowledged in the release notes at the top of this thread along with a statement it will be fixed in 4.3.

I don’t know what happened with the latest version of 4.2 but I had no problem with WLAN access on Android apps before this latest version.

right, didn’t see that - seems we’ll have to wait a bit then :slight_smile:

@babo you have to remember that this is EA release. You have to expect some issues.
If you want stable system stop using EA releases.


Technically, it only mentions that the lack of connectivity right after installing the Android support will be fixed in 4.3, not necessarily the lack of connectivity after switching between networks.

1 Like

On the OS update screen for version I get a message to remove the package “feature-xt9” because it could make problems with the update. I don’t have openrepos or anything related installed. What should I do?
Update: I just went ahead and it worked.

Upgraded to I got that same message about the “feature-xt9” package (also got the LONG list in the previous upgrade).

Out of interest I tested and noticed that while the Dropbox-signin still doesn’t work in the built-in Browser, I was able to complete it in Firefox.

Also I noticed that while adding an Exchange account still does not ask for the MFA, the account is added without errors. The built-in email app claims that it was able to sync Ok, and even shows my email folders, however the folders are all empty.

Are these purely coincidental, or have these issues been worked on?

Update to .21 went smoothly on X10II (Dual SIM). The AutoComplete typing lag seems to have been gone, also Android apps work ok when connected to WiFi. What’s left is to check battery life and also if switching from WiFi to cellular data is successful - with .19 I had to manually turn off WiFi.

Update went fine on XA2 (40mb)

no new issues found yet

You’re absolutely right. I’m at fault here. For some reason, I truly and honestly completely forgot that it was an EA release. I’ve been an early access subscriber since so long that I forgot about it (worth noting that I never had any trouble upgrading since J1)

But then again…

Introducing a bug and willingly passing it over to the official release promising a fix in an upcoming update, isn’t a thing Jolla regularly does? Shall we dig and search?

And… I believe I have posted having in mind the update rolled out today(13/09), which its announcement didn’t state any fix for any of the issues I mentioned/commented on.

Don’t get me wrong… Im happy and satisfied with SailfishOS, but Come On!!

  • Android apps losing connection?
    Doesn’t it feel like Jolla1 all over again? A book could be written on this subject/issue searching just TJC (and as an end user/customer I dont really care about the differences, challenges and specifics of the different implementations and android versions, etc… that we are all aware of).

  • Loss of telephone audio? No audio during phone calls? A few very quick finds:


However! It’s still an EA release. So I’ll gladly wait.
If Jolla actually fixes those 2 issues and they are included in the official release, I will then confess my ignorance publicly on here and I’ll gladly purchase 5 sailfishX licences just to support Jolla.


I just completed the second update

After downloading I was asked to deinstall the following packages before I continue installing:

… and more:

Since I didn’t install theses packages on my own, I decided to ignore this.

The new update works so far…

Sony XA2

Upgrading from to on my 10 II took ~890 MB and I’ve observed the same warning “remove the following packages because they may cause problems during the upgrade: $list_of_many_system_packages>”.

Other observations regarding the update process:

  • Very low screen brightness after reboot (when entering cryptsetup PIN and while displaying progress of the upgrade)
  • GUI upgrade seemed to hang at 0% after the reboot. Finally, I did a manual upgrade (ssu re, version --dup, reboot) because the progress bar was barely visible anyway (see above)

and some first notes regarding the update itself:

  • Sticky mode of app grid only works on the first page - the behaviour for the second page of app icons is still paging-only (just like in the previous version)
  • Predictive text input only works after installing from harbour and rebooting again