[Release notes] Vanha Rauma

Many thanks to you our active contributors for your feedback and proposals.

Special thanks to Kees van Niftrik for allowing us to use his beautiful photo of old Rauma at the OS update page in Settings.

Table of content

Table of content

Update version history

  • 2022-03-17: OS version was released to Early Access subscribers as an over-the-air update. No support for Xperia 10 III, yet.
  • 2022-03-29: OS version was released to all users as an over-the-air update. No support for Xperia 10 III, yet.
  • 2022-05-18: OS version was released to all users as an over-the-air update. Support for Xperia 10 III added.
  • 2022-07-13: OS version was released to all users as an over-the-air update. VoLTE beta support added for Xperia 10 II.
  • 2022-09-30: OS version was released to all users as an over-the-air update. Microsoft Exchange account got a new authentication method.

Stop release

Yes, is a stop release .

– Is also a stop release?
– Yes. We will switch the rpm compression from xz to zstd on 4.5.0. As the prerequisite, we have enabled zstd in deltarpm and related tools in the 4.4.0 release.

So far, all Sailfish 4 releases have been stop releases. Because of this, if there is a reason to “reset” an Xperia device, please do not do it with “device reset” but, instead, re-install Sailfish - see the comparison .

Jolla Blog

The blogs about Vanha Rauma and Meet the Xperia 10 III with Sailfish OS .

Device models supported by Sailfish X

The supported Sailfish X devices are listed in this table.

Sailfish OS is available for Xperia 10 III starting from .

The instructions for installing Sailfish OS to Sony Xperia X, Xperia XA2, Xperia 10, Xperia 10 II (mark 2), Xperia 10 III (mark 3) devices are here - covering Windows, Linux, and macOS computers.

Read this, please, to learn about the Sailfish X licence.

Release highlights

The list below contains examples of new features (and some bug fixes) added to Sailfish OS, compared to the previous public release The release notes of can be found here .


  • OAuth2 authentication taken into use in Exchange account creation. Microsoft deprecates Basic Authentication for Exchange accounts on September 30th. Create the new accounts (sooner or later you will have to) with option “Microsoft 365” in Settings > Accounts.
    • This has been tested with limited number of Exchange servers and configurations.
    • It could well be that some accounts may be unable to login.


  • Quick and easy way to copy a web page’s URL by long-tapping the URL at the toolbar
  • Using the Like button on Facebook fixed
  • Adding a website to the app grid used to get an incorrect icon. Fixed now.
  • Performing secondary actions (e.g. opening context menu, selecting text, saving image) on webpages improved
  • Additional improvement for quoting on Sailfish OS Forum
  • Downloading attachments from web Gmail works now
  • Signing in to Twitter accounts via Browser

Telephony (VoLTE)

  • IMS (IP Multimedia Subsystem) registration improved
  • Call forwarding query fixed

Device-specific improvements

Sailfish OS Forum: issues reported by the community fixed in this update

Technical changes

The detailed changelog is here.

Updating your device

Your device must be connected to the Internet and signed into your Jolla account.

Start the update from “Settings > Sailfish OS updates”. Avoid running updates on the command line, please.

We warmly recommend making some 3-4 GB of free space for the internal storage of your device ( /home ) before starting the update. Processing an OS update of almost 1 GB requires a good amount of work area. Move your pictures and videos to the SD card (or to your PC or cloud service).

This is the usual drill before attempting to update your devices:

Take a backup of your data before attempting to update your device and save the backup to an SD card or to some other off-device location (PC, your cloud service). Note that videos and images are not included in cloud-based backups. Do not reboot the device while the update is in progress. Do keep the phone connected to a battery charger during the whole process. The device screen may blank out during the update process; you may wake the display with a short press on the power key to monitor the progress.

For detailed instructions on updating software, read our help article in Zendesk.


Sailfish OS does not support downgrading. Never try to downgrade the OS as this would break your device.


After downloading an update and selecting “Install” in the pulley menu, the device runs a restart first. In the case of a device with the user-space encrypted, you will need to type the security code before the actual installation can start.

Notification concerning apps from Open Repos

The apps below have been reported to cause problems when installing the previous OS updates. We recommend that you uninstall them before proceeding to the OS update. At least, read the recent comments on those apps.

  • GetiPlay has caused problems to some users - see this post.
  • If you’ve previously installed the RIME input engine from Open Repos, please remove both that and its version of libyaml-cpp before upgrading, as the latter will cause the upgrade to fail
  • If you use Privoxy, be sure to disable it before downloading the update, especially if you have configured the HTTPS-inspection. The latest update is from September. There is no information about compatibility with Sailfish OS. See author’s instructions .
  • If you use Aliendalvik Control, see the author’s instructions . It says there “Application has no support for SFOS 4 and later”
  • If you use Storeman, please update it to a recent version before upgrading Sailfish OS. Storeman Installer ≥ 1.2.6 and Storeman ≥ 0.3.0 have been confirmed to work fine on Sailfish OS 4.4.0. Further information is available at the OpenRepos Storeman page. Note the mention on Chum GUI.
  • If you use Phonehook be careful. The latest update (32-bit) is from October 2020. The 64-bit version (Xperia 10 II) was published in May 2021.
  • If you use OKBoard (a.k.a. Magic Keyboard), update it first to version 0.6.34 which has the fix for the “Installation not complete” error. Also, read the author’s advice , please.

Known issues

We have relocated the known issues to a table in Sailfish OS documents. The issues remain the same as in

Known issues - Xperia 10 II & Xperia 10 III

  • If VoLTE doesn’t register when enabling it for the very first time, please try to reboot your device.
    The word ‘Registered’ should appear under “4G calling” on the menu page Settings → System → Mobile network in a few seconds.

How did the upgrade go?

  • I had no issues during the upgrade process
  • I had small issues but was able to handle them
  • I got into serious trouble when upgrading my device (please help!)

0 voters


A pity you didn’t manage to fix camera crashing when trying to record a video, but oh well, can’t wait for 4.5!

1 Like

While updating my XA2 from 68 to 72 the progress bar in the Sailfish screen is stuck at about 100%. I’m still waiting. Any advice how to proceed? :slight_smile:


That happens sometimes. The reason is unclear. After waiting 15 mins it is safe to turn the phone off and then restart. Check that it shows the new version .72 in Settings > About product.

If there is trouble in turning off the phone then the forced procedure can be used: press both the vol up key and the power key down. Keep them pressed until you feel the vibrator play 3 times (this should happen in 20-30 seconds).


Before i run the update, is there anything i can do to provide diagnostics if this happens?

1 Like

The forced procedure after 15 Minutes of waiting went smooth. Version .72 is shown now. Thanks a lot :slight_smile:


no mobile network issue fix? :frowning: damn… it’s been 6 months without SFOS for me already…


This is very sad, indeed. After that long time, I expected much more than some improvements in the browser. I expected a useable smartphone.


indeed, super sexy 10iii toy rather than super sexy 10iii phone.

1 Like

I’m happy about every improvement.
The update worked well as always for me on my 10III

But after all the months, I know you people had summer vacation and so on, I had been happy about a camera update or at least a way to use all three cameras.

Plus 5G capabilities.

Those are things I could and would use.
I don’t need Microsoft things and I never used VoLTE.

Waiting for 4.5 with the hope for those functions


Maybe sfos-upgrade made by @olf can be usefull?

1 Like

Update Sony Xperia 10 II Dual Sim worked well. But it’s not possible to create an account with the new feature Microsoft 365.

After consenting use of terms, the browser opens for a second and then closes. The accounts dialogue shows a message Not possible to create.account. Edit: this applies brfore I can choose any server.

The browsers history shows provided value for the input parameter %27scope%27 is not valid. The scope %27https://outlook.office.com/.default offline_access openid email%27 is not valid - it refers to a resource which is not listed in the client%27s Required Resource Access and for which the user does not have any existing consent.&state=430225797

1 Like

As some others reported, with an Xperia 10 ii, I needed to hard boot (Volume +, Power) to get the device to restart.

This has not happened on previous upgrades. Although, I must admit I’ve only been using this device for 6 months (it’s a backup device).

Proper license, no android stuff. Minimal installs but for my own applications for testing purposes.


@PrhggfCKfuQ4: thanks for the useful info from your nice investigation. Would you be able to share (either here or by Direct Message if you prefer not to make it public) the domain of your Exchange account? That could be useful for diagnosing it (no need to share account name or anything like that, just the domain).

1 Like

Update on my XA2 went.fine, but I got the following issue:

  • once used screen rotatatin (landscape and back) in Android apps e.g. Chrome browser is not working anymore. Before no problem. Any idea how to fix this?

My Xperia 10iii updated fine and now VoLTE sort of works. When making phone calls the phone stays on 4G - but SMS does not work when VoLTE is ON…

1 Like

Try rebooting once more. Also had a strange issue with brightness on my XA2 after the first reboot.


Well, I hadn’t have the chance to fill any entry, the wizard stopped before that. - I formerly have had my companies account, which became useless here as they moved to azure cloud and changed to 2fa (and restricted access to very few trusted apps like iphones or thunderbird). Could there exist remaining config files I can’t see right now, which interfere with creating a new Microsoft 365 account?

On both the 10 III and XA2 Ultra pictures of selected (quite many) contacts disappeared after the update. What’s interesting, it’s THE SAME pictures (of the same contacts) on both devices.


Again??? Really? sigh

@flypig, please give Contact photos gone a.k.a. https://forum.sailfishos.org/t/5536 some love.