Receiving MMS fails if MMS contains only image (no text)

@slava Thank you so much for having a further look into this! And I’m glad that I was right that subject is involved. But it’s strange, anyway, as it would mean that multiple sources (BlackBerry BB10 phones, the iPhone, and also my operator’s voice mail MMS service) produce MMS messages with such broken headers. Or maybe the phones generate correct header but it is the operator’s MMSC (or whatever else is involved on the way between the sender and me) that currupts the header somehow?

Anyway, other phones / OS seem to be somehow immune to this issue if the same MMS that fails on SFOS, sent from the Z10 to the iPhone (and vice versa) is received correctly. So maybe if the SFOS parser encounters this error, it should ignore it, or interpret it as an empty string like you changed it? Maybe that’s how other systems handle it and that’s why they correctly receive such messages?

P.S. I didn’t have the opportunity to get those logs for you yet. I should be able to do it on Sunday. Do you still need them?

Android isn’t so strict, and I’m leaning towards relaxing the parsing rules too.

Yes, please. I’m curious how Subject is encoded there.

2 Likes

@slava, I’ve just sent the logs to your email. I included two MMS Logger tarballs: one for successful MMS delivery (with some text in the Subject field) and the other one for failure / PDU decode error (same image but without subject). Both messages were sent from the iPhone 6s with Polish T-Mobile SIM card to XA2 Ultra / SFOS 4.3.0.15.

1 Like

Apparently the bug I encounter might be another one, because some MMSes should contain text according to the senders. I have been receiving fail-free MMSes earlier. I think last time was in October. First faulty MMS was received in December. So at first I thought it might be the same bug.

When I tap to download the MMS it’s just chewing and nothing else happens. There is nothing new in the MMS logger after I tap to download.

Presence or absence of message body text is irrelevant. It is lack of subject text what’s causing this problem.

2 Likes

Hi @slava, I just wonder, did you get the logs I sent you a week ago, and did they confirm your findings? Are there going to be some changes addressing this issue, e.g. by relaxing the parser’s rules? Thank you.

@slava Can you please advise if it was ever fixed and made it to any of the recent OS updates? As of 4.4.0.64 I still cannot receive MMS from my wife’s iPhone if she forgets to type that freaking “Subject” text.

What’s worse, since 4.4.0.58 I cannot send MMS to anyone if I first manually don’t resize the image to <1 MB, i.e. below the attachment size limit. Before 4.4.0.58 I could send any image (e.g. a multi-megapixel photo taken directly by the camera without any manual processing) as it (apparently) used to be automatically resized. Not anymore.

Well, as there has been no response from @slava since February, I would like to just say that the problem is still unresolved.

I see that @slava responds in other threads while here he (she?) stopped responding in mid February, so I guess it is unlikely to see any progress with this issue. Which is sad, because I did my best to help fixing it - collected and sent multiple logs, etc.

Anyway, MMS support is one huge mess, including:

  • failure to receive MMS if it doesn’t contain subject text. I can’t even receive my operator’s voicemail messages (every new message left in voicemail is automatically forwarded by MMS), which is a real pain. While I can keep reminding my wife to enter even just one letter in the Subject field of her iPhone so that I can receive her messages, I cannot force T-Mobile Poland to do so and I just can’t receive my voicemail MMS at all.

  • I have to manually resize images (e.g. taken by the camera) to be able to send them. It is impossible to just take a photo and send it like on any other phone where I guess they’re automatically resized, it takes opening the image in some image processing app and manually shrinking its size first. Which is an even bigger pain.

  • Installing @slava’s “MMS Settings” (and choosing the 1 MB file size limit) improved things a little bit. Now I can send larger images (I guess up to that 1 MB limit) and if the image is too large there is simply an error that “the MMS couldn’t be sent” (and there’s an MMSC error code in the logs), whereas before installing “MMS Settings” and applying those changes messages with images larger than a few hundred kB or so were just stuck on “Sending” with the spinning wheel rotating eternally.

It’s been months like that. And it’s one of the reasons why I still don’t dare to make SFOS my daily driver and I keep switching to my trusty BlackBerry Passport whenever I need to truly rely on my phone.

Sorry it took forever. I’ve finally filed a PR for that:

8 Likes

That’s a really great news! So, if I understand it correctly, it is now closer to being included in one of the future OS updates, right?

Thank you very much @slava.

1 Like

It’s already merged meaning that yes, it will be included.

5 Likes

That’s awesome! Thank you!

Given @slava’s PR has been merged in, I’ve tagged this as “fixed” to help us keep track of open issues.