Problems with installing the OS update 4.3.0

Hi @jollajo ,
I have tried to follow your suggestions.
I downloaded repo data from:
A search for your suggested packages seemed to suggest the following URLs:



I used “curl -O TheAboveURL’s”, however that doesn’t seem to have been correct. A file has been created, however, it is essentially empty.

Attempting to install using “rpm -Uvh ________” doesn’t work as the rpm package is not right.

Any suggestions on the correct process?

Thanks all.

Nope, I updated with the GUI. I tried running version --dup but there was nothing to do. Then I tried installing anyway. There was a message that update cannot be done. I rebooted the phone, downloaded the package again and got the same warnings about git packages. Tried the update anyway and this time it gave the same warnings but the update was succesful. I run the version --dup once more but it did not find anything to do.

Thanks for that hot tip - I had wondered about that. This has allowed me to download the packages!
However, on install it was reported that both packages where already installed.
So I tried “rpm -Uvh --replacepkgs _____________” This installed the packages.
Following a reboot there is no change in behavior.
pkcon reports the same error. systemctl status packagekit.service reports the same error.
I feel this is out of me reach. A reflash might be required :frowning:
Thanks for all the help.

What a shame,
don’t give up too quickly, I was close to it yesterday as well, however as long as you manage to login to your phone there should be a way to fix it.

You should try to find why packagekit fails.
The service file /usr/lib/systemd/system/packagekit.service mentions some options for debugging:

# To enable verbose logging define following in sysconfig file:
# PACKAGEKIT_ARGS="--keep-environment --verbose"

I’d uncomment those lines and restart the service. I guess you don’t need to reboot, if you restart the service by systemctl restart packagekit should do the job, I’m just not sure if the modified file will be read without asking systemd to rescan the files.

Actually shouldn’t we move this discussion into a new thread, to stop polluting this one here?

Yes, do not give up too early.
As long as you can log in (even only via ssh) there is hope :wink:

What does
ldd /usr/lib/ tell you?
Some other lib missing or wrong symbols (wrong package version)?

1 Like

And another yes, our posts should be extracted into a distinct thread.
But we cannot do this. @jovirkku?

1 Like

I am trying to install the update, but it’s saying that all my packages are blocking

there is way more packages

Should I try installing anyway ?

This is what a zypper dup give me:

it says that it’s going to retrograde 186 package (sailfish one from what it looks like)

I guess I should reflash with the latest version ?

Thanks for the continued help. It would be great to have this topic separated, is there anything I can do? Should I start a new one?

@peterleinchen I tried your suggestion and there are no alarm bells there. Though there is one different line. /lib/ (0xaaebe000) is different to all the others. Is this the way it should be?

[root@Sailfish nemo]# ldd /usr/lib/ => /lib/ (0xf6dec000) => /usr/lib/ (0xf6d93000) => /usr/lib/ (0xf6d2d000) => /usr/lib/ (0xf6c42000) => /usr/lib/ (0xf6c19000) => /usr/lib/ (0xf6bab000) => /usr/lib/ (0xf6b77000) => /usr/lib/ (0xf69b0000) => /usr/lib/ (0xf6955000) => /usr/lib/ (0xf6924000) => /lib/ (0xf68fd000) => /usr/lib/ (0xf68e6000) => /usr/lib/ (0xf67f7000) => /usr/lib/ (0xf6793000) => /usr/lib/ (0xf676a000) => /usr/lib/ (0xf6658000) => /lib/ (0xf663f000) => /lib/ (0xf6526000)
/lib/ (0xaaebe000) => /usr/lib/ (0xf64f5000) => /usr/lib/ (0xf64d9000) => /usr/lib/ (0xf64af000) => /usr/lib/ (0xf647d000) => /lib/ (0xf6411000) => /usr/lib/ (0xf63f8000) => /usr/lib/ (0xf63e4000) => /usr/lib/ (0xf62ed000) => /lib/ (0xf62d9000) => /usr/lib/ (0xf62ae000) => /usr/lib/ (0xf629a000) => /usr/lib/ (0xf6234000) => /usr/lib/ (0xf621f000) => /usr/lib/ (0xf6200000) => /usr/lib/ (0xf61a0000) => /usr/lib/ (0xf6154000) => /usr/lib/ (0xf610f000) => /usr/lib/ (0xf60f9000) => /lib/ (0xf60e3000)

@jollajo, I uncommented the lines you suggested, and restarted service. I think I might need to do more than that. It resulted in the following:

[root@Sailfish nemo]# systemctl status packagekit
● packagekit.service - PackageKit Daemon
   Loaded: loaded (/usr/lib/systemd/system/packagekit.service; static; vendor preset: enabled)
  Drop-In: /usr/lib/systemd/system/packagekit.service.d
           └─01-home-mount.conf, 01-prevent-start.conf
   Active: inactive (dead)

Nov 05 05:58:14 Sailfish systemd[1]: Started PackageKit Daemon.
Nov 05 06:05:50 Sailfish systemd[1]: /usr/lib/systemd/system/packagekit.service:13: Unknow
n lvalue 'PACKAGEKIT_ARGS' in section 'Service'
Nov 05 06:05:50 Sailfish systemd[1]: /usr/lib/systemd/system/packagekit.service:14: Unknow
n lvalue 'ZYPP_LOGFILE' in section 'Service'
Nov 05 06:05:50 Sailfish systemd[1]: Starting PackageKit Daemon...
Nov 05 06:05:50 Sailfish PackageKit[12911]: daemon start
Nov 05 06:05:50 Sailfish PackageKit[12911]: daemon quit
Nov 05 06:05:50 Sailfish packagekitd[12911]: Failed to load the backend: opening module zypp failed : /usr/lib/lib undefined symbol: _ZN4YAML15ostream_wrapper5writeERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaI
Nov 05 06:05:50 Sailfish systemd[1]: Started PackageKit Daemon.
Nov 05 06:06:04 Sailfish systemd[1]: /usr/lib/systemd/system/packagekit.service:13: Unknow
n lvalue 'PACKAGEKIT_ARGS' in section 'Service'
Nov 05 06:06:04 Sailfish systemd[1]: /usr/lib/systemd/system/packagekit.service:14: Unknow
n lvalue 'ZYPP_LOGFILE' in section 'Service'

Thanks again for the help. Slow replies due to sleep, and now off to work. All very much appreciated though. Sorry for convoluting this thread further.

I had this endless list as well. Something was messed up. A version --dup followed by a shutdown -r now solved it for me.

1 Like

I would suggest you just start a new thread with the key information copied from here with a reference to this thread.

There are a few differences to my output of ldd but it doesn’t seem to be significant.
You’re right your variables in the service file seem to need more info. The Zypp-Logfile probalby needs a location where to write the log to.

Actually does zypper run on your phone? That also uses libzypp.

Looks auite similar but some libs different:
the one abiut ld-linux is normal

But something came to my mind, what version is curl? curl-7.78.0+git1-1.6.1.jolla.armv7hl?

ldd /usr/lib/
/usr/lib/ (0xf6f5e000) => /lib/ (0xf6f40000) => /usr/lib/ (0xf6ee7000) => /usr/lib/ (0xf6e81000) => /usr/lib/ (0xf6d96000) => /usr/lib/ (0xf6d6d000) => /usr/lib/ (0xf6cff000) => /usr/lib/ (0xf6ccb000) => /usr/lib/ (0xf6b04000) => /usr/lib/ (0xf6aa90
00) => /usr/lib/ (0xf6a78000) => /lib/ (0xf6a4f000) => /usr/lib/ (0xf6a3a000) => /usr/lib/ (0xf694b000) => /usr/lib/ (0xf68f4000) => /usr/lib/ (0xf68cb000) => /usr/lib/ (0xf67b9000) => /lib/ (0xf67a0000) => /lib/ (0xf6687000)
/lib/ (0xab201000) => /lib/ (0xf6673000) => /lib/ (0xf6609000) => /usr/lib/ (0xf65d8000) => /usr/lib/ (0xf65ba000) => /usr/lib/ (0xf6590000) => /usr/lib/ (0xf655e000) => /usr/lib/ (0xf6545000) => /usr/lib/ (0xf6531000) => /usr/lib/ (0xf643a000) => /usr/lib/ (0xf640f000) => /usr/lib/ (0xf63fb000) => /usr/lib/ (0xf6395000) => /usr/lib/ (0xf63800
00) => /usr/lib/ (0xf635f000) => /usr/lib/ (0xf6301000) => /usr/lib/ (0xf62b5000)

Actually, is the issue in that thread related to yours? Bricked zypper and pkcon from restarting during hung 4.3 download
Maybe @throwaway69 's findings help you as well.

1 Like

@peterleinchen regarding curl version, I have the same release as you have listed in your post.

@jollajo zypper seems to be fully functioning and happy.

  • zypper ref - goes through the repositories and refreshes successfully
  • zypper up - says nothing to do, noting 2 apps (fotokopier and whisperfish) will not be installed
  • zypper dup - says nothing to do
  • zypper update curl - says latest already installed
  • zypper update PackageKit - says latest already installed
  • zypper update libzypp - says latest already installed

I have looked through @throwaway69 's method, and am trying it now.


If an update hangs in the middle, some packages will be upgraded while others are not. If either PackageKit or libzypp (or rpm, or ssu) don’t all get upgraded together, then there might be linking errors as PackageKit and zypp try to load libs from older or newer packages that they weren’t built against.

If you end up in this state after upgrade, we might be able to find out what caused it to break from the update log, which should be found at /var/log/systemupdate.log

1 Like

The update log is from the update to at the start of September. version --dup doesn’t leave behind a log perhaps.
Thanks for the help.

I had something in mind about curl (in another version) pulling in some lib that interfers.

But okay. One possibility less :wink:
@abranson is absolutely right
and maybe take a look at versions of
but after that I am (almost) running out of ideas… :frowning:

maybe check also
cat /etc/os-release

i have exactly the same Problem.

Failed to load the backend: opening module zypp failed : /usr/lib/ undefined symbol: ZN4YAML15ostream_wrapper5writeERKNSt7_

I had the wrong curl and libcurl Versions from openrepos-lpr.
I fixed this by installing the Jolla Versions.
I checked all other package versions you posted here, they are all good.
I’m really out of idea what the problem is here…
I attached the relevant parts of my systemupdate log here:

Btw, i’ve checked my Profile Settings at and have seen, that Early Access is disabled there? I had this enabled since years and never changed it. I reenabled it now. Could this maybe have something todo with my issue?
I updated manually while using sfos-upgrade app from @olf

Okay, I found my old notes.
And some more stuff to check:

and (most and last chance) probably:

For me i have exactly these versions installed and still have the libzypp issue :frowning: