Patchmanager patches in Koli 4.0.1

Something is definitely broken in your installation: statefs doesn’t even exist in SFOS 4.

Maybe you should check the current release activate in ssu :

[root@Sailfish nemo]# ssu re
Device release is currently:

check what the version updater is thinking:

[root@Sailfish nemo]# version --dup
Finished transaction (status=2, runtime=153432ms)

NO UPDATES FOUND. Try again later.

and check if everything is uptodate:

[root@Sailfish nemo]# pkcon refresh
Refreshing cache
Refreshing software list
[root@Sailfish nemo]# pkcon update
Getting updates                                                                                                                                                                                                                                                                                                                                                         
No packages require updating to newer versions.

Working for me on XZ2c,

Thanks - i will test it. In the moment runnig step 2.
Step1 was the same like in your post.

Here are my log to the 4 commands no idea:

nemo@Xperia10-DualSIM ~]$ devel-su
[root@Xperia10-DualSIM nemo]# ssu re
Device release is currently:

[root@Xperia10-DualSIM nemo]# version --dup
Finished transaction (status=2, runtime=264704ms)
NO UPDATES FOUND. Try again later.

[root@Xperia10-DualSIM nemo]# pkcon refresh
Zwischenspeicher wird aktualisiert
Software-Liste wird aktualisiert

[root@Xperia10-DualSIM nemo]# pkcon update
Aktualisierungen werden abgerufen
Keine Pakete benötigen eine Aktualisierung zu eine neueren Version.
[root@Xperia10-DualSIM nemo]#

Sorry its a German log.

Now I tryed follow. commands:

  `[root@Xperia10-DualSIM nemo]# systemctl --user restart lipstick
   Failed to restart lipstick.service: Unit statefs.service not found.
   [root@Xperia10-DualSIM nemo]# systemctl --user start statefs
   Failed to start statefs.service: Unit statefs.service not found.
   [root@Xperia10-DualSIM nemo]# systemctl restart lipstick
   Failed to restart lipstick.service: Unit lipstick.service not found.
   [root@Xperia10-DualSIM nemo]# systemctl start unit statefs
   Failed to start unit.service: Unit unit.service not found.
   Failed to start statefs.service: Unit statefs.service not found.
   [root@Xperia10-DualSIM nemo]#`

But no result :sleepy:

@coderus - one issue is that tapping on an installed patch from Settings > Patchmanager, which should show patch info and logs, now shows “unable to load page” for most patches, but displays normally for some, (e.g. automatic call recording) - unless you long-press and tap “patch info”. Then it shows normally for all, but jist tapping it shows unable to load…

I think the reason is that I remove the bysi-symlink-bash with shellex and no the gnu-bash is not installed with root?
I found this

pkcon install --allow-reinstall gnu-bash

But I am a little bit afraid to do this. Can I make this?

Hello pawel.spoon
Could you reinstall lipstick with the command from terminal?
pkcon install --allow-reinstall lipstick-jolla-home-qt5
I will also try this because my lipstick problems see here.
Thanks in advance

man, its a month ago :smiley:
in the meanwhile i am bricking volla phone.

as far as i remember i did it via ssh
i think i did it more then once

and yes phone did survive that
it did not solve my patchmanager issues.
some patches can only install from terminal, launcher patch does not work …

any updates?

PS shouldn’t jolla try and help with solving the issues with PM? PM is a big part of SFOS, and SFOS looses a lot with out PM

certainly would keep us happy if it ran smootly. (However it appears as we’re not the relevant customers here (anymore))

I really hope you’re not bricking your volla! I had troubles going back and forth ;:slight_smile: But that’s always so!

Thanks for this! The explanation helps a lot.
So, that implies finding a solution to use patchmanager alongside Firejail will need some serious hackery.
Since any patch will stop working as soon as the affected apps receives a Sailjail profile

Maybe that’s why coderus hasn’t yet updated Patchmanager. Seems like some pretty hard nut to crack.


Did someone finally get the launcher combined patch to work?

I tried this one, but issues applying the following patches:

  1. Scrabled lockpad (SFOS 3)
  2. App Locker
  3. Devicelock faith text
  4. Fix browser icon on picker menu

Patches get ignored with an error: Unreversed patch detected! Ignore -R [n] (at least with the first and third patches). The second patch complains about a lockscreen observer. And the fourth patch is ignored with the /home directory being the culprit.

Is it safe to change 4.0.1.xx/’s defaultuser to nemo?

Did I understand correctly, that you tried to apply Scrabled lockpad -patch by command patch -R …? If so, -R means --reverse, thus patch tries to unapply the patch. And gives the message Unreversed patch detected, because the patch has not been applied yet. If you answer ‘y’ to Ignore -R? [n], patch ignores -R and applies the patch instead of unapplying it.

It does that through patchmanager

1 Like

About applying launcher combined patch I found this partial solution:

First, apply patch with CLI command:
patch -p1 -d / -i /usr/share/patchmanager/patches/launcher-combined/unified_diff.patch

Then you have to edit file:
“LauncherGrid.xml” located “in /usr/share/lipstick-jolla-home-qt5/launcher”

In this file edit line 306, where replace string:
“FolderIconLoader {“
“LauncherIcon {“

and on the line 313, there is string “folder: model.object”, erase all this line.

Restart home screen.

Now you should see more icon rows, lines and sizes of icons according to your settings of Launcher Combined.

Reverting back:

  1. Use command patch –R etc…
  2. reinstall lipstick-jolla-home-qt5

If you have made folders, you can’t enter them yet.
It needs to edit LauncherFolder.qml somehow.

Edit file:
LauncherFolder.xml located in /usr/share/lipstick-jolla-home-qt5/launcher

on the line 103
replace string:
“FolderIconLoader {“
“LauncherIcon {“

on 318
“FolderIconLoader {“
“LauncherIcon {“

on 105
erase all line containing “folder: model”

on 325
erase all line containing “index: model.index“

and on 324
erase all line containing “folder: launcherFolder.model“


It’s been quite some time, enough time actually for the build artifacts to have expired at this point. It would be really cool if we could install PM3 from OpenRepos (StoreMan/zypper) directly without relying on those artifacts for testing, any ETA when that’ll be possible?
As far as I understand PM3 is written to withstand faulty patches in that it can be disabled on boot, and not modifying files on the filesystem directly, so I personally don’t see a reason to hold back on releasing even a half-baked version.