Patchmanager patches in Koli 4.0.1

thank you i did it unforn. no patch is working even coderus patch for device xperia x F5321

Addendum to my original message in this discussion thread:

I also did pkcon remove busybox-symlinks-bash, which automatically installs the gnu-bash RPM, right after upgrading to SFOS 4.0.1.
This may be a reason, why Patchmanager 3 (the recent pipeline artefact) on SFOS 4.0.1 works fine for some and does not for others.

Plus, I also do not use the “launcher-combined” patch.

P.S.: Another factor may be, if the primary user is nemo (or defaultuser symlinked by nemo), or if it is defaultuser: On my testing device it is nemo.


@:olf great thank you

I confirm that removing busybox-bash solved the patch installation. they are now working.


yes a few one of mine topmenucontrol not or analogclock :frowning:

1 Like

same here, uninstalled busybox-symlinks-bash and can now apply two patches …
Thanks !

No home carousel doesn’t work. Is there any alternative or way to install this patch on sailfish 4?

I will update it, but I must adapt it to changes in sailfish 4.


For No Home Carousel just remove the part regarding the file “lipstick-jolla-home-qt5/notifications/NotificationItem.qml” in the unified_diff file.

This unified_diff should work:


I also got it working by removing busybox. But I get something like “loading page unsuccessful”-message when I try to read the patch info page of a patch that has only patch.json but no main.qml.
For example, I get all options of Top menu control-patch, but Return old button style gives the error message.

update: In WebCatalog the infopages are showing correctly, but not if opened from the patch list.

can confirm that installation did work with your adapted patch.

sofar: behaves as expected

Thanks !!

Just select Patch Info when long pressing on the selected patch should show you the Info.

Thanks! A small change that fooled me.

Thank you so much for ubdating it, it is already so moch nicer to use SFOS with it. It would be great though if at one poit you could make the notifications area howkit worked in older versions, where you don’t need a longpress to delete them.

1 Like

This worked for me too - Thanks.

Different behavior of Xperia X and Xperia Xa2:
On both devices, the patchmanager no longer worked after the update to Koli.
The problem could be solved on the Xperia Xa2 by “pkcon remove busybox-symlinks-bash”.

On the Xperia X, it is a new installation of Sailfish and the patch manager does not work even after “pkcon remove busybox-symlinks-bash”.
The web catalog is not loaded and the patch manager can not be uninstalled.

Storeman reports the following error:

(@coderus: Thanks for all the effort and great work over the whole time!)

During I fix the patch Browser history swipes to work on 4.0.1, I found that patches which modificate apps running in firejail are ignored. In patchmanager these patches can be applied, but even after reboot phone nothing change. For example patches: Email pulley menu, Notes app cover and others.


You may try a rpm -e --nopreun patchmanager as root, see rpm man-page.

1 Like

Did you try

patch -R -p1 -d / -i /usr/share/patchmanager/patches/patch/unified_diff.patch

as @coderus uggested above. Solved my similar case.

1 Like

@olf / @hsjpekka: Thank you very much for the tips, as I am not very familiar with the terminal, they are always helpful.
I only know the most common commands.
Since I did a fresh install on the Xperia X with version 4.0.1, I reset the device again and have not yet reinstalled the patch manager.
I will start a new attempt and follow the advices.
Greetings and thanks