Occasional 'Sim Card Removed' Message on XA2'

I see this too on my Xperia X, usually when I just leave it unattended for a while. It started a looong while ago, can’t remember when. I have the feeling it got better recently, though. (No borders nearby btw.)

1 Like

I’ve had this a couple of times (Xperia X and 10). already discussed at tjc maybe interesting info there

No borders here … I live in central southern England. The ‘Sim Card Removed Message’ almost always occurs when I’m at home. There are a few providers in range - mainly EE (which is mine), Vodafone and O2 - but these are all UK providers. The nearest other country to me is France across the English Channel some 130 miles away (much closer to me than Ireland), so there’s no real possibility of picking up a French provider. … And it doesn’t happen on my iPhone :wink:

I had this on my Xperia X a while ago, coming and going, seemingly randomly. I assumed the SIM card was loose and put a small, very thin piece of plastic beneath the SIM card, so it would have better contact. That solved it for me. I haven’t seen the problem once since then.

1 Like

Thanks, I had a look at TJC. It seems like this problem has been going on for years :disappointed: - specifically since SFOS 2 but has never been addressed or fixed - not sure why as it is actually quite a big issue because you have no idea when it happens or how long ago it happened (unless you check your phone continuously) - so you don’t know how many phone calls you have missed if they don’t leave a message.

1 Like

Yes, it was also my assumption that it was a hardware problem with the sim or the reader, but swapping sim cards and re-flashing the phone back to Android for a month (with no issues at all during that period) seemed to rule out those possibilities. When I re-flashed to Koli on the same phone it started happening again. It may be your fix was unfortunately just a coincidence - I can’t believe there are common sim reader faults on XA2, X, 10, etc - I could find no reports of problems like this (where just a simple reboot fixes the problem) on Sony phones in general.

well … it must be then the contacts. You could try cleaning the card contacts if you have the appropriate solution.

Regarding the iPhone - I think it can not be compared in quality.

I had this problem multiple times in the same day last week. Each time I had to reboot. I took out my SIM and reseated it and haven’t had the problem in the last several days. No idea if that fixed it, or if it a software problem triggered by something else.

I am having the same problem on my XA2.
This is really a big problem, as there is no way to know that you are not able to be contacted by phone or SMS anymore !
Jolla must do something ! Is there no way to restart phone services somehow without having to reboot ?
This could be done automatically when sim card is lost, as a workaround.

This issue makes phone barely usable as a primary phone !

You may try
devel-su systemctl restart ofono

I tried this and sadly it makes no difference. The only way to (temporarily) fix this problem is to re-boot - but since I have to re-boot my phone several times everyday (a) just to get the exchange email to synchronise again and (b) to make the audio work in phone calls, what’s a few more reboots? Maybe somebody ought to write a script that re-boots the phone automatically every hour so that at least the basics can be kept working :wink:

I can’t help thinking this problem is something to do with the way that SFOS seems to be unique in the way it detects the presence of a SIM card and connects to a network. In every other phone I have owned for over 30 years (Nokia. Blackberry, Android, Apple, etc) all you have to do is put the SIM in the slot and it is detected (i.e. SIMs are hot pluggable). Sailfish is the only OS that I have ever come across where you need to reboot the phone after inserting a SIM card - so maybe this problem is that SFOS cannot tolerate momentary lapses in network connection without requiring a subsequent reboot, whilst most all other phones can? Whatever the reason it does mean you can never really rely on a Sailfish phone for day-to-day usage.


No, I don’t think so. Too many other people are having the exact same problem across a range of phones running Sailfish from the Xperia X, through XA 2 to 10. It would be highly unlikely that the contacts are faulty across all of these phones and people. If it were an endemic hardware fault in Sony phones then (a) Sony would have a big problem on their hands which would be visible in the technical press, and (b) there would be lots of similar issues for Sony phones running Android - and it’s not and there isn’t.

It looks like it is a strange problem with the Sailfish software.

I remember on the Intex AquaFish from time to time it is not possible to call. However you do not know unless you try to make a call.

The the SIM card removed I have had with 2.x was gone with 3.x. On the Intex that is still on v2.x from time to time it is needed to reboot, so that you can be called or can call.

The Xperia X is mostly fine on, but I have to reboot from time to time as it starts having problems with GUI. For now it is around every 15-20 days.

The Sailfish is not Unique in the way it detects the SIM, but it is a victim of the circumstances and still much better for what it is.

  1. Nokia N9 was developed by Nokia - it used Qt4 and it cost Nokia a fortune. Nokia became almost broke (well not only because of the mobile and N9, but because of internal mistakes … they still make)
  2. Blackbarry is gone
  3. Android and Apple invest a lot of money Jolla does not have. Android and Apple control the manufacturers (or work together with them) which Kolla can not do

To put this all together it is still amazing how good it works :slight_smile:

Just as a short update on this problem, I have spent the last few weeks in a different part of the UK. This part (Exmoor in Somerset) is very rural and supported by very few mobile service providers (you have to have the right provider to get a signal at all in some places). Luckily my provider (EE) is one of the only ones that work where I was. During this whole period I did not get one single ‘SIM Removed’ message requiring a re-boot. I got home a day or so ago (I normally live in a small town well served by different providers) and my ‘SIM Removed’ problem has returned with a vengance. There must be a clue to the cause of this problem here for Jolla to look into?

1 Like

I had this problem with “Sim Card removed” several times last week with my XA2 on a short vacation in Italy.
1st time on the outward journey when crossing the border from Germany to Austria.
2nd time hiking in South Tyrol.
3rd time on the way back when crossing the border from Italy to Austria.
At 1st and 3rd I had to restart the phone.
This is very inconvenient if it causes the navigation to fail and you have to restart the phone while driving.

With 2. the message disappeared again after a while. I have no idea what SFOS was doing or restarting, but all apps were suddenly closed and the home screen was blank. But it wasn’t a complete restart.
I had the phenomenon with the blank home screen 1-2 times that day, possibly due to poor reception in the mountains.

My provider in Germany is Vodafone. Roaming network in Italy was Vodafone IT. Roaming network in Austria was A1.

Another effect of “Sim Card removed” was, in my experience, that GPS reception no longer worked.

Last weekend I was on a trip to France (from Germany) and had this message when entering France and returning to Germany. I only had to tap OK and the phone worked as before. I wasn’t navigating, thought.

You are a lucky one.
What kind of phone model was that, also an XA2?

I remember having that kind of problems with my Xperia X.

Fortunately, I couldn’t determine the behavior of the Jolla 1 and Xperia X.
Sometimes the network was gone due to poor reception in a building, for example. But that could usually be solved via the SF utilities and “restart network” or via “restart ofono” etc. without a complete reboot.

Same here on Sailfish Xperia X - when crossing borders occasionally it happens, but I had just to press the OK and everything goes on normally.