New SFOS version number without upgrade

Dear community,
I have a really strange behavior of my wife´s XP10. (SFOS 3.3)
For some unknown reasons the package management got messed up. Storeman could not install or update apps anymore. After pkcon refresh, deleting aliendalvik-control manually (rpm -e --noscript…nothing else worked) and removing patchmanager (nothing went without some difficulties) package install worked again.
What did not work from that point on was alien dalvik. I didn’t find a fitting solution for my case in the forum so I decided to delete and reinstall alien dalvik. Well, that worked. Android support was working again. But now to the strange behavior:
My wife got a phone call and the phone showed the Phone dialog of SFOS 3.4. I immediately checked the menu update section. It said “up to date”. Product information dialog: SFOS 3.4
I tried to upgrade with sfos-upgrade from command line: NO UPDATES FOUND

I never made the upgrade from 3.3 to 3.4 on this phone. From my point of view the phone thinks it´s something it isn´t. (Although the new phone dialog (swiping horizontal) shows up. I really don´t know what to think about this.
Shall I force (if possible) to upgrade 3.4 to 3.4?
Or what went wrong with my wife´s phone? It´s really weird.

Thanks in advance, broncheolus.

Well maybe it was too much I wrote. Just in a few words:
I had software problems on the XP10. Fixed them by refreshing package list, reinstalling storeman, deleting aliendalvik controle and reinstalling Aliendalvik.

Result: XP10 thinks it has SFOS 3.4 although I never upgraded from 3.3.
The new telephone dialog of 3.4 is suddenly available.

My Question: Is it possible, that my XP10 thinks it has SFOS 3.4 although SFOS 3.3 is on it?
How come that the new telephone-dialog is shown?
Can I force a reinstall of 3.4 although the phone thinks it has 3.4 on it?
Or shall I wait til 4.0 an upgrade as usual?

I know it sounds crazy but that´s the way it is.
I really would appreciate you help or just your guesses what went wrong here.
Thanks, broncheolus.

The way you describe it, it seems that one of the commands you issued inadvertently executed an upgrade instead of just refreshing you package cache.
Compare the changes mentioned in the release notes for 3.4 with your system. If they are present in the respective components and apps (e.g. buttons in Jolla Email) and both Product Info in settings as well as sfos-upgrade report the same version, then this is pretty sure what happened.

If you can provide the exact commands you used, maybe someone could tell you how it happened.

If it would be my phone I would prefer to have this sorted before 4.0 comes out, I would feel safer updating from a 3.3 or 3.4 system, instead of a frankenstein system.

In case you do decide to update to 3.4 completely (after following rozgwi’s advice and making sure) I would think this is the way to hopefully fix it.

# ssu release
# version --dup

You could run a pkcon refresh and run this again, just to be sure.

I really, really thank you for your answer!!

Following the advice of @rozgwi Here are the commands I executed. Some commands did not work because packages could not be deleted using them.

Start of the odyssey: I cannot install or delete or update packages with storeman
pkcon remove harbour-storeman
----I now forced an update of the repos (this command looks for me as if here was some damage done)
pkcon repo-set-data refresh-now true
pkcon install-local /home/nemo/Downloads/harbour-storeman-0.2.3-1.sfos3_3.3…failure
----SFOS complained about missing so I installed an older version of storeman
pkcon install-local /home/nemo/Downloads/harbour-storeman-0.1.10-1…
----now installing of StM 0.2.3 was possible
pkcon install-local /home/nemo/Downloads/harbour-storeman-0.2.3-1.sfos3_3.3…
pkcon refresh
----here AD did not start again
pkcon refresh
rpm -e --noscript aliendalvik-control-9.3.0-1
----I think, here I deleted and reinstalled AlienDalvik over Jolla Store
pkcon install-local /home/nemo/Downloads/aliendalvik-control-9.3.1-1…

Thanks. I now check the features of SFOS 3.4 if all are present.

Well I now checked the features.
New phone design, scheduled backup, add user dialog, hourly weather forecast,… everything is present

It´s so spooky, All the updates I made in the last few years took ages longer than any command I mentioned above. Thanks.

There used to be the issue in the past where the update checker would actually set the release to the current/future one (similar to doing ssu re x.x.x.x).
Doing a pkcon refresh /update would then pick up the packages from the new version.

Maybe that is what happened here?

Yes, see “[Bug] /usr/libexec/sailfish-osupdateservice osupdate-check sets ssu re”.

How come that the new telephone-dialog is shown?

You do have (at least parts of) SFOS 3.4.0 installed.

Can I force a reinstall of 3.4 although the phone thinks it has 3.4 on it?

That is what " sfos-upgrade --verify " is for: Just read its documentation.

1 Like

Thanks mate, although my question was asked quite long ago. :wink: cheers.