Mullvad app not working, neither is wireguard, help?

I like Mullvad VPN service, tried using the app, but it crashes after setting it up, manually inserting info on Sailfish VPN Wireguard never connects neither with a Mullvad config file, Wireguard app also crashes.

Using XA2.

Any and all help appreciated greatly.

You can’t expect Android apps for VPNs to work. There are already lots of similar threads.


@attah thank you for your reply. Would love to know why it is so…

Those things are handled by the actual OS, not the Android runtime… and handled differently, so it’s not just some few apis to hook up. They simply can’t work. Use the built-in vpn config, and use supported protocols (wireguard might need something extra, or not work).


Wireguard stopped working for me to, I had to remove it via Storeman as it made vpn settings page flashing so heavily, that I couldn’t even disable it.

1 Like

I had a similar problem with the wireguard implementation from javitonino. The flashing ist fixed now. Still not work for me on Xperia 10 III. Others seems to have better luck.

Well, I didn’t try Wireguard again, I moved back to OpenVPN. Might try WG again some time.

I have MullvadVPN working with Wireguard perfectly fine. I installed the Wireguard-Packages from OpenRepos and downloaded a WireGuard-Config from Mullvad. You need to delete the IPv6-Addresses in that file though (as far as I can remember)

So you can definetly get MullvadVPN to work with WireGuard on SailfishOS


Thank you for the tip to delete the ipv6 connection.
It also works for me now :relaxed:

1 Like

For everyone interested, I have written an article on the wiki: