Lost mobile data - Can make calls but only get data on wifi - "3G" displayed - 4G calling = "Not Registered" and flashing

REPRODUCIBILITY: 100% now. Recurs after a restart.
OS VERSION: (Android 11_4.19_v9a_lena)
HARDWARE: 10 iii
REGRESSION: Yes - Mobile data tested before and after device flashing. Seems to have happened in last few days - difficult to be precise as I WFH with wifi. Mobile data on the same sim still works fine on my old XA2 Plus running


Went to a friends house where i don’t have wifi, and realised i didn’t have the “3G” symbol displaying next to the sim signal strength bar.
Ticked the mobile data button, got the “3G” symbol, but couldn’t load a webpage.
Checked System Settings > Mobile Network settings:
Contract = Enabled (mobile data may b used)
4G Calling (beta) = Not registered (button flashing on and off)
I can still make calls, just not get data.


Talk Mobile - UK


  1. Turn off wifi
  2. Check “3G” is displaying and that I have mobile signal
  3. Open a webpage using the browser


  1. Webpage loads


  1. Webpage doesn’t load


None, clean install on a new device.
Mobile data tested as working before and after flashing earlier this week.



Under mobile network and there the section for your actual provider (in case of dual sim) under data access point (or similar, i have a german ui), the entry above MMS access point, and in there under protocol what is configured? IP, IPv6 or Dual? Try setting it to ‘Dual’
Edit: And make sure the rest the of configuration in this section corresponds to the requirements of your provider (Talk mobile - UK).

1 Like

Thanks for the suggestion.
The phone was set to “IP”, but trying “Dual” did not work either.

On the rest of the Talk Mobile settings:

I first tried authentication, changing it from “None” to “PAP or CAP”
That didn’t work. So i set it back to “None”

Then i spotted the proxy address was set to whereas the following page recommends
That didn’t work either.

I do have two separate APN sites suggesting slightly different settings for Talk Mobile:

Anyone know what I should be using?

My phones current [MMS access point] settings:

Connection name = “Talkmobile MMS”
Access point name = “talkmobile.co.uk
Protocol = “Dual”
Authentication = “None”
Proxy address = “”
Proxy port = “8799”
MMS message centre address = “http://mms.talkmobile.co.uk/servlets/mms

To be sure try rebooting after changing to ‘Dual’. I forgot to mention that.
You said it worked on your XA2. So try the settings you used there.
Enable developer mode and let there generate a password or assign an own one.
Open (the now present) terminal app and get super user right with devel-su (be carefull while you have super user rights). Type ‘ipconfig’. It will surely show many ‘inet6’ addresses assigned but is there any ‘inet’ address assigned (IPv4)?
If so try ‘ping’ in the terminal app still with super rights. Does it reach the network?
Try ‘ping www.googel.com’.
If pinging an address doesn’t work but pinging a domain does work and you have no ‘inet’ address assigned this thread is probably a duplicate of IPv4 mobile data connection not possible - #12 by senders, Unable to use mobile data on Sony Xperia 10 III - #49 by akikyo and [][Xperia 10 III}VoLTE conflicts with mobile data.
But you should be able to use IPv6 capable apps (like the standard browser or firefox) and IPv6 capable websites like google or ‘www.heise.de’ over mobile data. Telegram won’t work.
If your aren’t able to do so you have a different problem and i got no real clue right now what it might be…

1 Like

Thank you.

Lots to cover here, i’ll update you on what I have tried:

“To be sure try rebooting after changing to ‘Dual’. I forgot to mention that.”
Fear not, i was doing that.

“You said it worked on your XA2. So try the settings you used there.”
The settings were quite different on my XA2 Plus, and i did faithfully re-enter them into the 10 iii (see attached).
Still didn’t work after a device restart.

One thing that is different between the two phones is the “4G Calling feature”, which I had mentioned was blinking on and off. I did manage to get it to search for networks, find talkmobile, and when i came back it had stopped blinked, and was set to greyed out.
Still didn’t work after a device restart.

One thing I should note, is that when I first booted the phone (and again when sim swapping just now), I got a text from talkmobile promising a text that would contain further settings.
Neither of these texts ever arrived.

I haven’t yet managed to try the developer mode stuff.
Is there anything in what I have told you so far that provides further clues as to the cause?

Thank you again.


[root@Xperia10III defaultuser]# ipconfig
bash: ipconfig: not found

(network interfaces)

1 Like

I can’t see any inet address (inet6 yes, but inet no).
As to whether it reached the network… not really sure what i’m looking at. Under the inet6 section:

“UP RUNNING MTU:1500 Metric:1”
“RX packets:14 errors:0 dropped:0 overruns:0 frame:0”
“TX packets:16 errors:0 dropped:0 overruns:0 carrier:0”

Is that good or bad?

p.s. is there any easy way to copy out the terminal log? I can see a copy/paste buttons. but no way to select the text to use the copy function.

Browser won’t load anything. So perhaps not simply an IPv4 problem.

Trying Talkmobile support and they’re asking about APN message settings.

I can see this old topic discussing APN, but not where to find it or how to interact with it:


I guess this is the MMS access point?

Is there a possibility that i have no data because i can’t receive the mobile data settings APN message - because that message from talkmobile is sent via IPV4?


May be a progressively dieing sim card.
As it no longer works in either of my SFOS phones (the older of which has worked fine since 2019.
Also doesn’t work in an xperia 10 ii running android.

1 Like