Jolla1 does not start anymore

I decided to do a backup of my J1, and in that process it seems to have died or something. I can’t power it on anymore, and simply get no reaction from it anymore plugging in power, pressing buttons etc. I have checked that the battery is almost full using a second J1, and also switched the battery with another one, but nothing has helped.

What is the most likely cause? How can I get my data from the internal filesystems?

This link may help you…

Sadly it doesn’t work. I can enter and leave the recovery mode on the other J1, but my device seems just dead.

Sadly, that happened to my J1 as well last year (shortly after having bought an Xperia X…) - I powered it down to reboot, and it never powered up again. The yellow LED comes on when charging, but otherwise it’s dead. I also remember reading of at least one similar case in the old forum - apparently, at some point, some J1s just die… :cry:

One more datapoint: when plugging the device into a computer it will show as Qualcom modem after 5 minutes as described in this TJC post.

Any chance I can access the flash some other way?

1 Like

When it shows up as modem, you have a serial connection to it, like an ESP8266 or an Arduino. You could try to connect with a serial terminal (e.g. screen) I recommend minicom. On Linux try sudo minicom -b <baudrate (probably 115200)> --noinit -D <serial device port, e.g. /dev/ttyACM0> Maybe you’ll discover something, I have zero knowledge about Qualcomm chips.

1 Like

I tried screen, but there is no visible reaction at least on 115200.

115200 is probably correct, afaik no reason why this ARM chip should have an uncommon br or Qualcomm just blocks it per default. Was worth a try. But after looking at the TJC post, isn’t the solution in the comments there?

There is some information that @sledges provided in the meeting on 24th June. I tried the QPSTConfig tool, which shows the broken Jolla1 in download mode after 5 minutes. However I can’t get the working J1 into the same mode to download the firmware files. Since I can access that phone in all other modes just fine I would appreciate if someone can give me some hints how to get that files.

Or how to do JTAG and download the flash contents.

My J1 is in the same state since some time.

@Dakon, did you have any success restoring the broken device? Or at least find a way to get the firmware files from the working device?

if you have unlocked bootloader then you can reflash

No, sadly there is still no progress.

That does not work if the device is so bricked that you can’t even enter the recovery mode in the bootloader.