Installing SF4 to Xperia 10 II stops at unlock stage - "waiting for any device"

I’ve tried to install SF4 (paid version) onto a new Xperia 10 II (XQ-AU52) from my pc running Linux Mint 20.2, but regrettably without success.

I’ve followed all the steps mentioned in How to install Sailfish X on Xperia™ 10 II on Linux - Jolla, including an upgrade to Android 11, pointing the terminal to the directory where the image file resides, and then finally gotten the blue LED-light in step 7.8.
However, after entering the “sudo fastboot oem unlock 0x…” terminal command in step 7.10, I don’t get the proscribed result referred to in step 7.11, but rather the message: " waiting for any device ".

At first I thought that maybe the problem is that the phone was not switched on while performing step 7.10, but I deduce from the instruction in step 7.12 that it really is meant that the phone at this stage (7.10) shall not be switched on again, after first having been switched off in step 7.7.

I’ve tried with two very different USB-C cables (with intermediate full restart of the phone and termination of the terminal session), and now I’ve no idea how to proceed.

Can anybody help me?

[Edit: made the error message visible, as the < and > signs within the quote made it disappear.]

I think I had the same Issue. My way to go was using another device in the end. I wasn’t able to get it unlocked and flashed under Linux on my XPS 13. (This notebook has only USB-C-Ports. I tried different USB-B Hubs and old cables and adapters.) It wasn’t successful for me to try to set the Mode of the USB hub to some other.
Finally the solution was to use another system. Still Linux, but the HW was “older” and had some real USB-B ports.

EDIT: There is some help, which didn’t work for me however:

Also I tried some of mentioned USB-Problems here before using another system: Guide: Installing Sailfish X on Xperias -

Thanks, that was really encouraging – I also use a XPS 13 …

I really find it totally unacceptable that we

  • buy a SF license from Jolla
  • buy the exact device that Jolla tells us SF runs on
  • follow exactly those instructions Jolla gives on how to install
    and then lots of the customers seem to run into various kinds of trouble, related to problems Jolla seem to be aware of but don’t warn against or include remedy for in the installation instructions.

The instructions instruct us i.a. to use “USB-C data cable, with one end always connected to the computer”. One cannot say this so generally if one knows that USB 3.x may create problem.

I really hate it (and I seldom use that word) that it shall be so complicated and risky to get a phone running something else than Android or iOS.

Why on earth cannot Jolla offer its customers the paid service of installing SF on the phones?

1 Like

Discussion on that question:

TBH, Jolla isn’t responsible of Sony devices (well, Android devices in general actually) being delicate, when trying to get them flashed. The unfortunate part is that flashing must be “difficult” so that it cannot be performed by accident.

It’s also true that some OSes and USB controllers just don’t play ball nicely :frowning:

Here is a few things to try:

  • Make sure the cable is good: boot the phone to Android and make sure you can e.g. move a few photos
  • Use another USB port. May seem stupid, but it affects things… Don’t ask me why.
  • Run the commands as root (sudo)
  • Disable USB power save settings using powertop (see this post/topic)
  • Use older fastboot (see link above) (I hope X10II really doesn’t need this…)

After I had my X10II finally unlocked, I had to flash it twice, because it went into reboot loop. No errors, but it just wouldn’t boot up… After second try, no errors either, it worked.


Thats why I came to the conclusion to recommend flashing with the community version of SFOS first and after “mission accomplished” buy the license.

See my sad story here Sony Xperia 10 II bootloader unlock fails

1 Like

Well, at first I tried once again with the first cable by which the procedure stopped as described in OP.
The command “sudo fastboot oem unlock 0x…” this time informed me that the phone already was unlocked.

Very well. And then one step further:

Running the command “fastboot getvar all” resulted in i.a. all the correct lines as described under chapter 4 in

After a reboot of the phone and switching it off again, I went about the flashing part in ch 8 in the instructions How to install Sailfish X on Xperia™ 10 II on Linux - Jolla.
However, the command “sudo bash ./” in section 8.4 resulted in the message:

“Detected Linux
Searching device to flash…
No device that can be flashed found. Please connect your device in fastboot mode before running this script.”

From all the good advice given to me here, I got hold of a USB 2 hub and necessary cable/adapters and connected the phone to my laptop over this hub, and, Hurrah!:
“sudo bash ./” sent things along, and then finally a message of “flashing completed”.

So I booted up the phone saw the Sailfish logo, selected language, heard the “sweep sound”, entered the Pin of the SIM and user data got encrypted.

BUT then I was asked to enter the new security code anew, (and being informed that user data is encrypted). When typing the Pin code once again (and checking for possible typos), there is then no “button” to enter/OK, only the number keys on the pad, and here I’m stuck anew

There’s no way back or forward. What do I do now?

Add another number.

It isn’t asking for your SIM’s Pin, it is asking you to create the phone’s security code, minimum 5 numbers.

Thanks a lot!
– But that’s bad programming - no textual or visual clues as to how many digits is expected.

Is that security code something we have to use, since the encryption of the personal data now apparently is forced upon us?

My Xperia 10 II is now up and running SF - that really feels like a relief after my Xperia X finally died and, as an intermediate solution, I had to revert to an old Nokia to keep Google at bay. Thanks for all help!

I’ve still two major challenges, though:

A. The phone detects and can use our house’s wifi, but it seems to not detect my all-important mobile broadband - at least it doesn’t come up in the list of available WLANs. (The broadband modem (b/g/n/ac) has been used without problems by my previous Xperia X with SF 4.1, and currently works flawlessly with my pc.)

B. I would like to change the SIM card in the phone to another SIM from another telecom company. However, when I change cards (with the phone switched off), the phone thereafter identifies the card and the telco, but it doesn’t establish contact with the network.

I thought that I might solve B by flashing the phone again (which I perceive to be power off and connecting the phone with blue LED again, and the “sudo bash ./” command once more). However, when I try this, (with same cables over USB2 hub), I again get the previous response from initial installation attempt:

“Detected Linux
Searching device to flash…
No device that can be flashed found. Please connect your device in fastboot mode before running this script.”

Is there another way to change the telecom provider / SIM card?

(And for my own question posed above, I’ve found that the security code is not necessary to enter each time one activates the phone, as after installation it can be deactivated in Settings - System - (Under “Security”) Unit lock - Automatic locking - Deactivate (or however an English language version exactly designate this) – or at least set a fitting time delay before entering the security code is required. The security code is anyhow required when the phone is powered-on, and occasionally for doing some system related operations.)

After several attempts and many hours, the mobile broadband suddenly showed up to the party for some reason or another …

The future is looking brighter and brighter. :slight_smile:

That leaves me with the challenge to change SIM / telecom vendor. This issue, I realize, is not a typical Get started matter, so I will raise the issue somewhere else more appropriate.

Once again, thanks for help received!
Invaluable for a non-geek (=little deeper understanding and experience from under the hood) like me.

(I’m not satisfied, though, with the installation instructions Jolla directs users towards, since many hours of trouble could easily be avoided by adding a few sentences here and there. I will raise that also as a separate issue in an appropriate place.)

That’s true - there’s no indication of minimum length of five numbers… There should be, really.

The OS assumes you may have a SIM that doesn’t have unlimited data. You have to go to Settings - Mobile broadband (well, the item below WLAN, I’m using Finnish) and enable it there (IIRC). Possibly you have to disable IPv6 too, if you have connectivity issues.

For reference: Apple phones simply refuse to download OS updates, and Android devices don’t automatically update apps via mobile broadband. Sailfish has it disabled altogether until you enable it yourself. Same idea, different implementation. TBH the setting had me baffled for a long while, too. You should be just able to enable it in the top menu…

I cannot allow mobile data before I have connection to a telecom provider.

Where do one disable IPv6?

You have to have the SIM card inserted for the Settings page to have effect. I can’t remember how I got it enabled, but that’s the correct location.

IP/IPv6 settings is in the same page, it’s the item below roaming settings. Its “data access point” or something similar. There select protocol - IP.

Thanks, SF had it set to “Dual” (both IPv4 and v6), but regrettably changing to IP only was not enough to solve the problem.