I'm frequently being blocked by whatsapp

I’m frequently being blocked by whatsapp claiming I’m using an unofficial version.
I’m using the direct download from whatsapp.com, though.
Is this an aliendalvik/microg specific issue or has my phone maybe been hacked?
Anyone else experienced this issue?

i use whatsapp from the aurorastore and do have no problems

1 Like

I’m using WhatsApp from Aurora Store too, and have had no issues (X10III with here). Do you have MicroG installed? That can have a part in this play, but then again, as installing the apk from the official web page is a thing, it really shouldn’t require Google services…

1 Like

Owner and group has both to be “media_rw”. For example:

This applies to any directory where WhatsApp wants access.

Thanks you all for your replies.
I have microg installed and I never had any problems until recently.
Now I happen to get blocked every now and then for no reason. This seems to occur especially when trying to call someone. I wonder if this may be related to some obscure security mechanism triggered by alien dalvik?
Maybe I should check my device for android malware?

I strongly recommend to avoid using spying apps :slight_smile: but speaking of which i use to have similar issue with one of my banking’s app complaining that the installed app is an “unofficial version”. I have found out that this app is checking “Installer App” string from an app android data. To fix this issue I had to set Aurora->Settings->Instalation->Instalation method->Native installer or use App Manager from F-droid and set Fake store as Installer App in Settings/Installer.


Thanks I will try that! However, I recently experienced this issue even with the version downloaded from whatsapp.com directly.
And yes it’s a pain having to rely on (some) propriatery spying apps and I’m currently really considering installing a matrix server with whatsapp bridge instead:)

And. WOW. Thanks for the installer hint! I eventually managed to get my banking app - s-id check - work! That’s AMAZING.

@inte, then please mark that post as the “solution”, which in turn marks this thread (“topic”) as “solved”.

1 Like

Well, it actually solved another issue for me (s-id-check). Let’s see how it goes with whatsapp:-)

This is indeed a very useful finding that warrants more exposure.


Yes, that worked for my banking app as well. Where do we put this knowledge so everyone can profit? It is not really a sfos bug report, or something that can be fixed. Maybe it is a bug in aurora store and they should switch the default? Just create a separate thread here? Feature it in the community news?


This is not a bug in Aurora store. This is a “protection” that banking apps uses and that “protection” I find lame and inherently dumb. It should CRC or hash checking at least to recognize if app is “official” or not.

Just use App Manager from F-Droid to install directly downloaded app instead of using built-in installer.