Idea to improve fingerprint sensor experience on X10 III

@Blumenkraft, and after you enable that pattern, you can customize it in /etc/mce/20hybris-led.ini, e.g. by adding

PatternFingerprintAcquired=1;5;0;0;0;007b00

for a dark green short blink when the sensor is reading a fingerprint. All options you can use are clearly described in that file’s header.

2 Likes

By doing what you said I managed to find something interesting, particularly with mcetool --enable-led-pattern=PatternScanningFingerprint
Sometimes after turning on the screen it keeps scanning and then it can immediately recognise fingerprint. But sometimes it stops scanning for like 2 seconds, and this is super annoying.
Up to this point I thought it simply can’t recognise my fingerprint, but it turns out is actually isn’t scanning at all!
This seems like a bug, that maybe can be fixed.
Edit: I tried to catch it on video and now can’t replicate it… Could someone confirm if it happens for them too? That the diode singaling scanning turns off for a second?

Same thing sometimes also happens when the screen is off. It takes several attempts (or simply waiting some time) for the sensor to “wake up” and start working again…

1 Like

Mostly I turn the screen on by pressing power button (aka fp scanner).
Sometimes the fingerprint scanner doesn’t work then at all.

So I have to turn the screen off and then turn on again, and only then the fingerprint scanner works and I can unlock the phone.

1 Like

Also enabling LED patterns finally allowed me to confirm what I was suspecting. With screen turned off if you put your finger on the sensor it will only turn the screen on if it recognises the fingerprint. And even though it recognised the fingerprint it will not unlock the phone, you still need to put the finger on the sensor again. This is kind of stupid, because often it won’t recognise it for the second time, even though it did just 2 seconds before.
So shouldn’t it unlock the screen immediately after it recognises a valid fingerprint?

Well, it is… Just like requiring to manually enter the security code two times in a row during boot. But I wish SFOS only had such problems :grinning:

Of course it should. There is absolutely no reason to show an unlock screen after recognizing a valid fingerprint. To compare, iOS turns on the screen and unlocks the device at once if a valid fingerprint is recognized.

2 Likes

I can confirm. That is also my experience with the fingerprint scanner (on Xperia 10 III).

Also sometimes it doesn’t seem to scan, and 2-3 seconds later it prompts with unidentified print.

While this behavior is somewhat annoying, i’m actually surprised how well the scanner works compared to my earlier Xperia X and XA2.

After a few succesful unlockings fingerprint didn’t work anymore. Tried it a second time: same story. It worked a few times, had to tap my finger several times quite firmly against the button. Then it stopped working… It’s not a key feature to me, so I leave it.

1 Like

I created a bug report for the fingerprint sensor stopping to work, so this topic can be just for discussion of the improvement, and not the bug.

Another consideration regarding fingerprint scanning, if the first touch immediately unlocks:
accidental unwitting unlocking.

  • You might want to just pick up your phone, put it in your pocket, etc… because the sensors is on the outer edge (as opposed to a dedicated area in the back like on my previous XA2 Ultra), just by grabbing the side you might accidentally touch the button with a valid fingerprint, and unwittingly unlock it (e.g.: and then having random objects in your pocket accidentally start calling your contacts)
  • You might want to just check content on the lock-screen itself (e.g.: the stock “list of notifications” that SailfishOS provides, or the oh-so-useful “upcoming evenets on lockscreen” patch, get to the stock “camera” shortcut that SailfishOS provides and/or other shortcuts for the Settings menu or the “torch and mute on lockscreen” patch)
1 Like

I’ve already posted that this is not required.

If only Jolla could take a look into it and implement simple 60 seconds caching in Linux kernel keyring via keyctl, just like cryptsetup in Linux already does it.

PS I’m at the point where I just stop caring.

2 Likes

That was my original suggestion in the first post, just some people wanted the sensor to work with screen off too
My suggestion is for the sensor to be inactive with screen off, and only start scanning when you press the power butto, same behaviour as with my XZ1 Compact on Android. This prevents accidental unlocks, allows you to see lockscreen (by lifting your finger) and is much faster than current setup on SFOS.

1 Like

Fine, but the question is how many clicks is that fragile Power button expected to withstand. Half of it is the sensor, so its clickable part is probably much less sturdy than “full” button. In general there are problems with buttons which require dozens or hundreds of daily clicks - sooner or later they break. Like home buttons on iPhones, which were one of the most popular replacement parts. Now they’re sensor-only, no clickable part at all… Whereas you’re proposing the opposite way…

And, one again: maybe we should first check how much current does this sensor draw when the screen is off. If its power consumption is negligible (say some microamperes) then why bother at all to turn it off and require button clicks? Note that it is a different thing than requirement to scan fingerprint twice, which I fully agree is annoying and should be changed.

I’m pretty sure Sony engineers know their job.
Xperia X has the same power button+sensor and there were no mass problems with it. Hell, I have one and it is still going strong.

1 Like

My kind wish is to make this configurable and keep pushing the power button optional. As it is stated above, buttons wear, and i would save mine as long as possible.

1 Like

Yeah, I suggested that because that was the default on multiple generations of Sony phones, and was super nice to use. My XZ1c also shows no problems with the sensor. So not sure if it really is dangerous, but if it could be configurable, then even better!

Hmm… I did mcetool --disable-led-pattern=PatternScanningFingerprint and now I can’t turn it of.
Obviously I tried mcetool --disable-led-pattern=PatternScanningFingerprint and I also tried mcetool --deactivate-led-pattern=PatternScanningFingerprint including reboot but nothing helps. Green light is permanently lit when screen is of. Hints anyone?

Never mind. It went out when I deleted the fingerprint and reinstalled it.

Sure they do.

You need to restart mce. In terminal type systemctl restart mce or reboot the device.

1 Like

That is also known as “the KDE Way” of doing things…
meaning:
just add a whole bunch of settings so Everyone can do his own thing​:joy::joy:

2 Likes