Hybris-recovery.img / hybris-boot.img files for SFOS 4.4

Dear community fellows

Having waited quite a long time for a request of Jolla support without answer, I would like to ask my question here, perhaps someone could help me out?
This is no complaint: I don’t know the situation now at Jolla and what are the resources at the moment - just hope that everything can be sorted out in a way that Jolla can continue its business for all products and we can go on enjoying SailfishOS :slight_smile:

Here’s the question:

  1. I broke the display on my Xperia 10 II running Sailfish OS 4.4.
  2. Then I tried to boot into recovery mode using the hybrid-recovery.img file I got from Jolla ( → I did not succeed to use recovery mode following the provided instructions.
  3. The display is now repaired: now I can see that flashing the hybris-recovery.img results in a boot loop (until the Sony Logo). Perhaps this happens because of using the hybris-recovery.img file from the wrong exact OS Version?
  4. I am sure I had Sailfish OS 4.4 on my Xperia 10 II before I broke the
    display, but don’t know how far I updated: 4.4.072,, or 4.4.058.

Perhaps someone downloaded the image files for these versions and could provide the hybris-recovery.img (and if possible hybris-boot.img) files?

1 Like

Please have a look here. It’s complicated.


  1. Older than installed : NOT RECOMMENDED (reading stuff and altering config files is O.K., but a fsck , resizing a filsystem and LVM actions etc. should be avoided)
  2. Same as installed : RECOMMENDED (theoretically the best)
  3. Newer than installed : RECOMMENDED, but may expose issues in niche cases, which might be avoided by directly upgrading to the SailfishOS release (or any newer one) the recovery image was from

Unfortunately the official statement is still the same (EXACT same version only).

Also maybe one of the torrents here can help. If you go this way I’d appreciate feedback about it being seeded or not.

Also see here and here.


1 Like

Since the XA2 SFOS versions following the, the recovery sshd password is broken. (see [hybris-recovery] Password not accepted)

So, I kept being using the hybris-recovery.img version until now, even with the 4.5.
I didn’t have any troubles.

However, I am only:

  • Unlocking and mounting the home in the shell (option 3) to access it with the PC through sshd (option 5).
  • in the shell (option 3), saving the whole filesystem into an .img file on the microSD.

Maybe some other action with the bad version could break something…

1 Like

Thank you for your help! Encouraged by point 3 and after finding out that from SFOS 4.4 some hybrid-recovery.img files only produce a boot loop ([Xperia 10 II] Unable to reach Recovery Mode - #11 by launchpad), I tried the latest one from 4.5 which brought me into recovery mode. I could copy all important files and even extract the hybris-boot.img and boot again into the intact UI.


Thank you for help! Even my problem I could solve with the latest hybris-recovery.img from SFOS 4.5. I copied the files of the home directory by following the instructions on SD Card in Recovery Mode | Sailfish OS Documentation, so I didn’t encounter the broken password problem