[How-to][Hardware] Fix XA2 GNSS(GPS): Let's Try harder

Yes. If it starts with:

  • GP = GPS
  • GA = Galileo
  • GB = Beidou
  • GQ = QZSS regional GPS augmentation system (Japan)

GSV = satellites in view sentence

I was quite happy with the overall navigation performance of my XA2. But I didn’t use navigation for a few weeks was impressed that the first fix then took me more than half an hour, the second one some fifteen minutes after which everything seems to work good again.

Indeed, dirty contacts cause a long reception time of ephemeris which is needed for a cold start.
well…one theory between others…

After travelling 600km with no GNSS use, the GNSS receiver should be in a cold start state, theory says. Hence it’d need at least 12.5minutes to get a fix.
Mine needed less than 3 minutes IIRC. (GPSInfo says 21 seconds but sometimes stops counting before having a fix).
Anyways, too fast to fit with theory, so… I don’t know how it really works.

Try to open and clean yours! Who knows…

I think the theory says that full ephemeris (for the whole GPS constellation) requires 12.5 minutes minimum (read without lossing frames on reception). But actually four satellites are enough to get your position, if their ephemeris are received first, then you can get a fix in less than 12.5 minutes. At least that’s my understanding of the system ; )

1 Like

Oh yes, so evident.
Thank you.
I thought the full ephemeris was necessary to even use some satellites.

Ok, I’m done. I was that guy.
I am not anymore.

For some three years I always used by XA2 for navigation nearly on a daily basis and told everyone that there were no serious problems with navigation if one gave it al little time and patience. First problems showed up a few weeks ago:

Last weekend I went on a tour with my car for some 300 km (200 mls) in a rural area with sunny weather and nearly no clouds visible. Navigation had degraded so much, that I had to take a turn at least three times. Back in the city things did not actually improve.

So on Monday I decided that my XA2 would return to Android and live on as my Idiot-Phone with Lineage and MicoG. (My old Samsung S4 will retire eventually).

Yesterday I flashed my new Xperia 10 III, restored my backups and I am totally i m p r e s s e d how much better GPS/Glonass/Beidou work here. Nearly instant fixes even in closed rooms (near windows, though) and an overall good user experience.

I will report how navigation will work once the XA2 is back on the dark side of the force.

1 Like

My impression is, GPS malfunction more depends of hardware than of SFOS. My last experiences with XA2 is more than 2,5 years ago, so no more relevant. But i can tell abt. X10 and Volla.

Time from switching GPS on & starting GPSInfo to valid position fix:

Sony: 50-60 sec.
Volla: 3-4 sec.

Conditions: rural area, in the house (small house), GPS not used before for a few weeks. SFOS (X10 meanwhile updated to …68)

1 Like

Better for me not to try a 10III then.
Considering the global situation, I try not to consume more goods than I really need but I don’t know if I could resist when trying one.

But I have to say my XA2 really works good after the hw repair. GNSS fix generally happens within the first minute. Sometimes within 2, rarely 3 minuges. Since approx 2 month now.
Especially cool since one month, I am travelling, no probs.


Good idea @ric9k , mee too. Sometimes here in the forum there’s a used X10 ii or iii for sale.

Your are right. As long as the fix works there is literally no reason to give up on a good XA2.
I will try the XA2 with Lineage, then maybe fix the antennas. I needed a replacement for the Samsung S4 anyway.

I second that. Degradation came suddenly over a few weeks and my GPS did a great job over three years in many countries in Europe before.

1 Like

On August, the first I did reflash my XA2 after navigation failed me pretty often and pretty fast after the first signs of degradation.

My new 10III does a much better job. No surprise.

But my old XA2 now with Lineage 19.1 and MindtheGAPPS suddenly appears to be navigating again with some success. I only tried inner city areas with good coverage and lots of networks but the combined navigation in Android with phone cell and WiFi triangulation sure takes a lot of the pain away.

I will do some tests in rural areas and see what happens there.


And after a trip on the German Autobahn, where cell coverage is pretty good, navigation still works on the XA2, Lineage 19.1.

1 Like

I think I can really testify now that my XA2 is fixed.
After I travelled this summer, the fix makes a huge difference in GNSS performance.

Before, it was a nightmare, now, it just works!

So, take your tools, go slowly, breath and think, and save your XA2!


I found something.
Reading the log of the community meeting from Feb. 2nd, 2023, on a question @Cryx asked, @flypig mentioned two config files (10:09:00) and asked for feedback (10:09:13).

The config files are:

These files have identical content but are independent files and must be edited both.

On top there’s an entry

Here is my feedback:

Setting this variable to true:

fixes a lot of problems. Time to position fix (GPSInfo displays valid data) is now 1 sec on my Volla and a few (2-4) seconds on my Xperia 10, while in flight mode and no WLAN or other network connection, GPS settings is GPS only.

Before this tweak it was 10 sec on Volla and something between 5-30 min (or never) on the Xperia 10.

Maybe also an option for the XA2…

edit: Tested time to position fix again next day on Xperia 10. Result is, the same problems occuring as always, and I must confess this ‘hack’ attempt is worthless. So don’t waste your time on it.


Wow… If you found sth after so many tries of so many people for so long, you will deserve a krown!

Cannot test atm.
But I made the changes on XA2 and will report in case of improvement.

But what agrement is it about? Mls? Would have thought the change in the file would have been made when we agreed the Mozilla thing in settings…

Let’s try tomorrow.

The gps.conf file was overwritten in the update to 4.5 so if you think you’re using suplpatcher and still waiting forever for a fix, just fix the file and reboot and make a backup this time. Tested on XA2.

Full instructions here:

Relevant bits:
/etc/gps.conf (Xperia X, …)
/system/vendor/etc/gps.conf (Xperia 10 II)
/vendor/etc/gps.conf (Xperia 10 III)

FOR unencrypted SUPL SUPPORT, set the following


for 4G devices


1 Like

I didn’t see a difference in GPS usage.

By the way, I wonder why we do have /etc/location/location.conf and /var/lib/location/location.conf?

Both files are identical…
Probably a change due to an upgrade, where the other one has been forgotten to remove.

I’ve checked now on a Xperia 10 that was flashed with a few weeks ago and had no updates. There also both paths + files present.

Fix in 125 seconds!
Comming back to the original topic to testify this procedure is working.
I used to have doubts about the causes of those XA2 GNSS problems on XA2.
I am still not very sure SFOS isn’t involved.
What is sure is that I saw today again a huge difference.

After some falls and/or dirty contacts, my XA2 GNSS again became useless.
Yesterday evening and this morning, I tried for respectively 20 and 40 minutes to get a fix with no success.
All bars in Gpsinfo’s graph were orange-yellow. Very weak signal an no fix at all.
Tonight, I did the procedure described in the beginning of this thread:
-Unplugged the battery,
-I bended the contacts again very carefully,
-I very carefully moved and back (<1mm) the 4 staple-type contacts on the antenna board,
-I scrubed all contact points lightly with wood/toothpick to clean them, especially the aluminium top cap which oxydate/bcome dark.
-New test: I put a little bit of contacts grease (silicon grease) on each contact point.

Reassembled, tested.
Fix was incredibly fast: 125 seconds.
With a very good signal quality (green), and up to 48 sat in sight.

Patience and delicacy seem to pay!
It’s worth giving a second life to your XA2 GNSS!
Just: don’t be in hurry, take time, be delicate.


My XA2 fell to the floor a while ago and the top cover fell off, I glued it back together and didn’t think any more about it.

Recently GPS fix time became very long and even when receiving a signal the quality was low. No software updates were done close to when the issue presented itself.

Found this thread hinting the issue could be related to the top cover, so I removed it, and noticed dirt had accumulated on the contacts. I cleaned the contacts and glued it back together again, now the GPS fixes fast and signal is solid.