How fix a borked MIME handler for links?

Any links shown by Sailfish apps get opened by Microtube instead of Browser.
I tried deleting the .desktop file belonging to Microtube in .local/share/applications and executed update-mime-database on the system path in /usr/share....
Still there’s no dialogue letting me pick either Microtube or Browser to open a link. It goes straightly to the former.

How can I restore the MIME settings for this properly?


Take a look at this thread:

the title is different but the bug is the same.

Hope someone at Jolla will fix this.