Has anyone gotten Google Maps to work?

I installed microg and Google Maps but havent been able to get it to work (gps never finds where i am located, so its unable to give me turn by turn directions while driving). I can get it to list the turns needed to take by entering in the starting address and the destination, but this isnt nearly as handy. Its probably not even possible, but wouldnt suprise me either if someone mamaged to get it to work.

Related issue: unable to open various apps because GAPPS is not installed. MicroG doesnt get the job done, at least for me.

Thanks in advance!


Have you tried pure maps?


I use Waze which is based on Google maps but features speed cams and other nice community based features. Works fine with microg

1 Like

I insralled microg and waze and i get the same problem: gps does not work. I also tried puremaps and it didnt work with the gps… Maybe its a hardware issue then… :frowning:

On which device? The XA2 Gps thread is kinda legendary. Probably one of the longest here.

test result wit 4.4

i just tested it again on my XA2 Plus it took half an hour for the frist fix and 4 fixes with arount 14 Minutes for being operative but as told it is a problem of the XA2
for testing the app gpsinfo is quite helpful after this time i could use puremaps without any problem

I am using an xperia 10 plus. Waze does not work, microg doesnt work, pure maps doesnt even work. I will try and find the gps thread you mentioned

I use custom MicroG version for Vanced. Google Maps installed from the Aurora Store works just fine. GPS fix in about one minute. XA2 Ultra Dual, OS 4.4.