General usability (of this forum) with SFOS browser

@peterleinchen I agree with you that the usability of the forum should be better with the sailfish browser. Virtual keyboard hides the text box, for example. An app would be great.

On the other hand, together.jolla.com wasn’t very handy either. But I liked the distinction between comments and answers. And one was able to edit his posts. Btw. just earned an Editor badge. At the end of the description:
“Edit to make your posts even better!”

But back to the link-problem: How about tapping at the browsers address bar, and when it expands to show the favourites, reselect the address (click ones to clear the selection, and press&hold to reselect). Reselecting copies the address to the clipboard. Or press the two circles below a post on the forum.

1 Like

Yes of course you should be able to correct typos. And remove posts, if they’re wrong or based on a misunderstanding IMO. Repost if that happens. That’s what I meant by ‘sparingly’.
Wiki and summary OPs - like XDA - are clearly useful. (Not so sure about wiki non-OPs. We’ll see how that goes. )

That was an addition to your post, which wasn’t there when I first read it, and did not get notified. A good example of an edit that should not have done after 12 hours IMO.

‘not very handy’ is an understatement. And for some purposes - the very long official release posts, where the question appeared on every page, it was terrible.

Askbot was a Q&A site, like stack exchange. This is a forum.
The answers/comments distinction worked well if people were disciplined, but many answers were just comments. Comments were often just as useful as ‘answers’:
I had to write a browser addon to notify me of new comments because askot didn’t.
Here the notifications work pretty well. (Provided people don’t make major changes to their posts!)

Enough from me on this subject I think.

2 Likes

Yes. :slight_smile:

Yes. :smiley:

This is the normal workaround to get the site address into the clipboard. But I want the (detailed) post address.

This is what I am talking about: pressing this two-circle button opens another text edit box and SFOS browser cannot copy from that!

above post

Aaannnd I just found that the adress bar in fact has the correct link to the post at the tip of the screen. Magic? :thinking:
So discourse SW has worked around that bug!

My “workaround” for the blind typing:

  • enable desktop view from the hamburger menu beside your user icon
  • after edit box is open, swipe the keyboard down, drag the handle to the top (as much as you like)
  • tap in the box and type some characters, then add many many empty lines by fire-button-pushing ‘return’ (as much as the text begins to flow), drag’n’move the text inside the box to the bottom, tap again on top line and begin to type

Now you are able to see what you type and you can move the already written text up and down…

Remark: this works only in portrait mode, no chance to write in landscape :frowning:

1 Like

My workaround so far is Notes app (just write all beforehand and just paste)

2 Likes
the 90's

Uh, that sounds so 1990’s… :smiley:
No problems with newline / carriage returns?

But when I switch to landscape I can see the preview. Handy when you are posting links, oneboxes, quotes…

1 Like

Oh with quoting/partial quoting it will almost for sure not work, but no issues with crlf from what I’ve seen for now (still hoping 3.4.0 browser update will make it somewhat usable at least, we’ll have to wait and see)

1 Like

My guess: You’ve performe-d this action too many times, pls wait 1 minute bef-ore searching again? Not sure what else could be rate limited

1 Like
Summary

Yes! :smiley:
But which action? I swiped away the browser to read an email and then that popped up.

1 Like

Oh… No idea then, unless you left the browser on search results and it auto-reloaded it triggering that? If search was not involved really not sure (check url next time, ending could give hints on what went wrong)

1 Like

Following a hint and trying o delete the full post above.
Please see here


for further discussion.

Now quoting above post swithout the third picture attachment link:

But thar wrongly uploaded pic is still on the server viewable via
https://forum.sailfishos.org/uploads/db4219/original/1X/dbb90920873addab1893c11c837aedc42afdec1a.png

Moving this thread under Applications. It is not related this site (forum.sailfishos.org)

This post was flagged by the community and is temporarily hidden.

1 Like

No issues on this site with the current (3.4.0.22) default browser.

2 Likes

The keyboard still overlays the composing window for me, which sucks.

4 Likes

We have an open bug report about that in our internal bug tracker

6 Likes

Thanks for letting us know…

1 Like
inappropriate?

General usability (of this forum) with SFOS browser

As written above in the edit I would like to know what makes you think this is inappropriate?
Please make use of PM…

You are right. I was using the forum with the Gemini PDA (no virtual keyboard). On my Xperia XA2 the composing window is hidden by the vk when replying to posts (but not when creating new posts)

1 Like