Email Sync always up to date doesn't work

Hi there folks,

I recently made a fresh install of on my XA2 single sim and realised non functioning sync of emails when selected the up to date setting - no new emails are recognized until I explicitly open the account in the email client. If e.g. 5 minute interval is selected, it does work. Can somebody confirm this behaviour or am I missing something. It did work on previous versions. I reflashed my device because the last update corrupted the system to much. So I am not sure if the previous updates really went smooth and updated to the current versions of packages.

best regards,

Which kind of account have you set up? On which frequency should your email be synced? I mean, what did you select?

On my side, I have 2 general emails account which are synced twice a day and I noticed no error.

My OS Language is german. When I select “Immer aktuell” under “Synchronisierungsrhytmus” I don’t get any emails, never. Unless I open the account in the email client and then the sync happens. With the interval setting e.g “Alle 5 Minuten” the client gets the newly arrived mails from the mail server - so this works. With my old set up I got new mails immediately.

Oh, I misunderstood your title. I just set up my general account to “always up to date” and if I open the E-mail client, it shows as updated. I tested sending an e-mail to myself and I received a notification.

Have you enabled Battery saving mode? In this case, it will disable option “always up to date”.

If no, you can enable some verbose mode. I followed this tutorial to get some logs. I had to restart my phone because restarting sailfish-eas didn’t work…

There has been a problem with always-up-to-date email synchronization for years on SFOS and across many releases, especially if the email account is Exchange and not IMAP. It works at the start, or after a reboot, but then for some inexplicable reason the background sync process just appears to stop and you won’t get any further email unless it is either restarted or you force a manual sync (which rather defeats the object of it).

I believe Jolla made some changes to help improve the Exchange sync in 4.4, but I got so fed up with it for so long I changed to IMAP and set a period sync of 5 minutes. That’s worked reliably ever since.

Thanks for the advice. I will try the tutorial later on. The phone is not in Battery saving mode but i will have a look at the logs. I forgot to mention that i have two IMAP accounts which i checked with several settings. The start page of the email client also show “up to date”, even though the sync did not happen. For now I will live with @Steve_Everett solution.

Could you please edit your post to a bug report?

There are already bug reports on problems with email sync, both always-up-to-date and periodic:

And on the old Jolla Together forum, the following posts:

Its an old chestnut …

1 Like