[duplicate] [4.2.0] [4.3.0] Fingerprint stops working

BUILD ID = OS VERSION: (and at least 4.2, too)


Fingerprint reader stops waking up or unlocking the phone after some days of uptime. CSD tests show that the reader in itself still works, it just doesn’t do anything.


  • X10II
  • Fingerprints added


  • Several days of uptime
  • Try to unlock phone using a known finger


  • The phone unlocks, or wakes up


  • Nothing happens


Restarting the phone fixes the issue.

Restarting sailfish-fpd.service helps, so a reboot is unnecessary. I have tried the service restart 2-3 times, and it has so far worked every time. I haven’t been able to get any meaningful logs yet; the last two times I tried simply with devel-su systemctl status sailfish-fpd.service the log was rotated out already.

1 Like

This seems to happen on XA2 too, for SFOS 4.2 and 4.3. “systemctl status” never showed anything suspicious, even when it wasn’t rotated. Related: Possibly a race on boot: fingerprint not operational.

Thanks for comments.

I think this issue is not a race, because a reboot fixes the issue. I’ll add it to the post…

Duplicate of Fingerprint record lost randomly

It’s not duplicate, since the fingerprint record is not lost and the record doesn’t need to be recreated.

Edit: Well, it looks they do disappear.

Well, it is only seemingly lost (i.e. lost from the GUI) there… not actually lost.
Reboot and restart of sailfish-fpd (twice) helps.
But for you they still show up, but refuse to work?

I think they remain in the list, but I’ll double check the next time it happens. (Had to reboot yesterday; ofono. Edit: Fingerprint works after reboot, as expected, in my case at least.)

Have the same issue. It works quite a while after reboot, then suddenly stops working. In the meantime I think it is related to the memory issue on the 10II (see bug report RAM management issue). The OOM killer may not only kills the apps, but also some daemon handling fingerprints. Is this posible?
Can someone tell me, which log contains usefull information?

OOM killer could explain the randomness of the issue… I’ll try to put some memory pressure on.

I also encounter such a problem on the X10II, which is annoying. Before I saw your post, I unlocked it with a password or reloaded it. Now I’m thinking of adding your team to the cron.

I rebooted the phone yesterday, but I think I didn’t try to unlock using fingerprint… This morning I tried, and it didn’t work. There are no fingerprints in Settings.

So, I think I have the suspected boot race condition ongoing… What logs should I get?

As this has happened a few times now, and for all times the fingerprints have disappeared from Settings, too, this is a duplicate report after all.

My fingerprint problem has gone away, but another one has come in its place, even worse