Contact photos gone

I’ve checked, and ALL the JPEG codes in the .VCF are changed.
PNG encodings are untouched.
Most of them are shorter.
The whole \People\data\all.vcf file inside the backup is much smaller now.
(2019 = 3.1MB » 2021 = 2.0MB)

Happened to me as well - but for one single contact only. Did not touch contact’s data for two years or more. I deleted the initial picture of the contact a while ago, but contact data was nicely showing the pic. My guess is the image is stored to the vcf data of the contact - is that correct?

Survived some updates of SF OS. Now, a week ago, out of nothing, the picture is not displayed anymore. No activity from my side, no restart or update involved. Just… magic.

As of now, I updated the contact’s photo manually by a newer one.

Running SF OS on Sony Xperia XA2 + Android support. Using the native contacts app from Jolla store.

1 Like

UPDATE, unsure if anyone posted this before:
Photo of another contact was gone, BUT when this person sent me an SMS, the contact photo was shown in the events preview.
So maybe this is a display photo in the contacts app issue?


UPDATE just noted inside the Phone (!) App:
‘People’ tab on the upper right shows dummies (just the contact’s first and last name) for my favourite contacts. Only the one contact of which I refreshed the picture manually is displayed correctly.
Inside of the Contacts App, all of my favourites are shown with the picture I linked to, 2-3 years ago. When picking one of those single contacts’ details view, no image is shown, just the blank default avatar head and shoulders.

Yes, that was the case for me too.
Only newly added pictures where able to show.
It is obvious, that they somehow reconverted all the old pictures to a non-readable format.

Is there any bug ticket opened for this?

@DEVELOPERS: does any of you reading this?

This is very interesting! It would mean, the reconverted photos are still readable somehow.
(Although I still disagree about the thinking of SFOS developer, who is responsible for this. An original JPG should be never recompressed, because it just gets worse.)

Are you absolutely sure about this that photo was yours, not an “auto-online-refreshed” one?

I’m pretty sure that avatar photos are not changed but it’s something changed about permissions of apps reading them.

It happen again on my X 10 with 4.3 release. I’ll try reimporting all.vcf from freshly created backup. At least that helped a few releases back.

1 Like

I have te same issue and never got to solve it. Finally I added avatars manually for my contacts (I only had 10-15 contacts with avatar) and I did a backup.

YES. Absolutely. 100%. Was a picture I assigned to the contact approx. 3 years ago. Reliable behaviour back in the day: Take a photo - assign to contact - delete photo in Gallery, but is still shown in Contacts App. Makes me guess the photo is “coded” into the contact’s details, independent from the Gallery.

Additional DEBUG info: I compare two contacts now, in the Contacts App.

  1. An “old” one, picture taken 2-3 years ago. Contact photo does not exist as a stand alone image on the device, nor SD card. Image is shown in the “Favourites” of the Contacts App.
    When I tab that very contact in details view, no image, just the dummy head/shoulders.
    Now I choose “Edit”. The area left to First name, Last name, Nick name is just empty. No head and shoulders, nothing. Blank area.
    I tab that area. Options now are “Choose from Gallery” - and “Delete Avatar”. Cancel. Back to Contact App’s main view.
  2. Another contact, as old as number 1, but picture recently refreshed by hand, as it got missing for whatever reason. Tab on contact for details. Image is displayed properly. Choose “Edit”. Picture shown left to First/Last/Nick name section. Tab on image. Same info given as above, two lines to choose from, BUT the distance between those options is larger than in case 1, estimate: 4-5 lines. Cancel.
    Both contacts are stored in the (local?) Address Book (“Adressbuch” in German).

What I recently changed, in general: Enabled Android support and added some Apps from F-Droid store. And updated SF OS, of course, as of now: on Xperia XA2.

Hope this helps.

Would like to help debugging (a little, at least - as long as I am still in the post New-Year’s-Eve-mode :wink:

I could look up differences (?) on my phone, but need help as I have no idea how contact images are stored these days. Thought they were part of the database (or .vcf), but discussion above shows me they are not (any more).

So my question is: How are images attached to contact data? Stored somewhere on filesystem, linked via UID?

You can click “Backup” button on your phone to create a .tar file.
Inside that >> People dir > data dir > all.vcf file.
That is a simple text file you can view or edit. The bigger sections include the photos.
You can compare with older backup to see the image code difference.
(I did that too … but had no time to extract an old + a new one to copy here to show the difference yet.)

1 Like

Confirmed. My files are dated: 2021-12-04 and 2021-07-21

  • Newer one is 75.9 kB in size, approx. 3039 lines
  • Older one is 16.9 MB in size, approx. 218650 lines
    Looks like the .jpg code is totally missing in the newer file

What I did NOT do in the time between July and December:
a) Delete 98% of my contacts
b) Change any of the contacts backup settings - I would not know where, and how

My conclusion, as of now: Contact photos are missing in the all.vcf backup file. Something has (been) changed in the backup behaviour.

Any confirmation, disproof, or bugfix available?

Thx in advance

Just another data point: when I finally upgraded my Xperia X from - stable version) to the latest (I upgraded to the stable 4.2 first, then upgraded again to 4.3), I also lost most of the avatar pictures I had set at some point in the past. Like described above, they do shown up if someone sends me an SMS, but not in the “People” app. The “People”-tab in the “Phone”-app is even worse - there, none of the avatars are displayed anymore. The contacts are also synched to a Nextcloud account, and there, I can still see some of the avatars, though in some cases I only see an older avatar.

1 Like

I think this may be a known problem.

You’ll need to get the all.vcf file from a previous backup and reimport the avatars: but I don’t think this is a permanent solution.

Previous posts on this topic by me follow, with much input by more knowledgeable people than me.

1 Like

I just gave up on contact photos. This is bad.

1 Like

Updated to on XA2.
Phone App - contacts/persons: Only one contact I recently added a new photo is shown. All the rest of my favorites only show: Last name, first name instead of an image :-(.
Contacts App: Same (as of now) six favorites here. Image is shown for a total of FOUR contacts, thereof: three older ones and one picture recently taken.
Two native Jolla Apps, different behavior?
For me, rolling back to an (outdated!) .vcf file that contained more pictures is not an option.

Professional, future-proof solution appreciated.


I use a workaround: create a fresh backup, extract file all.vcf and manually merge missing pictures with a GUI diff tool from backup that contains them. After import contact pictures are back. It’s manual process but at least it works.

Yes, filip.k, this is an approach. But…

Hey, this worked back in the day. I am too much “just an ordinary user”. Although I know what diff is, this is NO!!! solution for me. Not for regular backup, or update process.

Strictly speaking, some whatever-whenever update of Sailfish OS deleted! my! user! data!

I apologize, but consider this to be a bug. Once it worked as it should, now it is worse. I still hope for a fix. As of now, there are 1-4 contacts left ;-( I have a nice/working image of.