Can't get into fastboot (nor flash) mode. Xperia 10 III. Help! Pretty please

I got a new SIM card, recently. I started having connectivity issues (card working only within certain conditions). I thought reinstalling SFOS would help. Ouch!

I followed the guides provided, and I was able to get a working android phone (made calls, surfed web, used hotspot, etc.); I set myself to install SFOS again but…

I don’t get a blue led anymore! Every time I keep the Volume Up button pressed while plugging the (original Sony) USB cable in, the led stays red and the phone starts loading the system. I thought about reinstalling Android again, but LED won’t turn green (Volume Down) either!

By the way, I read about the autosuspend issues, but I also gather they were solved time ago… And my computer is from 2009, no USB3 here.

I can’t install SFOS, I can’t use Emma, and I can’t use Xperia Companion either because the PC (or the programme) does not see the phone, when I plug it in.

I thought about discharging the phone completely and see if anything happens, but I am not that confident in any results from it (I just do not know what else to do…).

Any suggestions are welcome! Thank you.

I can get into recovery mode, by the way. I ignore if this would help…

Solved by who? It has nothing to do with SFOS. Or maybe I misunderstand you.

If you’re on a Linux computer you might want to go through this checklist and maybe also read this.


Thank you, @ohnonot.

As for your guides, I will go through them thoroughly. I really hope the solution lies somewhere there. Thank you for your help.

As for the autosuspend issue being solved, I was referring to …Jolla?


Oh, I didn’t know it was possible to do that from within the installer - even so, I had this problem long after that release came out.

1 Like

Make sure that the phone is fully turned off before you start. When you keep the Volume Up button pressed and are about to plug in the USB cable, there must be no red LED at this moment (as the phone should be off).

After plugging in the cable, the LED should turn red for a couple of seconds and then turn blue.

If that did not help, try using another USB2 port of your computer.

1 Like

Have you enabled the developer mode again in android?

1 Like

Okay. So, I got my olde faithful working again. @ohnonot, @jovirkku, @chris_bavaria, I want to thank you for being there and helping me.

At the end, having done and tried pretty much everything else, I did try to disable autosuspend but it didn’t seem to do anything: phone booted normally, and no blue light. Yet, I got lucky.
More out of desperation than else, I got into recovery, and there I did enter fastboot mode. I made sure that the PC could see the phone ($ fastboot devices), and while still in fastbootd I did reboot system KEEPING the Volume Up button pressed.

Unfortunately the issues that had made me reinstall the system are still there, but this will be another story…

BTW, @ohnonot, great site! I had found it in the past, but totally forgotten about it recently. Thank you.


Did you tried with several different USB-C cables?

I did a rookie mistake forgetting to check it and used microUSB cable with USB-C adapter which I often use for charging. That’s fine for that but less then useless for flashing. My many unsuccessful attempts left Xperia 10 stucked in a strange state with 3 short red LED pulses on power button press. Was unable to power it off even with Sony recommended forced power off 2 minutes power button + Vol up press. Had to drain the battery completely for more than a week. Not recommended :wink: if you only have Nokia from 2010 available.

No, I tried with the original Sony cable (which for long was the only USB-C cable I had, by the way); it had always worked fine, previously.