Bug: Galery App practically unusable, Bug in file operation

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product): unfortunately since at it seems now
HARDWARE (XA2, X10, X10 II, …): XA2 Ultra, but also Intex Aquafish (OS 3.xx) running as Jolla C, JP1
UI LANGUAGE: German, English
REGRESSION: (compared to previous public release: Yes, No, ?): No, since I use Sailfish a know this behaviour


Moving files changed the LAST MODIFIED date as well as CREATED date. Last Modified date HAS to stay, as well as created date. Just because you move a file you neither change the content nor are you creating a new file, you just change the saving location.


Have a picture in one folder with a date earlier than today (datetime.now)


  1. chose a picture at least older than today
  2. move picture from folder to another (either phone to sd card or phone/sd card to 2nd folder phone/sd card)
  3. check the timestamps for file the dates will be changed to last time file moved


Date stays as it was


Dates are changed and now the Gallery app display 6 year old pictures BEFORE photos that I just shot 10 mins ago (before file movement). The order of pictures gets completely destroyed and since the Gallery app doesn’t segregate pictures into folders and shows everything at once you have no idea what is where any more and why everything is suddenly mixed


(Please ALWAYS attach relevant data such as logs, screenshots, etc…)
I’m not sure if this is a bug on file system level (I assume so) but I have used ALL available file managers for Sailfish and always had this end result as behaviour.
For the record I tried with the followings apps:
Fileman, Cargo Dock, FileCase, File Browser, Filecat, Filetug (currently on my phone)
For displaying I used: SFOS Gallery app, ImgOrganizer, Sailphoto, Imageworks Photofunia, LLs vPlayer, Android Apps, Android Gallery, Android Filemanagers.

I mentioned this behaviour already in the old Forum in 2014 !!!
And just now realized that it seems like ALL time stamps get changed when a file is moved.
Sailfish is in this case absolutely NOT reliable for using dates as a trustworthy source of information.

In my opinion this is a serious issue that hasn’t been touched in 7 years.

Do others see this effect too or did I somehow destroyed my Sailfish environment and this is something unique to my installation(s)?


Sorry for a repetition, I also answered to your other question here. One of my apps called ImgOrganizer does support fetching timestamps from metadata. If enabled system creation or modification dates are only used where EXIF timestamps are not available. You may enable this feature in Settings / JPG Album and Date from → Metadata. You are also able to set albums to make it easier to find your images. This info is stored within JPG files and remains available when opening these pictures in programs like Shotwell or Adobe. Hope it works for you.

1 Like

In the case of moving from/to Sd card , which filesystem is on the card?

Because AFAIK fat filesystems only have one timestamp not three (not sure about ntfs), so moving files to and from such a fs are bound to lose some time information.


Good hint! Didn’t think about that at all. In fact Storage part in Settings tells its VFAT. Strange I thought I formatted the card in the phone but I guess it was in my old Intex and SFOS2 still.

But that is also not the solution I just tried to move a file in phone memory from downloads to downloads/newfolder and the file has immediately a changed creation date.

I know your app :slight_smile: I even mentioned it above.
This was the catalyst for my threads as it made me realise I can’t handle the files like this anymore.

I just changed the settings to metadata and now the app crashed after leaving the settings. I have seen this now whenever I change settings, is this a bug or do I use it wrong?

Hi, this bug happened in ImgOrganizer when scanning large amounts of images and should be fixed with today’s major update on Openrepos.net. One now can optionally parse filenames for dateTime where metadata dateTime is unavailable and system file creation dateTime undesirable. That hopefully covers your use case as well.

To all others in this thread.
Please check out @tplabs ImgOrganizer app.
It is now really awesome. I can only highly recommend it for everyone struggling with the default gallery app.