Browser displays numerical keypad instead of normal keyboard

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product):
HARDWARE (XA2, X10, X10 II, …): Volla Phone Gigaset GS290
REGRESSION: (compared to previous public release: Yes, No, ?): Yes.


When I tap on the url bar or open a new tab, instead of getting a text input keyboard, I get the numerical keypad and can’t do regular text entry.


Presage keyboard for German is installed, default is English. There are no other patches installed although I do have some packages from Chum installed.


  1. Open the browser
  2. tap on the webpage name/url bar


Normal text entry keyboard.


Numerical Keypad appears.


(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

Dupe? Keyboard stuck in numeric mode

Well, well. I had, while doing some debugging:

Modified the FormAssistant :slight_smile:

So, that’s a precondition. Resetting that solves the issue. Requires a restart. Sorry for the noise. But it is interesting, isn’t it!

And it’s all your fault (ducks and runs!) …

EDIT: ok, now I’m not sure after reading that thread! But I did nothing more than revert the form assistant changes and reboot. And the keyboard was back.

Don’t think that’s related - I have had the stuck numeric kbd one or two times, restarting the maliit service fixes that.

And I most certainly did not hack around in that file :slight_smile: Because you told me so.

I had the same problem. Simple resetting the screen by ‘Hilfsprogramme’ solved it. Now working fine.

Yeah, it’s a bit central since it’s used by both the browser and WebView. On the other hand, it’s buggy anyway :slight_smile:

So, my ‘solution’ is probably not correct either, I was possibly being fooled by it having only occured in the context of the browser, where I had been hacking, after all.

I had tried to find related bugs with keywords like numeric pad and hadn’t found the thread that you mentioned. Why, oh, why!