Bricked with 4.0.1 EA

REPRODUCIBILITY (% or how often): 1 out of 1…
BUILD ID = OS VERSION (Settings > About product): 3.4 → 4.0
HARDWARE (Jolla1, Tablet, XA2,…): Xperia XA 2
REGRESSION: (compared to previous public release: Yes, No, ?): sorta


  • Ran the upgrade according to the instructions in the release notes.
  • Upgrade process ended in the “SailfishOS could not be updated. Please try again later.”-screen with reboot button.
  • Reboots ends up every other time in either the Sony screen, or passes it until a black screen. In the later case, display backlight turns one when you press power. But network is not working, SSH is thus no option.
  • So far so good, risk of EA.
  • But: I cannot get the device into fastboot or flash mode anymore. I tried with two cables on all the USB ports of three different laptops with four different Linuxes (Arch, Neon, Ubuntu 18.04 and 16.04). One of the combinations was also how i flashed at back then for the first time. I also tried with some different usbcore module options without success. On two machines I see errors like:
usb 1-7: Device not responding to setup address. 
Feb 05 15:54:44 zara kernel: usb 1-7: Device not responding to setup address.
Feb 05 15:54:44 zara kernel: usb 1-7: device not accepting address 44, error -71
Feb 05 15:54:45 zara kernel: usb 1-7: device descriptor read/64, error -71

On the other it is

ubuntu kernel: usb 2-1.1: device descriptor read/64, error -32

Is it actually possible that the upgrade bricked the phone itself? Or what else could be the issue or is there something else to try?

I’ve got into the same. (albeit on Xperia X) Update halfway, try again later …
I’m exploring repair option. Unfortunately I didn’t secure my ssh passowrd.

Fast boot works after some trial and error (had to shutdown completely - VolUp + Power - vibrates once, keepgin buttons for another few secons - vibrates 3 times and shuts down).
Just figured out fastboot blue icon is almost invisible. Managed to boot into recovery following this instructions.

Update (08/02/21):
I’ve managed to recover from broken upgrade successfully.
References I’ve used in the process:

My recovery process was (working on Ubuntu 20.04):

  • boot into recovery enabling sshd, backup nemo user (rather spend another hour and half than be sorry later);
    hint (mount home partition under homefs): ssh root@ "cd /homefs; tar czf - nemo" > nemo.tgz
    Note: compression is not needed and probably just took some extra time.
  • install zypper & augeas libs;
    I was doing this before I got network up. So I’ve lost quite some time getting right rpm (guessing urls). I have used (3.4 version): augeas-libs, zypper. Suppose I could’ve done pkcon install zypper if I had network up before.
  • link zypper cache: I have mounted home partition on /homefs and binded it into rootfs, linked zypper as per instructed in several other posts
  • zypper dup (I’ve got some 300 packages upgraded, some removed, some dowgnraded), restored zypper cache, rebooted
  • phone booted functional; so I followed by
    pkcon refresh # took quite a while
    pkcon update # was very surprised when I saw some 250 pkgs to be updated; seems it is normal
    Note: pkcon update completed, but also messaged an error at the end about screencast package (kind of scripts issue), discovered two versions installed (.18 & .19), so I removed both by explicit names e.g. rpm -e --noscripts screencast-0.3.0-10.19.1.jolla.armv7hl; not sure how I got into this, but it is kind of unusual. I’m guessing this could be a culprit for a broken upgrade in first place.
  • rebooted again (just in case)

Lessons learned:

  • remember ssh password (recovery would not require using fastboot and recovery image),
  • verify that you have a clean system prior to starting upgrade process (if it was screencast, that the issue was there from before, because I have tryed to deinstall it through warehouse, but didn’t check if operation succeeded; obviously it failed),
  • good old Jolla 1 phone still works surprisingly well and gave me opportunity to reherse my OTP (harbour-sailotp) and password (ownKeepassx) recovery skills. :grinning:
  • learning tons of new stuff along the way.
1 Like

The last option is to reset to Android with the help of a Windows computer and Sony’s Emma. There are good instructions for this here:
Warning: You will of course lose data if it is not on the SD card and can be viewed on the computer.

Only have it flashing green once, whatever I try. Same when trying flash mode.

That would be an option, but it refuses to run with wine.

It tried with Flashtool, but am not getting further there either way. Essentially because I need to enter flash or fastboot mode – and both are failing.