Bluetooth: Car Kit only sees A2DP, not HFP

Hi, involved devices:

Xperia 10 Dual SIM, SFOS (Rokua)

VW Car Kit H41, SW version 0468

Trying to pair (starting from the phone) works, but the connection only offers media functions (A2DP), and not phone functionality (calls, contacts).

Likewise when starting the pairing from the car, the phone is found, but again only media connection is listed.

The paired device settings on the one shows the car kit offering all the necessary profiles.
Showing the phone on the car kit settings only lists media support, not call support, both when searching for a new device, and when listing the connected/paired ones.

Please Note I know from the various Release Notes, and several threads on TJC that there are various issues around bluetooth and car kits etc.
Please keep this topic about HFP (calls, addressbook) not working, not the other way around. If you have the problem of calls working but not media, please open a separate topic about that.


I most definitely had both functions working on this device previously, so there likely is some magic sequence to the pairing process involved.

Are you sure about that with the same SFOS version? Or might it be another regression with

I’m absolutely sure about the running version. It might be a regression, yes, because it used to work more or less reliably in the past. But I definitely did use calling functionality with that version once.

From what I know about bluetooth, it stores some profile associated with some device paired in the past.

Look in /var/lib/bluetooth/. What could be tried is to reset BT - perhaps stop service remove directory start service, or reboot. Then pair again. If this does not help you could try bluetoothctl and advertise HFP (UUID: 0000111f-0000-1000-8000-00805f9b34fb)

I personally think it is a shame that bluetooth is in such shape in Xperia X. I mean Jolla, could have kept BT 4.x for a while longer as my car works perfectly well with Sailfish X 2.0 on Intex and not at all with 3.x.


Thanks for the hints.

I have found /var/lib/bluetooth/cache and removed its contents. Will test again next time I am in that car.

I ave also found that one can turn off caching of non-paired devices in /etc/bluetooth/main.conf.
Caveat: The only acceptable change to the caching is setting Cache=yes. Setting Cache=no makes bluetooth not start at all. The default is unset which sets Cache=always.

Back with test results:

At first no change in behaviour when I paired again.

A day or two later (and a reboot), addressbook/calling suddenly did work after connecting by selecting the car kit in the Paired Devices list. At the time, the second SIM (which cannot make phone calls) was disabled.

Have you tried it in another car? I recently read in Business Insider and Witschaftswoche that VW is knowingly selling faulty bluetooth kits in their cars, 2 out of 3 have issues.

My XA2 running Rokua does sync with my Citroen DS3 infotainment system vie Bluetooth. Audio Streaming works fine (-:

aha, also second sim. It could be useful if you keep it disabled for the beginning. AFAIR (TJC) it has issues.
I guess it is ofono there, but anyway - keep 2nd sim down.

What is happening is when ofono starts it registers as HFP in the bluetooth subsystem and you have the HFP available. You can check this in bluetoothctl by typing “show” and you see Handsfree Audio Gateway.

So perhaps you can test this with 2nd sim on and off and tell us the results here.
Then what happens when you reboot with 2nd sim off or is it now working when 2nd sim is off.
Again if I remember correctly someone reported that it was working when first HF is connected, but not sure. To me it makes no sense. It is interesting to know what ofono and pulseaudio are doing on top of bluetooth

  • is it registered
  • is the profile offered to connect
  • does car tries to connect HFP with phone
  • does phone tries to connect HFP with car

I experience that I can not connect multiple profiles at once - and often HFP comes as the 2nd one and fails because bluetooth is buzy connecting the A2DP. At the end A2DP is only working.

1 Like

nephros, thanks for the hint, clearing of the Cache in /var/lib/bluetooth/ MAC Address /cache solved my problem.

It was not working for me last 2 months, I hoped that it will be solved in but it was not.

1 Like

I came here to report the same problem, and found this topic. I have an xperia 10 single sim running, and my car is also a VW with factory bluetooth. Handsfree profile connecting seems to be random. Sometimes it connects and I see battery and signal level and mobile network name in the car instrument cluster, but the majority of the time it just shows the phone name and I cant access the address book or answer/make calls. Audio streaming works fine. Pairing and unpairing seems to make no difference. Specifying HFP on the phone does not help. I thought once that it started working after I enabled mobile data (which i dont know why it was disabled) but actually there was no causation here as it is still random afterwards.

Would love to get this working as I really need calls to work. I will try the 3.4 update to see if it helps but if not I will have to use an android phone until it’s working again as I use the phone in the car a lot!

Definitely not faulty car BT. It works with every other apple and android device perfectly.

Im not sure if I should make a new post in the bug reports section?

Edit: Just tried the new release preview: No change. I will try to clear the cache and pair again tomorrow but I don’t think the release has fixed it.

I have erased the cache and also edited the relevant /var/lib/bluetooth///info file to move the hands free and phonebook access profiles to the start of the list of profiles. Probably that wont make any difference but I thought it was worth a shot. I will see how it fares on my drive tomorrow.

This has not made any difference. It seems that the only way to make it temporarily working, and even then it is pure luck if it works or not, is to unpair and pair again. But it does not like to pair if the pairing is started by the car, I see the car BT adapter appear in the list under sailfish BT settings for a split second and then the car says it failed. It has to be done from the phone and the car simultaneously. Once it is paired, sometimes it works fully and sometimes only for A2DP, but the next time it almost always gives A2DP only.

I will raise a bug report about this later today. I have to reluctantly switch back to android until it is fixed as I keep missing calls while I am driving.

Once successfully paired, try disabling BT, enabling it again, setting the connection to “always allow” and then manually connect from the phone to the car kit.

This has been working for me. It’s a shame that connection cannot/does not happen automatically, but at least once the connection is established it works as it should.

Thanks @nephros.

So last week it suddenly worked for two days and now does not work any more. Under “Show device settings” and “Type” I have “Car kit” selected. But what I have noticed is that if I click on “Type” while connected to the car “Headset” is the option that is highlighted (and changing it has no effect). Disconnecting and then connecting again from the phone after selecting “Car kit” has no effect. I will try disabling BT and enabling it again, I am not sure if I have tried that particular approach. If I disable “Always allow connections from this device” and manually connect from the phone every time would that help I wonder? I don’t remember if I already tried that either.

I updated to sf and this problem seems to be fixed!

Indeed! It works in my Volvo V60. Audio can be adjusted via my steering wheel and I see the title, artist information in the display. The music also stops when leaving the car (instead of continuing on the phone). I only thing I notice is sometimes the bluetooth still stutters. I have a Sony Xperia AX2.