Android app support no longer working after update

Hi everyone,

So I made the upgrade to v4.5.0.16 today - I actually used the CLI tool sfos-upgrade.

Since this update I have tried running Android App Support via the settings GUI - the “start” button will turn to a swirl however will then change back to the “start” text, and the app will read “App Support unable to start”.

I checked this with systemd on the command line, and the system service has failed with this:

[root@Xperia10III defaultuser]# systemctl status aliendalvik.service
● aliendalvik.service - Alien Dalvik
   Loaded: loaded (/usr/lib/systemd/system/aliendalvik.service; enabled; vendor preset: enabled)
  Drop-In: /usr/lib/systemd/system/aliendalvik.service.d
           └─01-prevent-start.conf, 01-user.conf
   Active: failed (Result: exit-code) since Thu 2023-02-02 14:33:43 GMT; 10s ago
  Process: 31128 ExecStopPost=/usr/libexec/appsupport/ (code=exited, status=0/SUCCESS)
  Process: 31089 ExecStartPost=/usr/libexec/appsupport/ (code=exited, status=20)
  Process: 30289 ExecStart=/usr/libexec/appsupport/ (code=killed, signal=TERM)
 Main PID: 30289 (code=killed, signal=TERM)

Feb 02 14:33:43 Xperia10III systemd[1]: aliendalvik.service: Service hold-off time over, scheduling restart.
Feb 02 14:33:43 Xperia10III systemd[1]: aliendalvik.service: Start request repeated too quickly.
Feb 02 14:33:43 Xperia10III systemd[1]: aliendalvik.service: Failed with result 'exit-code'.

I ran a journalctl -xe and this seems to give a number of outputs but to be honest I’ve no idea which ones are actually relevant so not entirely sure what would be useful to post from this.

As an aside I can also no longer launch Jolla Store from the app grid, as this simply shows a white screen (or a white box on my home screen) with no contents, so I think further problems have occurred with my update to, which is why I’m not submitting this as a bug report yet as it seems like something I’ve done has broken it!

I’ve tested a number of native apps and nothing else appears to be broken however I haven’t as of yet tested everything.

Can anyone help? Hoping it’s just a case of a bad update that I need to somehow push through but I’ve tried the standard pkcon refresh/version --dup and that doesn’t seem to want to reinstall anything.


1 Like

From the release note:

Start the update from “Settings > Sailfish OS updates”. Avoid running updates on the command line, please.

I suppose by doing it via CLI something broke in the android support.
Maybe you could try to remove the package with the android image and reinstall it.

Also, the package aliendalvik-system has been replaced by appsupport-system-unprivileged

1 Like

That’ll teach me to read the release notes more closely :roll_eyes:

So I already have the package “appsupport-system-unprivileged”, is this the package you’re referring to to un/re-install?

I have the same ish problem, though I didn’t upgrade from cli.
I don’t have the appsupport-system-unprivilleged package, but a package called appsupport-system-priviliged instead

I’ve tried to reinstall the previligied package, but still no android-support.
in the android support section there is just the spinning wheel, when trying to start the service, but it dosen’t start

I ran the command:

from the app qCommand

Then I get the android config app, and if I try to install an apk package then, I am prompted with how I want to install it, which prior to this just nothing happend

I have the same problem: Aliendalvik does not start correctly. After trying with “systemctl restart aliendalvik” it seems to run (“System-App” → “Android-app-support” also tells me it’s running), but no Android-app starts.
I am not sure if the problems are connected but app updating does not work either completely! Some apps do update some do not.
@Jolla: that’s the first upgrade I have problems with. Please help.

My problem is very similar. After updating to Android apps have been working. After a reboot of the phone, Android support is trying to start, but returns with error.

aliendalvik.service - Alien Dalvik
   Loaded: loaded (/usr/lib/systemd/system/aliendalvik.service; enabled; vendor preset: enabled)
  Drop-In: /usr/lib/systemd/system/aliendalvik.service.d
   Active: failed (Result: exit-code) since Wed 2023-02-15 22:43:42 CET; 28min ago
  Process: 24698 ExecStopPost=/usr/libexec/appsupport/ (code=exited, status=0/SUCCESS)
  Process: 24634 ExecStartPost=/usr/libexec/appsupport/ (code=exited, status=0/SUCCESS)
  Process: 24390 ExecStartPost=/usr/libexec/appsupport/ (code=exited, status=0/SUCCESS)
  Process: 23391 ExecStart=/usr/libexec/appsupport/ (code=exited, status=1/FAILURE)
 Main PID: 23391 (code=exited, status=1/FAILURE)

I tried to reinstall Android App Support. No effect.
I also can not deinstall Android apps.
What can I do to fix it?

1 Like

I managed to upgrade meanwhile, see here: [Release notes] Struven ketju - #51 by Stevo
Maybe you can try the same.

Today I had the same issue, I stopped Android support and out of nowhere it couldn’t start again. I rebooted the phone, I free some space (I had ~500 mb free on /home partition) to ~4gb, still nothing. I did:

systemctl status aliendalvik.service

and I saw the same error fwilamo mentioned above. I had the idea to run the following as defaultuser:


From there I got the error:

[defaultuser@Xperia10II-SailfishX ~]$ /usr/libexec/appsupport/ 
rm: can't remove '/home/.android/data/alien_boot_completed': Permission denied
lxc-start: aliendalvik: parse.c: lxc_file_for_each_line_mmap: 80 Permission denied - Failed to open file "/tmp/appsupport/aliendalvik/10-bsp_config"
lxc-start: aliendalvik: parse.c: lxc_file_for_each_line_mmap: 132 Failed to parse config file "/tmp/appsupport/aliendalvik/config" at line "lxc.include = /tmp/appsupport/aliendalvik/10-bsp_config"
Failed to load config for aliendalvik
lxc-start: aliendalvik: tools/lxc_start.c: main: 208 Failed to create lxc_container
cat: can't open '/home/.android/data/alien_boot_completed': Permission denied
[defaultuser@Xperia10II-SailfishX ~]$ No status data could be sent: $NOTIFY_SOCKET was not set
info systemd again...
No status data could be sent: $NOTIFY_SOCKET was not set
info systemd again...

As root I chmod the file /home/.android/data/alien_boot_completed from 600 to 777. I did a reboot again and android support seems to work again. Also the file has again permissions 600. No ideas why it worked but I am glad I didn’t have to remove all the /home/.android directory.

Same error as NAS, but in my case changing permission of /home/.android/data/alien_boot_completed do not helped to run AppSupport again.

What went wrong? For a month it worked (there were issues with starting bluetooth)

ahoy @krzyklo,

have a look here:

Try to free some space from your /home partition, maybe that was that worked for me and not (only?) the file … Try to have more than 1 - 2 Gb free.


1 Like

Dear @nas
Thank you !!!, yes it was lack of space on /home!
I had ~250MB, when increased to ~800MB, Android Support started to work again!

Many thanks for your kind suggestion!

1 Like

Nice! glad it worked for you too!