Ad blocking VPN not blocking ads

I have configured the VPN settings to connect to a VPN server that block ads, but for some reason I can still see ads. I have tried the exact same OpenVPN config on my desktop computer and then it works as expected. I have no idea about how to troubleshoot this. Any suggestions are welcome. Btw, I do have a public IP from my VPN provider, so I am connected. :slight_smile:


ip route get

in the terminal to see if your default route goes via the vpn.

]$ ip route get dev vpn0 src

It seems like it.

Then your browser on the pc might block ads which maybe your mobile browser does not?

No, that is not it. The config is also working as expected on my Android device, but in Sailfish the DNS requests are leaking I have now seen.

That’s bad in any case. Bu does that explain the ads?

No idea, but that is one thing that differ using the same Proton VPN config.

Arch Linux

  • No ads
  • No DNS leaks


  • No ads
  • No DNS leaks

Sailfish OS

  • Ads
  • DNS leaks

Now I seem to get it. Your VPN provider might block ads based on DNS resolving. SF might ignore the DNS suggested in the .ovpn file.

I had that with Windows clients on a VPN. Linux mashines accepted the DNS on the VPN side.

You could try and edit the client configuration file like in:

1 Like

I tried setting the DNS manually in the ovpn file, with no success.

This seems to be the same problem VPN leak on Xperia 10 III

Yes. You are right. I tested with three of my own VPNs one ending in Hamburg, the others in Berlin and Greifswald, Germany. Works with Linux, leaks with SF.

Do you mean native apps or AD?

Assuming AD is Android there is now difference in behavior, and I guess they are using the same connection in the end anyway, or am I wrong?

The same connection but different DNS system. Native apps are using /etc/relsolv.conf. Android (Alien Dalvik) is using DNS that get directly from network router you are currently using. So, if you want Android apps to use vpn DNS addresses you have to force AD to use resolv.conf


Just for the record; tried with protonvpn-cli utility, still leaking.

1 Like

This is a real bug and worth a bug report. The purpose of a VPN is to route everything over it except local addresses (eg. printer or other computer in LAN).

1 Like

Isn’t this the exact same thing as Netshield adblocker ProtonVPN not working using Android apps over 4G and Mobile VPN usage, ipv6 not routed and DNS leaks ?


Thank you and all orher people for paying attention ti this very serious bug. And yes @attah , you are so right! You made my day!
I want to report my investigation in ad-blocking via peoxy. To be continued.

1 Like

Thank you @Seven.of.nine !

1 Like

BTW: is it allowed to refer to Dutch forums? I really don’t know, excuse me if it’s not done.
Very interesting: Het mini Jolla Topic - Smartwatches, sporthorloges en overigen - GoT
I prefer for translation.

1 Like