[][10II] Android App Audible is unusable saying SD Card required (solved)

HARDWARE: Sony Xperia 10II


The Android App “Audible” does start but shows an error “SD Card required” and is not usable.


Sailfish OS 4.4 with Audible App installed and logged in and downloaded a podcast


  1. Update to Sailfishos
  2. Open Audible App


Audible App starts and you see the start page


White Message Box appears with message “SD Card required”



1 Like

Just installed the app. I don’t have any account and once I unmounted (software) my SD card, the app open easily.

Exactly the same issue here, tried several things:

  • Uninstall/Install the app
  • Remove all data files
  • Start the app with and without an SD card
  • All permissions granted (though I suppose only media is needed)

No change at all, keep on getting the error message, app doesn’t start. Worked smoothly on 4.4

And the app still works on an updated XA2, so something seems to be wrong on the X10II…

May I ask you to check the owner of the sdcard?

The owner is defaultuser

I’m wondering if it’s not the same bug as [][10II] Whatsapp media not readable/not storeable

Maybe it is the same for me all android data folders and files have an owner 501023 and group appsupport-media_rw. Do you know what are the correct values?

Seems like a mix of 501023 and appsupport-root:

[defaultuser@Xperia10III ~]$ ls -la ../
total 76
drwxr-xr-x 10 root            root             4096 Feb  2 21:25 .
drwxr-xr-x 33 root            root             4096 Feb  2 21:20 ..
drwxrwxr-x  2 root            root             4096 Feb  2 21:28 .aliendalvik_systemimg_patch
drwxr-xr-x  3 appsupport-root appsupport-root  4096 Feb  2 21:22 .android
drwx------  5 appsupport-root appsupport-root  4096 Feb  2 21:22 appsupport-root
-rw-------  1 root            root            23552 Feb  2 21:25 aquota.user
drwxr-x--- 25 defaultuser     defaultuser      4096 Jan 19 13:48 defaultuser
drwx------  2 root            root            16384 May 11  2022 lost+found
lrwxrwxrwx  1 root            root               11 Jun 13  2022 nemo -> defaultuser
drwxr-xr-x  5 root            root             4096 Jul 23  2022 .pk-zypp-dist-upgrade-cache
drwxr-xr-x  3 root            root             4096 May 11  2022 .system
drwxr-xr-x  5 root            root             4096 Feb  2 21:14 .zypp-cache
[defaultuser@Xperia10III ~]$ ls -la ../.android/
total 20
drwxr-xr-x  3 appsupport-root appsupport-root   4096 Feb  2 21:22 .
drwxr-xr-x 10 root            root              4096 Feb  2 21:25 ..
drwxrwx--x 46          501000 appsupport-system 4096 Feb  2 21:29 data
-rw-r--r--  1 root            root                 6 Feb  2 21:22 .privilege_migration_done

android_storage in home:

drwxrwx---+ 14      501023 appsupport-media_rw     4096 Feb  2 21:24  android_storage

I’m guessing 501023 is the new unprivileged user. Also some leftover folders from migration, might be tricky to get it working manually, weird fresh install of appsupport doesn’t work (since you have 501023 somehow the migration broke I guess)

The SD card in Android speak is actually ~/android_storage. Just install an Android file manager (Total Commander is pretty good) and look into /sdcard.

The owner and group of the app have changed but the data directory has the old ones and is thus not writable.

Possible solutions:

  1. as root (pkexec bash, sudo or devel-su)
    chmod -R 777 ~/android_storage/Android/data/com.audible.application/

  2. as 1 but chown -R newuser:newgroup instead of chmod -R 777

  3. rename the existing data directory and let the app create a new one. When the app works, import or move your data to the new directory. This needs root, too, because the directory is 770.

Edit: I don’t use the app, I just tried a clean install. Audible might save stuff in other places, like

Check if ~/android_storage/ has a hidden file

Also experienced this. Tried removing .privilege_migration_done and .storage_migration_done, started Android support. Saw that Documents and Audiobooks were set with owner 510043:510043 (rest remained with 501023:appsupport-media_rw). Did chown 510043:510043 -R * in ~/android_storage, downloading media started to work again.


Thanks, mate! That also did the trick on my X10II - however, on my device it’s 510031:510031, so just copying the chown command might not work on every device…
Audible and WhatsApp are working properly again.


Maybe one should be careful. I have problems with my SD-Card in Spotify App.
I did the chown and now banking app no more working and Aurora cannot install packages :-/

I have the same issue. However I have no folder/file with the correct user:group. Even setting the read/write to 777 doesn’t help. Is there a way I can get the correct user:group? I have tried the above suggestions.

I have reinstalled osmAND+ for this error. But I can’t find the old files to remove… Costing about 25GB of storage…

SOLVED FOR ME! Steps I used.
0. Stop the android services if there running. Use the settings to do so.

  1. Dev-mode on.
  2. SSH in device or use terminal.
  3. Navigate to ~/android_storage/
  4. use devel-su to elevate to root user.
  5. remove 2 files: ‘.privilege_migration_done’ and ‘.storage_migration_done’. The leading dots are mandatory.
  6. Start the android runtime from the settings menu. This will take a while.
  7. In the terminal nog have a look at ls -la. This will show a lot of files, folders and there user/groups.
  8. Look for a folder that has a user and group with the same number.
510107   510107        4096 Feb  2 10:59 Pictures
501023   appsuppo      4096 Jun 23  2021 .facebook_cache

The top one gives the numbers you need.

  1. Then run
chown 510107:510107 -R *

This will change the owner of all files and folders.
10. No open you android apps again.
11. Happy sailing


This seems to be a duplicate of the previous bug ([][10II] Whatsapp media not readable/not storeable (solved)), I’m closing this one. Let’s continue the discussion on the other bug.