[] Jolla camera (also torch) does not start at all - as well as videos do not play

Same here with XA2.
Updated right now - no sailfish camera, no flashlight…

sadly @deusexbeer solution with adaptation-common and zypper steps did not help me

For the XA2 (dual SIM model, should not matter?) the repository added standard on my daily driver SFOS 3.2.1 device is:

ssu ar adaptation1 https://store-repository.jolla.com/releases/

Mind the ‘-dhd’ !
But when trying to add this repo it gets automagically “censored” to

Enabled repositories (user):
- adaptation1             ... https://store-repository.jolla.com/releases/

After adding above mentioned repo adaptation-common, thanks to @deusexbeer
devel-su; ssu ar adaptation-common https://releases.jolla.com/releases/; ssu ur
and using @olf 's sfos-upgrade there were 13 new pacages downloaded and

Install (13 packages)

  • audiosystem-passthrough;1.1.2-1.2.1.jolla;armv7hl;adaptation-common
  • bluebinder;1.0.12-1.2.1.jolla;armv7hl;adaptation-common
  • geoclue-provider-hybris-binder;0.2.32-1.3.1.jolla;armv7hl;adaptation-common
  • gmp-droid;0.4-1.2.1.jolla;armv7hl;adaptation-common
  • gstreamer1.0-droid;0.20210820.0-1.2.1.jolla;armv7hl;adaptation-common
  • libgbinder-radio;1.4.1-1.2.1.jolla;armv7hl;adaptation-common
  • libgbinder;1.1.10-1.2.1.jolla;armv7hl;adaptation-common
  • libgrilio-binder;1.2.5-1.3.1.jolla;armv7hl;adaptation-common
  • libncicore;1.1.18-1.2.1.jolla;armv7hl;adaptation-common
  • libnciplugin;1.1.1-1.3.1.jolla;armv7hl;adaptation-common
  • nfcd-binder-plugin;1.1.8-1.2.1.jolla;armv7hl;adaptation-common
  • ofono-ril-binder-plugin;1.2.5-1.3.1.jolla;armv7hl;adaptation-common
  • qtscenegraph-adaptation;0.7.6-1.2.1.jolla;armv7hl;adaptation-common

Afterwards camera and flashlight and video works…


you mean adaptation-common, right? @Starghost did that typo as well before. keep an eye!

@peterleinchen what do you mean with:

1 Like

Same to me. After update from factory reset to 4.3 on my xperia xa2 no native cam, but Android “Open Camera” is working fine.
Very annoying.

1 Like

Oh dear (to myself).
Yes, of course. Please see my code lines :wink:

olf’s sfos-upgrade

1 Like

thx, heard of it. never used. you mean installing and running through that process on already installed 4.3 can maybe fix the problems?

I don’t know whether or not this is related, but I did another factory reset. This is my second time of going from complete reset to 4.3 without any third party installations. And like the first time I get a strange notification when downloading v 4.3:
“Remove the following packages before update:
I’ve not installed anything myself, so I assume that these are jolla-packages. I’ve no idea what these packages are or if it’s safe to simply uninstall them using the terminal. Seems strange that I would have to jump through these hoops to install an update, and if the packages are official sailfish packages why the installer simply doesn’t handle it. Could this be the cause of my issues with the camera? On previous installs I just ignored this warning, as I couldn’t see how there could possibly be an issue as I’m coming from a clean factory reset.

Sorry for the typo error. I did correct the text in the original post. :roll_eyes:

1 Like

After configuring the somehow vanished (or on purpose removed? @Jolla?) repository which holds some packages that were earlier in another one, you may either use
zypper ref, zypper dup
pkcon refresh, version --dup
or more simple and safe:
which will then check for missing or newer packages related to your current SW version release (ssu re).

1 Like

@peterleinchen : i did what you suggested and now Jolla camera , torch and Fotokopierer are running fine ! Video playback from Gallery is also working now, too.

Advanced Camera can now be installed (previously not possible ) but still doesn’t work.

edit: Just now I updated the 3rd SFOS phone in my family (a Xperia 10), and took care of everything written above. On this phone also Jolla cam, torch and video playback now working. Advanced Camera was installed. After the update and system cleaning, Advanced camera was working fine with main camera but not working with the selfie cam (black image). On switching back to main cam, Advanced Camera app crashes. So I deinstalled it, waiting for better times.

he suggested multiple things. what exactly worked four you?

i did everything, but nothing satisfies. it is always saying that everything is up to date.

I did first: pkcon install zypper (because it was not installed before),
then I did zypper ref and zypper dup, but there was nothing new (because it was fresh installed :wink: ),
then I did pkcon refresh (downloaded something),
then version --dup (downloaded a lot!)
then sfos-upgrade (did not work, gave some error message)

Then I rebooted the device by CLI “reboot”. Then it worked again as described.

That would be extremely interesting to someone from Jolla who might notice this topic.

So you did not add the adaptation-common repository manually?

Please post output of
ssu lr
pkcon search gstreamer1.0-droid

[root@Xperia10 nemo]# ssu lr
Enabled repositories (global):

Enabled repositories (user):

Disabled repositories (global, might be overridden by user config):

Disabled repositories (user):

[1] This is wrong. “adaptation-common” must be in the section of global repositories. Nobody should add this system repository manually! Manually added repositories always go to the section of user repositories.

[root@Xperia10 nemo]# pkcon search gstreamer1.0-droid
Suche nach Details
Software-Liste wird aktualisiert
Installiert gstreamer1.0-droid-0.20210820.0-1.2.1.jolla.armv7hl (installed) GStreamer droid plug-in contains elements using the Android HAL
Verfügbar gstreamer1.0-droid-tools-0.20210820.0-1.2.1.jolla.armv7hl (adaptation-common) Tools for gst-droid
[root@Xperia10 nemo]#

» So you did not add the adaptation-common repository manually?

No! What is this? Should I do this?

Then I do not understand it!
Are you sure you did not execute the code deusexbeer gave?
Because this adaptation-common repo is added in the user section!

I did execute pkcon install zypper.

Can someone who’s run into this problem test rebuilding just the ssu cache instead of adding the missing repo manually? There’s a bug in ssu that we didn’t think affected public releases, but this is sounding very similar.

Remove any Jolla repos (from the section of user added repos) you might have added manually with:

ssu rr <repo name>

then do:

rm -r /var/cache/ssu/
ssu ur

After this, you should see the missing repo (e.g. adaptation-common) in the system repos when you run ssu lr. Please let me know if this gives you the correct repository listing, and if so then i’d recommend doing that rather than adding the repos manually, as this might break the next upgrade if that repo can’t be updated to the new version.


Okay, thanks for the feedback.

Seems to have worked!

But ssu update -f gives
[root@Sailfish nemo]# ssu up -f Device is not registered, can't update credentials [root@Sailfish nemo]# ssu r Username:

So I just removed ssu cache and ssu ur, so I suggest to use:
devel-su; ssu rr adaptation-common; rm -r /var/cache/ssu/; ssu ur


Thanks, I’ll remove that line. I wondered what it did…