[] WhatsApp starts only once

I’m using my “old” xperia X while a new update…

No change with WhatsApp It still crashes on splash screen.

Actually, I’ll split the issue; I’ll get another SIM card to use in another phone until this gets fixed. I’ll dig my trusty old Xperia X from the closet and use it first to test the bug with it, and downgrade to SFOS 3.4 if I must. Stay tuned…

1 Like

I’m new to this forum and wanted to use Sailfish OS as my daily driver but - exactly the same problem as you. Sony Xperia X10, Sailfish, Whatsapp versions:,, no MicroG - it is not the XA2.

First Start: Fine.
Close it once, no second start possible.
Re-registration, loss of all messages, not possible to import backup (0kb) that was manually done before following.

Aside from the fact that Nextcloud worked only partially (sync Contacts+Calendar, nothing else) in a second attempt (after deleting the first account with exactly the same settings) this leaves me angry about myself as I disobeyed the golden rule of avoiding .0 releases…

Unluckily, I am not a programmer, so thanks for your insight guys.

(Can we somehow add the X10 to the bug report?)

Thanks for the info - and sorry that the bug hits you, too… I’ll update the bug report.

It could be something related to Android support level, but then again, I’d have thought more X10 owners had already found this… Either the bug doesn’t hit every user, or WhatsApp is not at all that common :thinking:

Edit: I don’t seem to be able to edit the first post anymore, so this will have to do…

WhatsApp updated to and still the same…

And here on with latest (same) WA everything working…

ome thing I’ve found with some Android apps is that downgrading the app sometimes fixes it, (code added to newer versions causes new ceashes). This is even the case on native Android sometimes, (e.g. GMaps). Maybe try going to Apkmirror, and download a version from 6 months ago, and try it…

1 Like

Hmm … I have an XA2 with SFOS newly flashed (i.e. not upgraded from SFOS 3) and Whatsapp works fine for me all the time. Its also the latest version of Whatsapp in a long line of new versions (they seem to release an updated version of the app almost every week) that have been installed on SFOS 4. never had a problem with any of them.

Only difference I can see is that I have vanilla android, no MicroG installed or anything else special.

1 Like

I doubt this is related to microG, as I have microG installed and I’ve never had any issues with starting WhatsApp. Well, it might be related to some specific settings in microG, but at least just having microG installed doesn’t cause WhatsApp to not start.

1 Like

Thanks for the additional info, everyone.

It looks like that a freshly-flashed (try saying that fast three times) SFOS does not suffer from the issue, but an SFOS 3.4 > SFOS 4.0 does suffer from it. So, I’m making backups (again) and flashing my phone straight to 4.0 to see if it helps… Fingers crossed, everyone!

freshly-flashed, fastly-flushed, fishly-thrashed … Oh damn!


Different symptom for me on Koli - Whatsapp asked to update client and I downloaded it via the Browser. I think Whatsapp client may not work after a while if you don’t keep it up to date, but I’m not sure about this. Anyway, clicking on APK resulted in a short message at top of screen but no installation occurred. Older Whatsapp client still working OK. Deleted old client altogether and re-ran installation which again gave no visible indication that it was installing, except that this time it did install. It seems to be running fine so far.

It didn’t help :weary: And on top of it all, my group memberships had all expired :confused:

I still haven’t accepted the new terms of use, maybe that affects the behavior of the app…? I think I’ll grab some more coffee and give it a new read.

Well, this looks to be fixed in EA! My WhatsApp survived a few reboots already! Hooray!


confirming, works also for me now on EA. Finally can remove it from Tablet and continue with the phone :slight_smile:


Excellent news! I’ve been holding off on the update to SF4 for some time because it’s my daily driver and I simply couldn’t be without WhatsApp. Might finally take the plunge when 4.1 is on general release.

Thanks for keeping the thread updated!

Hi there,

an update from my side (referring to the sailfish version of my first post):
Reset sailfish from menu, complete wipe of data.
A completely new Whatsapp with a new SIM under a new Number: works.
My Whatsapp, my number, my old group memberships: same problem.

Maybe it has something to do with old groups, legacy things - I don’t know. But now I know why this bug isn’t more common, it is just happening for a very tiny fraction of the userbase (I’m in it, of course :confused: )

thx for reading.

1 Like

You are running SFOS 4.1.0 EA, right?

Could it be the old EULA messing things up? I accepted the new EULA…

Thx for your reply, it was and unluckily, my time was limited - so I had to return to the dark side of mobile operating systems :wink:
Maybe in a few months I will be able to start another attempt.

Take care