[3.4.0 onwards] Bluetooth turning on doesn't work

I just had to do the restart network in SF Utilities twice to get my BT working again.

Then you are the lucky one ;-).
BT doesn’t worke here anymore right now.

Not even after restarting the phone? If it does not work anymore I would try reverting to Android and trying there.

No, but there were several reboots.
I will wait for the next update first, maybe that will bring an improvement in this matter ;-). I don’t have the time to always switch between SFOS and Android when there is a problem. This is also one of those pains with SFOS ;-).
I am currently not thinking of a hardware defect, as it worked a few times after the last update.
We will see…

Good news guys! For some reason my XPERIA X now finds and connects my BT headphones at least after almost every reboot. I have no idea why, though! If I restart it once in the morning the headphones work – at least as long as I do not disconnect them. I always knew that these devices have their own souls :upside_down_face::wink:. Let’s keep the fingers crossed that it works like this until the next update will fix it altogether.

1 Like

I made the following observation on Koli (, Xperia X):

Starting point:
Bluetooth turns on normally on a freshly booted phone.
Connecting to a Bluetooth device works, automatically as well.

  1. Turn BT off
  2. Turn BT on again - takes longer than usual (a few seconds)
  3. Connecting is not working anymore
  4. Turn BT off
  5. Try turning it on: Won’t work. Top Menu button stays gray, radio button in setting keeps blinking.
  6. Reboot the phone: Bluetooth is turned on automatically

The cycle repeats…

Does anyone have a hint on how to collect the right logs?

@jovirkku: I’m being blunt and ping you directly. Could you comment on this?
Can we do anything to help debugging?


I experience exactly the same pattern! Thank you for sharing. The only thing that miraculously changed is that it works now as if my XPERIA X had reprogrammed itself. In the beginning it would only connect occasionally. Since a few weeks it suddenly connects every day and I only have to restart it if I disconnect my headset.

I can testify that I have the exact same bug ! (on the same phone)
My current solution remains rebooting the phone every time… I tried this patch but it did not change anything…

Hmmm. You might want to start with our shotgun script that collects many kinds of logs from your phone.
Guidelines here: https://jolla.zendesk.com/hc/en-us/articles/360013910599

Naturally, it should be run after observing the problem again.

If you want to keep your logs in privacy, file a ticket at Jolla customer support at https://jolla.zendesk.com/hc/en-us/requests/new. Attach your log package there, please.


Oh wait that’s interesting @jovirkku. Does that means that no one at Jolla has experienced the issue and thus no specific fix is in the pipe?
Also, a reflash could potentially fix it then?

That’s the kind of info we’d love to have proactively, in order to try to provide you better logs and decide whether we should reflash our phones or not.

I still hope that 4.1 will fix it :crossed_fingers:


After the update to, the Bluetooth of my XperiaX also lives again after a restart and no longer after it has been deactivated.

Now the magic line for me to reactivate it is:
systemctl restart bluetooth-rfkill-event.service

Strangely enough, reactivation does not work here with the extended sailfish-utilities (from nephros) and only via the command line.
The problem seems to have been around for a while, as I’ve read here:
Sailfish OS for the Samsung Galaxy S2 (i9100)


Brilliant! Thanks a lot!

I’ll take the script to the ‘shooting range’ as soon as I find some time.
In the meantime: have a nice weekend @jovirkku :slight_smile:

it doesn’t work in

[root@XperiaX RPMS]# systemctl status bluetooth
● bluetooth.service - Bluetooth service
   Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; disabled; vendor preset: enabled)
   Active: active (running) since Mon 2021-05-17 01:54:02 CEST; 6min ago
     Docs: man:bluetoothd(8)
 Main PID: 6436 (bluetoothd)
   Status: "Running"
   Memory: 332.0K
   CGroup: /system.slice/bluetooth.service
           └─6436 /usr/libexec/bluetooth/bluetoothd -n

May 17 01:54:02 XperiaX systemd[1]: Starting Bluetooth service...
May 17 01:54:02 XperiaX bluetoothd[6436]: bluetoothd[6436]: Bluetooth daemon 5.54
May 17 01:54:02 XperiaX bluetoothd[6436]: Bluetooth daemon 5.54
May 17 01:54:02 XperiaX systemd[1]: Started Bluetooth service.
May 17 01:54:02 XperiaX bluetoothd[6436]: bluetoothd[6436]: Starting SDP server
May 17 01:54:02 XperiaX bluetoothd[6436]: Starting SDP server
May 17 01:54:02 XperiaX bluetoothd[6436]: bluetoothd[6436]: Failed to open RFKILL control device
May 17 01:54:02 XperiaX bluetoothd[6436]: bluetoothd[6436]: Bluetooth management interface 1.3 initialized

May 17 01:54:02 XperiaX bluetoothd[6436]: Failed to open RFKILL control device

May 17 01:54:02 XperiaX bluetoothd[6436]: Bluetooth management interface 1.3 initialized

It seems to me in hciattach cannot be deactivated.

When you execute killall -TERM hciattach or killall -KILL hciattach should be working

The same in :frowning:

I’m frustrated with that, until version 3.4 BT worked flawlessly, even pairing in a Mazda 3, now it’s completely useless! Jolla boys, what did you do with that?


I can easily reproduce the issue by following your steps (on This happens on Xperia X only, to me, while Xperia XA2 and Xperia 10 II work almost flawlessly (*). I have filed an internal bug about this problem on Xperia X. This is not a promise on getting it fixed.

(*) Automatic reconnection at step 3 may fail but the manual one succeeds on XA2 and 10 II.


@jovirkku Thanks! I very much appreciate your commitment in forum in general (not just this bug)! I’m sure I’m not alone ;).


I’ll look forward to the fix :smiley:

Can anyone please write a patch which restarts bluetooth?

I’m a Xperia X user and had some hope till now, that kvarken will fix this nasty bug… :confused:

you rang?