[] Signature spoofing doesn't work on a freshly flashed xperia 10 plus

https://github.com/yeoldegrove/sailfish-signature-spoofing-lxc I believe these are the instructions.

1 Like

I have the same issue on my Xperia 10, freshly flashed to 3.4 and followed all the steps… enabled it in android settings as well as in sailfish settings and still, sig spoofing is showing disabled…

i have tried this now and can report back that it works perfectly!


Had the same issue with my new Xperia 10 Dual Sim with 3.4.

Going the route 3.3 route and then upgrading worked.

Hope this gets fixed soon!

I tried it too and it seems to work on an XA2 flashed directly to SFOSX 3.4.x, but I’m a total n00b at microG so I can’t tell what’s using signature spoofing or not. Before going through that tutorial, I was able to install most Android apps that I needed. Afterwards, one of those that didn’t run, and which had a mapping component (Mapbox/OpenStreetMaps), started running. No GPS, though.

Figured it out - the real problem why it will work on upgraded from 3.3 devices and not work on the clean install 3.4 is the only difference between them - the user folder name - defaultuser for clean 3.4 and nemo for 3.3 upgrades. So, the fix to get spoofing working is to stop AD and create a nemo symlink to defaultuser. :wink: Of course, if you already have a nemo folder, first move its contents to defaultuser, delete nemo and then symlink it.


That would be a bummer! :frowning:
But already mentioned/suspected in Octobre

And to fixed by @Jolla asap.
(maybe by adding the symlink into the flash image? :wink: )

1 Like

Yeah, I saw that, but didn’t expect the fix to be so easy. :smiley:

So what is the status in 4.0?
I managed to grant microG spoofing permissions through its checker (it should really be documented that it no longer shows as a regular permission), but still spoofing shows as inactive for all the microG apps.

I didn’t notice any mention of the issue in the Release notes, but @bundyo spelled out the fix just above.

This post here has the necessary commands:

1 Like

Wow, you are right, this still applies. How is it even possible?

Ugh, i found where the issue is.
/usr/sbin/alien-generate-properties.sh has:

export XDG_CONFIG_HOME=/home/nemo/.config
for CONFKEY in $(dconf list /alien/)
    CONFVAL=$(dconf read /alien/$CONFKEY)
    echo "$CONFKEY=$CONFVAL" >> /tmp/aliendalvik/generated_props

So who do we ping to get this fixed?


Okay, this is a good find!

Edit: I’m also confirming that replacing nemo with defaultuser in said spot eliminates the need for the nemo -> defaultuser symlink. After restarting Android app support, the signature spoofing works! Note that you need either the symlink or fixing the folder, both are not needed (for this specific fix at least).

@jiit, could you have a look at this?

1 Like

Really a good find.
Should be fixed somehow. But how?

On older systems upgraded we only have /home/nemo/ and on newly flashed systems with >=3.3 we do have /home/defaultuser/ only.

The way I did with harbour-defender?
First check for existence of directory /home/defaultuser and if not there assume /home/nemo?
#doh HOME_DIR = os.environ['HOME'] HOME_DIR = '/home/defaultuser' if not os.path.isdir(HOME_DIR): HOME_DIR = '/home/nemo'

Or would we need also a ‘backlinking’ from defaultuser to nemo on older upgraded systems?

In the case of this script, it is called with the username as parameter (I haven’t checked from where ^^), the proper fix is to put:

export XDG_CONFIG_HOME=/home/$ALIEN_USER/.config

At line 133 of /usr/sbin/alien-generate-properties.sh
It’s actually what Jolla has done on line 42! They simply forgot to do the same on line 133 :confused:
Very nice finding @attah, I confirm too that after doing that and having restarted Android support, all checkboxes are checked! :tada: The fix is so simple, I hope they can still put it in the 4.0.


This fix is still needed with freshly-flashed SFOS on my XA2 Ultra.

Works like a charm!

Removed my question…

Apparently, this has been fixed in EA! Well, at least nemo is not in the file, and line 133 is different :slight_smile:

Could someone test the spoofing and report this in 4.1.0 release notes? I don’t plan to do it (for now).

Edit: And the corresponding change low message is:

[alien-aliendalvik-configs] Fix an issue where nemo is used instead of ALIEN_USER.

In my case, I’m still having the same issue, even with a fresh flashed XA2 running The symlink fix did the trick too, so I’m guessing either it was reverted or a similar issue still exists.

And it was not just the restart of the Android runtime that did it? Try removing the symlink and restarting, and see if the problem comes back.