[] Signature spoofing doesn't work on a freshly flashed xperia 10 plus

Thanks, I feel less alone, now :slight_smile:
I wanted to try with an earlier version but shop.jolla.com only provides the latest.

On, I also tested mindthegapps, opengapps (playstore hangs or crashes), patching using haystack (spoofing doesn’t work or microg can’t access google servers), nothing worked.

I’ve just flashed on an Xperia 10 plus dual SIM, and I’ve got the same issue.
I’ve followed The Yak’s guide on TJC, including enabling ‘system package replacement’ permissions in the Android Settings app for FakeStore, microG Services Core and Signature Spoofing Checker.
Unfortunately both apps show that the signature isn’t being spoofed.

Don’t forgef to set the app permissions.

Rather than using AlienDalvik control you may simply open Android settings directly via

apkd-launcher com.android.settings

For me, MicroG works flawlessly on both the XA2 and the Xperia 10 with


Lucky you! I flashed at least three times, but nothing: Signature spoofing doesn’t work on my Xperia XA2 Dual Sim!
Could I ask you, please, what guide did you follow or what procedure? :pray: :pray: :pray:

Could we say it works when the device is updated from 3.3 to 3.4 but not when it is directly flashed to 3.4?
Something to do with the renaming of the default user, perhaps?


I basically followed DrYak’s guide as in
https://together.jolla.com/question/209300/how-to-microg-in-sfos-31/ (see @razcampagne post above) but run into trouble with the enabling of the system package replacement (see section " Grant Signature Spoofing Permissions")

That is why I recommend opening the android settings via the terminal with

apkd-launcher com.android.settings

There you can proceed as written by DrYak:

  • from the main screen of Android settings app:
  • Apps & notifications - Permissions, default apps
  • (after the apps) “App permissions - Apps using Location, Microphone, Camera” ( ^- warning it’s not in the same place as on other ROMs, it’s not among the Advanced permissions )
  • (You arrive roughly at the screen that carmeloferso has shown here )
  • scroll down to the list of permission (the end should read “SMS”, “Storage”, “Telephone”, and…)
  • pick the last permission " enable system package replacement "
  • (You arrive at the second screen above )
  • Here you can grant the “enable system package replacement” permission, a.k.a “Signature Spoofing”:
  • FakeStore (make so the empty package seem to contain “com.android.vending” coming from the genuine Google’s Play Store, so that apps checking for that are kept happy)
  • microG Service Core (make so “com.google.android.gms” seems to be coming from the genuine Google Play Service)
  • Signature Spoofing Checker (if you installed this option. It makes the checker apps’ screen go green if the spoofing works)

BUT, I have to add that I did all that after a full factory reset just one day BEFORE (EA) was released, i.e still under

1 Like

I just looked into com.android.settings on my Xperia 10 and still can see everything that is needed to enable signature spoofing - but as I just said, I was happy to have enabled signature spoofig just one day before the release of

So maybe there is a problem now …

Thank you very much for your reply! :smiley:
I wanted to try to install a previous version again, on which spoofing worked and then update to, but fastboot mode doesn’t work for me…
I’ll have to buy another Xperia XA2 I’m afraid… :sob:

Do you mean can’t get “blue LED”? Sometimes it is the speed with which you push in USB-C when holding "volume down’ button in. Sometimes need to press and hold the power and the volume up button simultaneously until the device makes three vibrations if continually getting green LED.

1 Like

No no: the fact is that it turns blue, but from the terminal it gives me an error: Found 0 devices:
Incorrect number of connected devices. Make sure there is exactly one device connected in fastboot mode.

As not mentioned: with a USB 2.0 it works… :roll_eyes:
I try to flash, where spoofing worked and update to, and let you know.

Hopefully you can now get back to:

For me the “killer” upon is non-functioning GPS no matter how many satellites are in view usually 13 for some reason!

I’m also having issues getting Waze to work (no map tiles loading, and it says ‘Searching network…’ , although HERE WeGo works ok.

It can be done! By flashing, turning on spoofing regularly, and then updating to, the spoofing remains and everything works fine!!! :smiley: :clap:


I also have this problem, i think i’ll wait for it to be fixed rather than downgrading. Is it possible to mark this “i also have this problem” here on Sailfish OS Forum without creating a pointless reply?

Good luck, as until now I did not see that this is noted by Jolla as a problem at all.
Maybe it is an upgrade problem, maybe wrong execution of steps? But until now we also did not see any positive feedback where a user has spoofing enabled under a freshly flashed system, right?

No, not really. Only way to acknowledge is the like (heart) button. (which has only been pushed once as of writing this here)

I also have this problem on a freshly flashed 3.4 device. An XA2 Ultra single sim specifically. Seems like it’s not an adaptation-specific issue?

Random thought: would someone be willing to try the old method of enabling spoofing to see if that still works? I have a bunch of travel this week so I can’t.

Do you have a link to a tutorial for this? I’m willing to give it a shot.